Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 235118 - got the following info when I emerge openoffice
Summary: got the following info when I emerge openoffice
Status: VERIFIED INVALID
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Gentoo Linux bug wranglers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-08-18 15:44 UTC by Cao Jin
Modified: 2008-08-21 15:37 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Cao Jin 2008-08-18 15:44:48 UTC
I want to emerge openoffice, and there is 34 packages to be emerged ,and, there is nothing wrong with the first 33 packages ,but the last:app-office/openoffice-2.4.1 , I didn`t how to deal with it.The infomation are as follows:
emerge openoffice
Calculating dependencies... done!
>>> Verifying ebuild Manifests...

>>> Emerging (1 of 1) app-office/openoffice-2.4.1 to /
 * oox.2008-02-29.tar.bz2 RMD160 SHA1 SHA256 size ;-) ...                 [ ok ]
 * extras-2.tar.bz2 RMD160 SHA1 SHA256 size ;-) ...                       [ ok ]
 * ooo-build-2.4.1.8.tar.gz RMD160 SHA1 SHA256 size ;-) ...               [ ok ]
 * OOo_2.4.1_src_l10n.tar.bz2 RMD160 SHA1 SHA256 size ;-) ...             [ ok ]
 * libwps-0.1.2.tar.gz RMD160 SHA1 SHA256 size ;-) ...                    [ ok ]
 * libwpg-0.1.2.tar.gz RMD160 SHA1 SHA256 size ;-) ...                    [ ok ]
 * biblio.tar.bz2 RMD160 SHA1 SHA256 size ;-) ...                         [ ok ]
 * OOo_2.4.1_src_core.tar.bz2 RMD160 SHA1 SHA256 size ;-) ...             [ ok ]
 * lp_solve_5.5.0.10_source.tar.gz RMD160 SHA1 SHA256 size ;-) ...        [ ok ]
 * writerfilter.2008-02-29.tar.bz2 RMD160 SHA1 SHA256 size ;-) ...        [ ok ]
 * checking ebuild checksums ;-) ...                                      [ ok ]
 * checking auxfile checksums ;-) ...                                     [ ok ]
 * checking miscfile checksums ;-) ...                                    [ ok ]
 * checking OOo_2.4.1_src_core.tar.bz2 ;-) ...                            [ ok ]
 * checking ooo-build-2.4.1.8.tar.gz ;-) ...                              [ ok ]
 * checking extras-2.tar.bz2 ;-) ...                                      [ ok ]
 * checking biblio.tar.bz2 ;-) ...                                        [ ok ]
 * checking lp_solve_5.5.0.10_source.tar.gz ;-) ...                       [ ok ]
 * checking libwps-0.1.2.tar.gz ;-) ...                                   [ ok ]
 * checking libwpg-0.1.2.tar.gz ;-) ...                                   [ ok ]
 * checking oox.2008-02-29.tar.bz2 ;-) ...                                [ ok ]
 * checking writerfilter.2008-02-29.tar.bz2 ;-) ...                       [ ok ]
 * checking OOo_2.4.1_src_l10n.tar.bz2 ;-) ...                            [ ok ]
 *
 *  It is important to note that OpenOffice.org is a very fragile
 *  build when it comes to CFLAGS.  A number of flags have already
 *  been filtered out.  If you experience difficulty merging this
 *  package and use agressive CFLAGS, lower the CFLAGS and try to
 *  merge again. Also note that building OOo takes a lot of time and
 *  hardware ressources: 4-6 GB free diskspace and 256 MB RAM are
 *  the minimum requirements. If you have less, use openoffice-bin
 *  instead.
 *
 * Checking for at least 512MBytes RAM ...                                [ !! ]
 * Don't have at least 512MBytes RAM

 * Checking for at least 5120MBytes disk space at ${T} ...                [ ok ]

 * Bad things may happen! You may abort the build by pressing ctrl+c in
 * the next 15 seconds.
 *
 * To make this kind of warning a fatal error, add a line to /etc/make.conf
 * setting CHECKREQS_ACTION="error". To skip build requirements checking,
 * set CHECKREQS_ACTION="ignore".
 * Sorry, but openoffice does not support the LINGUAs: zh
 *  You are building with java-support disabled, this results in some
 *  of the OpenOffice.org functionality (i.e. help) being disabled.
 *  If something you need does not work for you, rebuild with
 *  java in your USE-flags.
 *
 *
 * ERROR: app-office/openoffice-2.4.1 failed.
 * Call stack:
 *                 ebuild.sh, line   49:  Called pkg_setup
 *   openoffice-2.4.1.ebuild, line  210:  Called built_with_use 'pkg_setup' 'pkg_setup'
 *             eutils.eclass, line 1729:  Called die
 * The specific snippet of code:
 *                                      die)   die "$PKG does not actually support the $1 USE flag!";;
 *  The die message:
 *   dev-lang/python-2.4.3-r4 does not actually support the threads USE flag!
 *
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/var/tmp/portage/app-office/openoffice-2.4.1/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/app-office/openoffice-2.4.1/temp/die.env'.
 *
!!! When you file a bug report, please include the following information:
GENTOO_VM=  CLASSPATH="" JAVA_HOME=""
JAVACFLAGS="" COMPILER=""
and of course, the output of emerge --info

emerge --info
Portage 2.1.4.4 (default-linux/x86/2007.0, gcc-4.1.1, glibc-2.5-r0, 2.6.25-gentoo-r6 i686)
=================================================================
System uname: 2.6.25-gentoo-r6 i686 Intel(R) Core(TM)2 Duo CPU     T7250  @ 2.00GHz
Timestamp of tree: Thu, 14 Aug 2008 13:45:01 +0000
ccache version 2.4 [enabled]
app-shells/bash:     3.2_p17-r1
dev-lang/python:     2.4.3-r4
dev-python/pycrypto: 2.0.1-r6
dev-util/ccache:     2.4-r7
sys-apps/baselayout: 1.12.9
sys-apps/sandbox:    1.2.18.1-r2
sys-devel/autoconf:  2.13, 2.61
sys-devel/automake:  1.4_p6, 1.7.9-r1, 1.9.6-r2, 1.10.1
sys-devel/binutils:  2.16.1-r3
sys-devel/gcc-config: 1.3.14
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.17-r2
ACCEPT_KEYWORDS="x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O3 -march=i686 -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config"
CONFIG_PROTECT_MASK="/etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/revdep-rebuild /etc/terminfo"
CXXFLAGS="-O3 -march=i686 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="ccache distlocks metadata-transfer sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="ftp://gentoo.anheng.com.cn/gentoo http://mirror.averse.net/pub/gentoo/ http://61.135.158.199 http://ftp.isu.edu.tw/pub/Linux/Gentoo ftp://ftp.isu.edu.tw/pub/Linux/Gentoo http://ftp.twaren.net/Linux/Gentoo/ ftp://ftp.twaren.net/Linux/Gentoo/ http://ftp.ncnu.edu.tw/Linux/Gentoo/ ftp://ftp.ncnu.edu.tw/Linux/Gentoo/ http://ftp.cs.pu.edu.tw/Linux/Gentoo/ ftp://ftp.cs.pu.edu.tw/Linux/Gentoo/ http://gentoo.cs.nctu.edu.tw/gentoo/ ftp://gentoo.cs.nctu.edu.tw/gentoo/ "
LANG="en_US.utf8"
LINGUAS="zh zh_CN zh_TW"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://mirror.averse.net/gentoo-portage"
USE="X acl alsa berkdb cdr cjk cli cracklib crypt cups dri dvd fortran gdbm gpm iconv ipv6 isdnlog kde midi mmx mudflap ncurses nls nptl nptlonly opengl openmp pam pcre pppd qt3 qt3support qt4 readline reflection session spl sse sse2 ssl tcpd truetype unicode utf8 x86 xorg zlib" ALSA_CARDS="ens1371" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="zh zh_CN zh_TW" USERLAND="GNU" VIDEO_CARDS="vesa vga vmware"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, LDFLAGS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, PORTDIR_OVERLAY



Reproducible: Always



Expected Results:  
with i could emerge openoffice successful,then I can experence Linux as Windows
Comment 1 Cao Jin 2008-08-18 15:52:13 UTC
BTW, I am a gentoo user from China mainland
Comment 2 Cao Jin 2008-08-18 16:02:29 UTC
Checking for at least 512MBytes RAM ...                                [ !!
]
 * Don't have at least 512MBytes RAM

Does that mean I must have 512M RAM free? because I have 512M ram now
and by the way too, I am using gentoo in vmware
cat /proc/meminfo
MemTotal:       516036 kB
MemFree:         30132 kB
Buffers:         96540 kB
Cached:         302392 kB
SwapCached:        644 kB
Active:         322252 kB
Inactive:       116160 kB
HighTotal:           0 kB
HighFree:            0 kB
LowTotal:       516036 kB
LowFree:         30132 kB
SwapTotal:      500368 kB
SwapFree:       499724 kB
Dirty:               0 kB
Writeback:           0 kB
AnonPages:       38836 kB
Mapped:          30552 kB
Slab:            37508 kB
SReclaimable:    32384 kB
SUnreclaim:       5124 kB
PageTables:       1048 kB
NFS_Unstable:        0 kB
Bounce:              0 kB
CommitLimit:    758384 kB
Committed_AS:    61176 kB
VmallocTotal:   507896 kB
VmallocUsed:      6284 kB
VmallocChunk:   501448 kB
Comment 3 Jeremy Olexa (darkside) (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2008-08-18 16:20:34 UTC
(In reply to comment #0)

> support the $1 USE flag!";;
>  *  The die message:
>  *   dev-lang/python-2.4.3-r4 does not actually support the threads USE flag!
>  *

Upgrade python then emerge openoffice. The version 2.4.3-r4 is not even in the tree anymore and the error message is correct because that version doesn't have threads in its USE flags. You may want to re-read the portage man page and use the -avuDN options to emerge. ie. emerge -avuDN world. This will upgrade deps of packages you have installed.
Comment 4 Jeremy Olexa (darkside) (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2008-08-18 16:22:14 UTC
(In reply to comment #2)
> Checking for at least 512MBytes RAM ...                                [ !!
> ]
>  * Don't have at least 512MBytes RAM

You may want to use the openoffice-bin package instead.
Comment 5 Cao Jin 2008-08-21 15:37:25 UTC
Thank you  Jeremy Olexa, thanks for you helpful infomation , i got the problem resolved
I am a linux freshman,I use it just it just several months ,and for job reason, gentoo is my first distro