Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 234337 - media-video/mplayer-1.0_rc2_p26753-r1 : gmplayer doesn't stop xscreensaver
Summary: media-video/mplayer-1.0_rc2_p26753-r1 : gmplayer doesn't stop xscreensaver
Status: RESOLVED UPSTREAM
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: x86 Linux
: High minor (vote)
Assignee: media-video herd
URL: http://bugs.archlinux.org/task/12930
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-08-09 22:03 UTC by Maxx Twayne
Modified: 2009-04-30 21:44 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Maxx Twayne 2008-08-09 22:03:02 UTC
In my gui.conf for gmplayer, i set the stopxscreensaver = "yes" to stop xscreensaver. 
It used to work, but it's no longer working.

I can avoid this by killing xscreensaver before using gmplayer.

Reproducible: Always

Actual Results:  
xscreensaver starts after a few minutes of media playing without using the computer.

Expected Results:  
The xscreensaver should be disabled while playing media.

my gui.conf :

enable_audio_equ = "no"
vo_driver = "xv"
vo_panscan = "0.100000"
vo_doublebuffering = "yes"
vo_direct_render = "no"
v_framedrop = "2"
v_flip = "0"
v_ni = "no"
v_idx = "-1"
vf_pp = "yes"
vf_autoq = "0"
vf_lavc = "no"
ao_driver = "alsa"
ao_volnorm = "yes"
softvol = "no"
ao_surround = "no"
ao_extra_stereo = "no"
ao_extra_stereo_coefficient = "1.000000"
dvd_device = "/dev/hdc"
cdrom_device = "/dev/cdrom"
osd_level = "1"
sub_auto_load = "yes"
sub_unicode = "no"
sub_pos = "100"
sub_overlap = "no"
font_factor = "0.750000"
font_name = "sans-serif"
font_text_scale = "5.000000"
font_osd_scale = "6.000000"
font_blur = "2.000000"
font_outline = "2.000000"
font_autoscale = "3"
cache = "yes"
cache_size = "2048"
playbar = "yes"
load_fullscreen = "no"
show_videowin = "no"
stopxscreensaver = "yes"
autosync = "no"
autosync_size = "0"
gui_skin = "default"
gui_save_pos = "yes"
gui_main_pos_x = "1627"
gui_main_pos_y = "817"
gui_video_out_pos_x = "1280"
gui_video_out_pos_y = "0"


Portage 2.1.4.4 (default/linux/x86/2008.0/desktop, gcc-4.1.2, glibc-2.6.1-r0, 2.6.25-gentoo-r7 i686)
=================================================================
System uname: 2.6.25-gentoo-r7 i686 Intel(R) Core(TM)2 CPU 6600 @ 2.40GHz
Timestamp of tree: Sat, 02 Aug 2008 23:04:01 +0000
ccache version 2.4 [enabled]
app-shells/bash:     3.2_p33
dev-java/java-config: 1.3.7, 2.1.6
dev-lang/python:     2.4.4-r14, 2.5.2-r6
dev-python/pycrypto: 2.0.1-r6
dev-util/ccache:     2.4-r7
sys-apps/baselayout: 1.12.11.1
sys-apps/sandbox:    1.2.18.1-r2
sys-devel/autoconf:  2.13, 2.61-r2
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.1
sys-devel/binutils:  2.18-r3
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   1.5.26
virtual/os-headers:  2.6.23-r3
ACCEPT_KEYWORDS="x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=nocona -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/revdep-rebuild /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-O2 -march=nocona -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="ccache distlocks metadata-transfer sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://linux.rz.ruhr-uni-bochum.de/download/gentoo-mirror/ http://cudlug.cudenver.edu/gentoo/ http://gentoo.tiscali.nl/"
LANG="fr_FR.UTF-8"
LDFLAGS="-Wl,-O1"
LINGUAS="fr"
MAKEOPTS="-j4"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://puffy/gentoo-portage"
USE="X a52 aac acl acpi alsa apache2 arts asf berkdb bluetooth branding bzip2 cairo cdr cli cracklib crypt cups dbus dri dvd dvdr dvdread eds emboss encode esd evo exif fam ffmpeg firefox flac fortran gdbm gif gnome gphoto2 gpm gstreamer gtk hal iconv ipod ipv6 isdnlog java jpeg kde kerberos ldap libnotify lm_sensors mad matroska midi mikmod mmx mp3 mpeg mplayer mudflap ncurses nfs nls nptl nptlonly nsplugin ogg opengl openmp pam pcre pdf perl png ppds pppd python qt3 qt3support qt4 quicktime readline real reflection samba sdl session spell spl sse sse2 ssl startup-notification svg sysfs tcpd theora tiff truetype unicode usb v4l v4l2 vorbis win32codecs x86 xine xinerama xml xorg xv xvid zlib" ALSA_CARDS="hda-intel" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic auth_digest authn_anon authn_dbd authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock dbd deflate dir disk_cache env expires ext_filter file_cache filter headers ident imagemap include info log_config logio mem_cache mime mime_magic negotiation proxy proxy_ajp proxy_balancer proxy_connect proxy_http rewrite setenvif so speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="fr" USERLAND="GNU" VIDEO_CARDS="nvidia v4l vesa"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, PORTDIR_OVERLAY
Comment 1 Slava Gorbunov 2008-08-13 15:46:12 UTC
"plain" mplayer doesn't stop xscreensaver, too. I've tried to specify 'stop-xscreensaver' in .mplayer/config, /etc/mplayer/mplayer.conf, and on command line without any effect. Both versions 1.0_rc2_p26753-r1 and 1.0_rc2_p27120 built with USE=xscreensaver have this bug.
Comment 2 Renato Alves 2008-10-08 21:21:44 UTC
I will also add 1.0_rc2_p27458 to the list of non working versions.

I have the same problem here with plain mplayer. Neither setting the option in the config file, nor -stop-xscreensaver on start works.

mplayer has +xscreensaver flag
current xscreensaver version 5.05.

Now testing media-video/mplayer-1.0_rc2_p27725-r1 and x11-misc/xscreensaver-5.07
Comment 3 dnw.ftw 2008-10-18 13:18:52 UTC
Still not working with the following packages:

media-video/mplayer-1.0_rc2_p27725-r1
x11-misc/xscreensaver-5.07

mplayer does indeed claim to detect the xscreensaver API's during configure, but it says nothing about xscreensaver when launching mplayer with -stop-xscreensaver, even with -v -v (and the screenserver kicks in after awhile, with mplayer not paused.)

Note: I did compile mplayer with the xscreensaver USE-flag.
Comment 4 Samuli Suominen (RETIRED) gentoo-dev 2009-04-30 21:44:51 UTC
This is an upstream issue. MPlayer now insists that screensavers use XSuspendScreensaver or XResetScreensaver, which xscreensaver apparently doesn't. Specialized support for screensavers not using these methods has been dropped from recent MPlayer versions.

See -heartbeat-cmd in mplayer(1) for a workaround.

For reference from http://www.jwz.org/xscreensaver/faq.html#dvd
If you are using a recent version of MPlayer, put this in your ~/.mplayer/config file:

heartbeat-cmd="xscreensaver-command -deactivate"