Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 234281 - net-misc/curl-7.18.2 tests 513 and 514 fail when -march=nocona is in CFLAGS using gcc 4.1.2
Summary: net-misc/curl-7.18.2 tests 513 and 514 fail when -march=nocona is in CFLAGS u...
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Unspecified (show other bugs)
Hardware: AMD64 Linux
: High minor (vote)
Assignee: Daniel Black (RETIRED)
Depends on:
Reported: 2008-08-08 23:58 UTC by Nathanael Hoyle
Modified: 2010-01-15 13:53 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Nathanael Hoyle 2008-08-08 23:58:26 UTC
When FEATURES="test" is enabled, the net-misc/curl package performs an extensive set of tests as part of the emerge process.  Tests 513 and 514 fail from this suite (blocking the emerge, so long as FEATURES="test" is not removed or CFLAGS altered) when -march=nocona is set in CFLAGS.  I do indeed have a nocona architecture processor, it is a Core 2 Quad Q9450.  Other software seemingly works fine here.

I see three possible issues, which go in different categories, hence the "unknown" category I am filing this in:

1) curl is not 64-bit "safe" in some sections and has problems with the native register size being larger than expected.
2) curl test case bug, similarly, expects output based on a 32-bit environment
3) gcc bug (I hope not) in generation of code for the nocona arch, correctly detected by the test suite.

I encountered this first using CFLAGS of "-O2 -march=nocona -pipe", which failed.  I tried "-O0" (no optimization, no arch target) and that worked.  I then tried "-O2 -pipe" and that also worked, narrowing the issue down to the -march flag.

Reproducible: Always

Steps to Reproduce:
1.Enable FEATURE="test"
2.Include "-march=nocona" in CFLAGS (only on the appropriate processor of course)
3.emerge net-misc/curl-7.18.2

Actual Results:  
Tests 513 and 514 fail, emerge aborts.

Expected Results:  
All tests complete successfully, package installs.

Here's emerge --info:

 $ emerge --info
Portage (default/linux/amd64/2008.0, gcc-4.1.2, glibc-2.6.1-r0, 2.6.25-gentoo-r7-nhoyle x86_64)
System uname: 2.6.25-gentoo-r7-nhoyle x86_64 Intel(R) Core(TM)2 Quad CPU Q9450 @ 2.66GHz
Timestamp of tree: Fri, 08 Aug 2008 21:45:01 +0000
ccache version 2.4 [enabled]
app-shells/bash:     3.2_p33
dev-lang/python:     2.5.2-r6
dev-util/ccache:     2.4-r7
sys-devel/autoconf:  2.13, 2.61-r2
sys-devel/automake:  1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.1
sys-devel/binutils:  2.18-r3
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   1.5.26
virtual/os-headers:  2.6.23-r3
CFLAGS="-march=nocona -O2 -pipe"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/kde/4.0/env /usr/kde/4.0/share/config /usr/kde/4.0/shutdown /usr/share/config"
CONFIG_PROTECT_MASK="/etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/revdep-rebuild /etc/terminfo /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-march=nocona -O2 -pipe"
FEATURES="ccache distlocks metadata-transfer sandbox sfperms strict test unmerge-orphans userfetch"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
USE="X acl acpi alsa amd64 arts artswrappersuid audiofile authdaemond berkdb bzip2 cairo cddb cli cracklib crypt cups dbus dri dv dvdread encode firefox flac fontconfig fortran gdbm gif gnutls gphoto2 gpm gtk hddtemp iconv imlib isdnlog jpeg kde lm_sensors midi mjpeg mmap mmx mmxext mng mp3 mpeg mplayer mudflap multilib ncurses nntp nptl nptlonly offensive ogg opengl openmp openntpd oss pam pcre pdf perl pg-intdatetime png povray pppd pulseaudio python qt3 qt4 quicktime readline reflection session smp speex spl sse sse2 ssl ssse3 sysfs test tetex theora threads tiff truetype unicode vim-syntax vorbis x264 xine xorg xprint xscreensaver xv xvid yv12 zlib" ALSA_CARDS="oxygen" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CAMERAS="canon" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" USERLAND="GNU" VIDEO_CARDS="nv nvidia"

I am not attaching the full build log, because it does not contain detailed technical information regarding the test failures, and is therefore not useful.  It only lists the tests which failed.
Comment 1 Joshua Doll 2009-02-16 20:16:36 UTC
I ran across this bug to in curl-7.19.3, I don't if this adds anything but setting -mtune=nocona allowed the tests to complete. 
Comment 2 Daniel Black (RETIRED) gentoo-dev 2009-03-08 01:25:12 UTC
upstream as per url
Comment 3 n.reyrolle 2010-01-15 13:53:25 UTC
Unfortunately, the upstream bug (I guess was closed.

And I got the bug on x86 with curl-7.18.7 (~x86 in portage for now).