Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 23419 - ebuild: plasticfs
Summary: ebuild: plasticfs
Status: RESOLVED WONTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High enhancement (vote)
Assignee: x86-kernel@gentoo.org (DEPRECATED)
URL: http://plasticfs.sourceforge.net/
Whiteboard:
Keywords: EBUILD
Depends on:
Blocks:
 
Reported: 2003-06-24 16:26 UTC by Sean P. Kane
Modified: 2004-04-09 07:38 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
The PlasticFS Ebuild (plasticfs-1.7.ebuild,902 bytes, text/plain)
2003-06-24 16:27 UTC, Sean P. Kane
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Sean P. Kane 2003-06-24 16:26:41 UTC
The Plastic File System 1.7

plastic, adj. Capable of being shaped or formed, malleable.

The Plastic File System is an LD_PRELOAD module for manipulating what the file
system looks like for programs. This allows virtual file systems to exist in
user space, without kernel hacks or modules. 

Reproducible: Always
Steps to Reproduce:





It would be nice to see this added as sys-apps/plasticfs or some such.
Comment 1 Sean P. Kane 2003-06-24 16:27:17 UTC
Created attachment 13803 [details]
The PlasticFS Ebuild
Comment 2 Michal Januszewski (RETIRED) gentoo-dev 2004-02-17 06:44:00 UTC
Seems to be an interesting app. The only problem is it won't work with glibc-2.2 and 2.3, unless we have a special version of glibc prepared (see http://sourceforge.net/mailarchive/forum.php?thread_id=2735794&forum_id=26320). Any comments on this?
Comment 3 Jason Cox (RETIRED) gentoo-dev 2004-03-29 12:50:48 UTC
I'd opt against this one. The changes to glibc are not something I'd really like to toy with to make this work. It's an intersting iea, but needs to be reworked some.
Comment 4 Jason Cox (RETIRED) gentoo-dev 2004-04-08 19:06:19 UTC
Any more updates on this? Perhaps the author of this bug report could comment. What does the rest of the kernel team think of this?
Comment 5 Jason Cox (RETIRED) gentoo-dev 2004-04-09 07:38:01 UTC
Plasticfs is not something which justifies toying with glibc. It appears the author lost interest, so I'm closing and marking won't fix.