Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 234108 - meld [Error] - No module named pygtk
Summary: meld [Error] - No module named pygtk
Status: VERIFIED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-08-06 17:07 UTC by Joseph
Modified: 2008-08-07 16:01 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Joseph 2008-08-06 17:07:24 UTC
Application "meld" is not working on x86 nor on amd64

On x86 when I try to start it I get:
meld
No module named pygtk
Meld requires pygtk2.6.0 or higher.

I have dev-python/pygtk-2.12.0 installed.
I recompiled pygtk and meld; revdep-rebuild is not showing anything to rebuild but I still can not start meld. 

on amd64 I get an error
ImportError: could not import bonobo.ui

#Joseph

Reproducible: Always




emerge --info
Portage 2.1.4.4 (default/linux/x86/2008.0/desktop, gcc-4.1.2, glibc-2.6.1-r0, 2.6.23-gentoo-r8 i686)
=================================================================
System uname: 2.6.23-gentoo-r8 i686 AMD Athlon(TM) XP 2500+
Timestamp of tree: Mon, 04 Aug 2008 14:36:01 +0000
distcc 2.18.3 i686-pc-linux-gnu (protocols 1 and 2) (default port 3632) [enabled]
ccache version 2.4 [enabled]
app-shells/bash:     3.2_p33
dev-java/java-config: 1.3.7, 2.1.6
dev-lang/python:     2.5.2-r6
dev-util/ccache:     2.4-r7
sys-apps/baselayout: 1.12.11.1
sys-apps/sandbox:    1.2.18.1-r2
sys-devel/autoconf:  2.13, 2.61-r2
sys-devel/automake:  1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.1
sys-devel/binutils:  2.18-r3
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   1.5.26
virtual/os-headers:  2.6.23-r3
ACCEPT_KEYWORDS="x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=athlon-xp -fomit-frame-pointer"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/lib/fax /usr/share/config /var/lib/hsqldb /var/spool/fax/etc"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/terminfo /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-O2 -march=athlon-xp -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
FEATURES="ccache collision-protect distcc distlocks metadata-transfer parallel-fetch sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://distro.ibidio.org/pub/linux/distributions/gentoo/ ftp:///ftp-stud.fht-esslingen.de/pub/Mirrors/gentoo/ http://gentoo.osuosl.org/ http://mirror.datapipe.net/gentoo http://gentoo.binarycompass.org"
LANG="en_US.UTF-8"
LC_ALL="en_US.UTF-8"
LDFLAGS="-Wl,-O1"
LINGUAS="en en_US"
MAKEOPTS="-j4"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://10.0.0.101/gentoo-portage"
USE="X acl acpi alsa apache2 berkdb bluetooth branding bzip2 cairo cdr cli cracklib crypt cups dbus dri dvd dvdr dvdread eds emboss encode esd evo fam firefox foomaticdb fortran gdbm gif gpm gstreamer gtk hal iconv ipv6 isdnlog java jpeg kde kerberos ldap libnotify mad midi mikmod mp3 mpeg mudflap mysql ncurses nls nptl nptlonly ogg opengl openmp pam pcre pdf perl png ppds pppd python qt3 qt3support quicktime readline reflection scanner sdl session spell spl ssl startup-notification svg sysfs tcpd tetex tiff truetype type1 unicode usb vorbis win32codecs x86 xml xorg xv zlib" ALSA_CARDS="via82xx" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic auth_digest authn_anon authn_dbd authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock dbd deflate dir disk_cache env expires ext_filter file_cache filter headers ident imagemap include info log_config logio mem_cache mime mime_magic negotiation proxy proxy_ajp proxy_balancer proxy_connect proxy_http rewrite setenvif so speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en en_US" USERLAND="GNU" VIDEO_CARDS="nv vesa fbdev"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, PORTDIR_OVERLAY
Comment 1 Joseph 2008-08-06 20:27:45 UTC
I forgot to mention: meld-1.1.5.1-r1 (stable) and meld-1.2 (unstable)
act the same way.
Comment 2 Gilles Dartiguelongue gentoo-dev 2008-08-06 21:30:07 UTC
I guess you ran python-updater before getting rid of python 2.4 ?
Comment 3 Joseph 2008-08-06 22:09:57 UTC
I did not run any python-updater (doesn't it run by itself).
I have only python 2.5 installed

equery l python
[ Searching for package 'python' in all categories among: ]
 * installed packages
[I--] [  ] app-admin/python-updater-0.5 (0)
[I--] [  ] dev-lang/python-2.5.2-r6 (2.5)
[I--] [  ] dev-python/gnome-python-2.20.1 (2)

Though, I've found a solution for "x86"
emerge -1 pygobject pygtk pycairo
it fixes the problem for x86; thanks for help to Arfrever

But AMD64 problem is still there.
When I try to open a file on AMD64 I get:

ImportError: could not import bonobo.ui
Traceback (most recent call last):
  File "/usr/bin/meld", line 107, in <module>
    meldapp.main()
  File "/usr/lib64/meld/meldapp.py", line 876, in main
    doc.set_location( os.path.dirname(a) )
  File "/usr/lib64/meld/vcview.py", line 198, in set_location
    self.fileentry.gtk_entry().set_text(location)
AttributeError: '__main__.GnomeFileEntry' object has no attribute 'gtk_entry'

Comment 4 Mart Raudsepp gentoo-dev 2008-08-06 22:17:42 UTC
(In reply to comment #3)
> I did not run any python-updater (doesn't it run by itself).
> I have only python 2.5 installed

Must be recent, as you are running stable x86 per emerge --info, and I assume you didn't get it differently earlier.

When you installed it, it told you this:

If you have just upgraded from an older version of python you will
need to run:

/usr/sbin/python-updater

This will automatically rebuild all the python dependent modules
to run with python-2.5.

------

Please do what it told you to do :)
You can not loose this kind of information in lots of upgrade spam thanks to ELOG feature imporemevant of (already stabilized long ago) portage, unless it's configured wrong, so you should be seeing them in ways that are configured for you and you should follow them.
Comment 5 Joseph 2008-08-06 22:35:50 UTC
running: /usr/sbin/python-updater
doesn't do anything it exit cleanly
so I must have run python-updater :-)
Comment 6 Gilles Dartiguelongue gentoo-dev 2008-08-06 22:49:07 UTC
either that or it fails because there is no more python to update from (I don't know I didn't check the code). Please list what's under /usr/lib*/python2.4/, if there is anything more than 3 files then you probably need to recompile some packages.
Comment 7 Joseph 2008-08-06 23:00:09 UTC
I is showing only one directory under (no files)
# ll /usr/lib*/python2.4/
total 4
drwxr-xr-x 14 root root 4096 2008-08-06 15:06 site-packages

but that directory: "site-packages" contains many files:
drwxr-xr-x  2 root root    4096 2007-03-02 16:50 antlr
-rw-r--r--  1 root root    2960 2008-02-08 13:07 cracklibmodule.a
-rwxr-xr-x  1 root root     940 2008-02-08 13:07 cracklibmodule.la
-rwxr-xr-x  1 root root    5356 2008-02-08 13:07 cracklibmodule.so
-rw-r--r--  1 root root   15061 2008-04-19 09:12 drv_libxml2.py
-rw-r--r--  1 root root   10964 2008-06-20 20:50 drv_libxml2.pyc
-rw-r--r--  1 root root   10964 2008-06-20 20:50 drv_libxml2.pyo
-rw-r--r--  1 root root   76894 2008-06-20 20:36 fetchmailconf.py
-rw-r--r--  1 root root   71030 2008-06-20 20:50 fetchmailconf.pyc
-rw-r--r--  1 root root   71030 2008-06-20 20:50 fetchmailconf.pyo
-rw-r--r--  1 root root    6240 2008-06-20 20:50 _gamin.a
-rwxr-xr-x  1 root root     827 2008-06-20 20:50 _gamin.la
-rw-r--r--  1 root root    6954 2008-06-20 20:50 gamin.py
-rw-r--r--  1 root root    8663 2008-06-20 20:50 gamin.pyc
-rw-r--r--  1 root root    8663 2008-06-20 20:50 gamin.pyo
-rwxr-xr-x  1 root root    9644 2008-06-20 20:50 _gamin.so
drwxr-xr-x  2 root root    4096 2008-03-29 02:12 gsf
drwxr-xr-x  2 root root    4096 2008-01-21 13:15 higwidgets
drwxr-xr-x  2 root root    4096 2007-05-11 21:30 java_config
-rw-r--r--  1 root root  617440 2008-01-05 18:33 _lcms.a
-rwxr-xr-x  1 root root     848 2008-01-05 18:33 _lcms.la
-rw-r--r--  1 root root   95614 2008-01-05 18:33 lcms.py
-rw-r--r--  1 root root   85353 2008-01-21 13:15 lcms.pyc
-rw-r--r--  1 root root   85353 2008-01-21 13:15 lcms.pyo
-rwxr-xr-x  1 root root 1504884 2008-01-05 18:33 _lcms.so
drwxr-xr-x  2 root root    4096 2007-03-14 19:09 libsvn
-rw-r--r--  1 root root  365018 2008-04-19 09:12 libxml2mod.a
-rwxr-xr-x  1 root root     855 2008-04-19 09:12 libxml2mod.la
-rwxr-xr-x  1 root root  281932 2008-04-19 09:12 libxml2mod.so
-rw-r--r--  1 root root  336589 2008-04-19 09:12 libxml2.py
-rw-r--r--  1 root root  416582 2008-06-20 20:50 libxml2.pyc
-rw-r--r--  1 root root  416582 2008-06-20 20:51 libxml2.pyo
-rwxr-xr-x  1 root root   11780 2008-02-08 13:08 magic.so
drwxr-xr-x 11 root root    4096 2006-06-11 15:49 mx
drwxr-xr-x  6 root root    4096 2007-10-26 19:16 Numeric
-rw-r--r--  1 root root       8 2007-10-26 19:15 Numeric.pth
drwxr-xr-x  9 root root    4096 2006-06-11 15:49 OpenGL
lrwxrwxrwx  1 root root      13 2008-03-20 19:22 pygtk.pth -> pygtk.pth-2.0
lrwxrwxrwx  1 root root      12 2008-03-20 19:22 pygtk.py -> pygtk.py-2.0
drwxr-xr-x  2 root root    4096 2007-11-20 14:49 samba
-rwxr-xr-x  1 root root   27820 2008-03-16 21:57 _snackmodule.so
-rwxr-xr-x  1 root root   27959 2008-03-16 21:57 snack.py
-rw-r--r--  1 root root   34778 2008-06-20 20:50 snack.pyc
-rw-r--r--  1 root root   34778 2008-06-20 20:51 snack.pyo
drwxr-xr-x  2 root root    4096 2007-03-14 19:09 svn
drwxr-xr-x  2 root root    4096 2008-01-21 13:15 zenmapCore
drwxr-xr-x  2 root root    4096 2008-01-21 13:15 zenmapGUI

Comment 8 Gilles Dartiguelongue gentoo-dev 2008-08-06 23:09:26 UTC
yep that's what I wanted, now run qfile (portage-utils) or equery belongs (gentoolkit) on each files (not the .pyc or .pyo) to find out which package it comes from and re-emerge it.
Comment 9 Joseph 2008-08-07 01:05:56 UTC
Thank you for your help; I'm almost there.
I've done as you suggested but I'm left with only few directories:

# ll /usr/lib*/python2.4/site-packages
total 4
drwxr-xr-x 2 root root 4096 2007-05-11 21:30 java_config
lrwxrwxrwx 1 root root   13 2008-03-20 19:22 pygtk.pth -> pygtk.pth-2.0
lrwxrwxrwx 1 root root   12 2008-03-20 19:22 pygtk.py -> pygtk.py-2.0

directory: java_config contains all bnuch of files that are belong to file: java-config; I recompile java-config but that directory doesn't go away.
I think the reason is that java-config is linked against: python2.4 & python2.5

dev-java/java-config (/usr/lib/python2.4/site-packages/java_config/__init__.py)
dev-java/java-config (/usr/lib/python2.5/site-packages/java_config_2/__init__.py)

What to do with it and the two linked files:
pygtk.pth -> pygtk.pth-2.0
pygtk.py -> pygtk.py-2.0
Comment 10 Joseph 2008-08-07 04:55:36 UTC
SOLVED!

removing java-config and re-emerging it solved the problem with double linking.
Though,  I still don't know what to do with these two linked files:
pygtk.pth -> pygtk.pth-2.0
pygtk.py -> pygtk.py-2.0
Comment 11 Gilles Dartiguelongue gentoo-dev 2008-08-07 07:07:58 UTC
you can just remove them, these are generated by the ebuild but never cleaned up (or at least not for other python installations), I'll look into fixing the ebuild.
Comment 12 Joseph 2008-08-07 16:01:49 UTC
Thank you for all your help. 
Without your input I would not be able to fix this problem.   I have three systems and all with the same problem, I don't remember if I run python-updater or not; I usually read through most of the important notes and have even PORTAGE_ELOG_CLASSES="info warn error log" sending email to me so I can not explain how it had happen.   There is a possibility that if there were many updates I have a tendency read it fast and it didn't catch my attention :-/

Anyhow, I think I'm not the only one with this problem :-/  I think it is spread wider that we might think.  If somebody, that reports any strange problem like me run-onto a good guy like you, who can quickly trouble shoot the problem it will be fix in no time but not everybody is so lucky like me :-)
So I think for the future python updates I would suggest the ebuild after finishing compiling stop and exit with a WARNING sign + message explaining what to do, similar like "emerge --depclean generates.

In addition I think that this problem generates considerable amount of headache for many users who reports problem on the forum and/or reporting bugs, applying simple solution like I did "emerge -1 ...." this is a "band aid" it is not a solution to fix the real problem.  
So to fix it I think it would be wise to make some kind of python-updater-ebuild that will go through those directories on every Gentoo system generates list of files that needs to be rebuild and do it without user knowing it.  

If we don't do it the problem will get worse and all we see are a negative comments about Gentoo that it is disintegrating, people are frustrated as they don't know how to fix it, others can not help them as not everybody is aware of this potential problem.

Thanks again for all your help :-)