Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 233941 - mrxvt not usable, complains "Unknown colorls variable `rs'."
Summary: mrxvt not usable, complains "Unknown colorls variable `rs'."
Status: RESOLVED CANTFIX
Alias: None
Product: Gentoo/Alt
Classification: Unclassified
Component: Prefix Support (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Gentoo non-Linux Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-08-05 06:52 UTC by Rabbe Fogelholm
Modified: 2008-08-12 07:53 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Rabbe Fogelholm 2008-08-05 06:52:31 UTC
The mrxvt application can be emerged in prefix portage. However, it comes up with a single tab containing the text

Unknown colorls variable `rs'.

Process exited normally with status 1. Press any key to close the tab.

When a key is pressed the application exits with status 0. There are no messages in the console window from which mrxvt was launched.

The output of `emerge --info' is:

Portage 2.2.00.11322-prefix (default-prefix/linux/x86, gcc-4.2.4, unavailable, 2.6.16.53-0.16-smp i686)
=================================================================
System uname: Linux-2.6.16.53-0.16-smp-i686-Intel-R-_Core-TM-2_CPU_6600_@_2.40GHz-with-SuSE-10-i586
Timestamp of tree: Tue, 05 Aug 2008 00:41:32 +0000
ccache version 2.4 [disabled]
app-shells/bash:     3.2_p39
dev-java/java-config: 1.3.7-r00.1, 2.1.6-r1
dev-lang/python:     2.5.2-r7
sys-apps/sandbox:    1.2.17
sys-devel/autoconf:  2.13, 2.61-r2
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.1-r1
sys-devel/binutils:  2.18.50.0.7
sys-devel/gcc-config: 1.4.0-r04.5
sys-devel/libtool:   1.5.26
ACCEPT_KEYWORDS="~x86-linux"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/revdep-rebuild /etc/terminfo"
CXXFLAGS="-O2 -pipe"
DISTDIR="/local/tmp/nightly/2008-08-05/usr/portage/distfiles"
EPREFIX="/local/tmp/nightly/2008-08-05"
FEATURES="collision-protect distlocks parallel-fetch preserve-libs sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://mirror.gentoo.no/ http://mirror.qubenet.net/mirror/gentoo/ http://mirror.muntinternet.net/pub/gentoo/ http://ftp.linux.ee/pub/gentoo/distfiles/ http://ftp.snt.utwente.nl/pub/os/linux/gentoo"
LANG="en_US"
LDFLAGS=""
MAKEOPTS="-j2"
PKGDIR="/local/tmp/nightly/2008-08-05/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/local/scratch"
PORTDIR="/local/tmp/nightly/2008-08-05/usr/portage"
SYNC="rsync://rsync.prefix.freens.org/gentoo-portage-prefix"
USE="X cracklib iconv midi mudflap ncurses nls openmp prefix readline ssl unicode x86 zlib" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" USERLAND="GNU"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, LINGUAS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, PORTDIR_OVERLAY
Comment 1 Jeremy Olexa (darkside) (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2008-08-05 14:32:42 UTC
Works for me on amd64-linux.

I have seen this before when the coreutils version on the host doesn't match the coreutils version in prefix. dircolors cannot process etc/DIR_COLORS or .dir_colors or something weird like that. Hence, http://overlays.gentoo.org/proj/alt/changeset/25749 awhile back.
Comment 2 Fabian Groffen gentoo-dev 2008-08-11 15:54:53 UTC
Hmmm, I can't reproduce this either on Darwin.  It just works fine here.  If you have any clues like a "weird" prompt or environment, let us know.
Comment 3 Rabbe Fogelholm 2008-08-12 06:47:17 UTC
Some quick observations:

1. No change in behaviour since the problem was first reported.

2. `which dircolors' reports the prefix version of dircolors.

3. If I do `dircolors -b >cmds.sh' and then `source cmds.sh' and then `mrxvt' I get the error message "Process exited normally with status 1. Press any key to close tab".

4. If I edit cmds.sh, dropping the very first definition which is "rs=0", redo `source cmds.sh' and retry `mrxvt' then I get a usable mrxvt instance!

The output of `dircolors -b' for reference:

LS_COLORS='rs=0:di=01;34:ln=01;36:pi=40;33:so=01;35:do=01;35:bd=40;33;01:cd=40;33;01:or=01;05;37;41:mi=01;05;37;41:su=37;41:sg=30;43:tw=30;42:ow=34;42:st=37;44:ex=01;32:*.tar=01;31:*.tgz=01;31:*.arj=01;31:*.taz=01;31:*.lzh=01;31:*.lzma=01;31:*.zip=01;31:*.z=01;31:*.Z=01;31:*.dz=01;31:*.gz=01;31:*.bz2=01;31:*.bz=01;31:*.tbz2=01;31:*.tz=01;31:*.deb=01;31:*.rpm=01;31:*.jar=01;31:*.rar=01;31:*.ace=01;31:*.zoo=01;31:*.cpio=01;31:*.7z=01;31:*.rz=01;31:*.jpg=01;35:*.jpeg=01;35:*.gif=01;35:*.bmp=01;35:*.pbm=01;35:*.pgm=01;35:*.ppm=01;35:*.tga=01;35:*.xbm=01;35:*.xpm=01;35:*.tif=01;35:*.tiff=01;35:*.png=01;35:*.svg=01;35:*.svgz=01;35:*.mng=01;35:*.pcx=01;35:*.mov=01;35:*.mpg=01;35:*.mpeg=01;35:*.m2v=01;35:*.mkv=01;35:*.ogm=01;35:*.mp4=01;35:*.m4v=01;35:*.mp4v=01;35:*.vob=01;35:*.qt=01;35:*.nuv=01;35:*.wmv=01;35:*.asf=01;35:*.rm=01;35:*.rmvb=01;35:*.flc=01;35:*.avi=01;35:*.fli=01;35:*.flv=01;35:*.gl=01;35:*.dl=01;35:*.xcf=01;35:*.xwd=01;35:*.yuv=01;35:*.pdf=00;32:*.ps=00;32:*.txt=00;32:*.patch=00;32:*.diff=00;32:*.log=00;32:*.tex=00;32:*.doc=00;32:*.aac=00;36:*.au=00;36:*.flac=00;36:*.mid=00;36:*.midi=00;36:*.mka=00;36:*.mp3=00;36:*.mpc=00;36:*.ogg=00;36:*.ra=00;36:*.wav=00;36:';
export LS_COLORS


Comment 4 Fabian Groffen gentoo-dev 2008-08-12 06:49:36 UTC
mine looks the same, starts with rs=0:
Comment 5 Rabbe Fogelholm 2008-08-12 07:06:27 UTC
OK ... the rs=0 seems to be a feature of Prefix Gentoo (it is not there on SUSE, Red Hat or native Gentoo). For some strange reason this causes a problem in my prefix but not in every other.

BTW, I checked for a possible ~/.dir_colors file, but it turns out I don't have one.
Comment 6 Michael Haubenwallner gentoo-dev 2008-08-12 07:10:22 UTC
(In reply to comment #3)
> 2. `which dircolors' reports the prefix version of dircolors.

The use of 'which' indicates you're a C-Shell user?
If yes, does your ~/.cshrc override any PATH by chance?
Comment 7 Fabian Groffen gentoo-dev 2008-08-12 07:12:41 UTC
I am tcsh user, and the problem doesn't appear, same output in dircolors -c though.  I don't know where Prefix would "invent" the rs=0: from if normal Gentoo doesn't have it ...
Comment 8 Rabbe Fogelholm 2008-08-12 07:53:48 UTC
At work I use an environment that more or less enforces tcsh, so I am quite used to it. However, `which' is a stand-alone program too.

In Prefix Gentoo:

bash$ which which
/local/tmp/nightly/2008-08-12/usr/bin/which

bash$ which bash
/local/tmp/nightly/2008-08-12/bin/bash

etc..

While in prefix I usually use bash, mostly because it is there from the start.