Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 23338 - Recent PPC releases unable to bootstrap
Summary: Recent PPC releases unable to bootstrap
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: PPC Linux
: High blocker (vote)
Assignee: PPC Porters
Depends on:
Reported: 2003-06-23 12:09 UTC by Marc Doughty
Modified: 2006-02-04 06:03 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Marc Doughty 2003-06-23 12:09:59 UTC
I don't know if this is just a problem I had, but I downloaded rc6,7, and 8 and
they all exhibited it:

followed ppc install instructions on my B&W G3, when running
"scripts/" got "could not run/locate gcc!" and compilation failed.

running GCC at command prompt at this point also gave me the error.

I had to resolve by adding "/usr/powerpc-unknown-linux-gnu/gcc-bin/3.2" to the
END of the PATH line in /usr/sbin/, delete /usr/bin/gcc, run again, ^Z the bootstrap after portage emerged (while next package
was downloading) and add the path AGAIN in /usr/sbin/, then I ran 'fg'
to go back to the bootstrap. Everything worked fine after that.

It seems that /usr/bin/gcc in the stage1 tarball is borked, or the profile is
missing or something.

This effectively makes the PPC port uninstallable for anyone without some
serious time to waste and a decent linux knowledgebase.

Could this also be caused by documentation bitrot on the PPC side of the fence?
Comment 1 Lars Weiler (RETIRED) gentoo-dev 2003-06-27 07:04:49 UTC
On some releases you have to run 'gcc-config' first.

But the next CD release, outcoming next week, will solve this problem.

Nevertheless thanks for reminding us to this bug!
Comment 2 Lars Weiler (RETIRED) gentoo-dev 2004-02-15 15:01:43 UTC
Should be fixed.