Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 233181 - Stabilize =media-sound/banshee-1.0.0-r1 (and =dev-dotnet/taglib-sharp-2.0.3.0)
Summary: Stabilize =media-sound/banshee-1.0.0-r1 (and =dev-dotnet/taglib-sharp-2.0.3.0)
Status: RESOLVED CANTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High enhancement (vote)
Assignee: Gentoo Sound Team
URL:
Whiteboard:
Keywords: KEYWORDREQ, STABLEREQ
: 205210 (view as bug list)
Depends on:
Blocks:
 
Reported: 2008-07-28 18:39 UTC by Samuli Suominen
Modified: 2008-11-24 00:06 UTC (History)
6 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
banshee.log (banshee.log,7.46 KB, text/plain)
2008-09-20 12:17 UTC, Markus Meier
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Samuli Suominen gentoo-dev 2008-07-28 18:39:23 UTC
and required =dev-dotnet/taglib-sharp-2.0.3.0, please test it with USE="doc" as I had to patch the build system (again). This is because taglib-sharp-2.0.2.0 which just got stabilized (unfortunately) corrupts OggVorbis files as per bug 230465. And has an open QA bug 226701.

As for banshee itself, it's a media player.. play something. Might also want to test it same time with bug 232054.
Comment 1 Samuli Suominen gentoo-dev 2008-07-28 18:54:15 UTC
*** Bug 205210 has been marked as a duplicate of this bug. ***
Comment 2 Samuli Suominen gentoo-dev 2008-07-28 18:55:47 UTC
ppc, you still need to rekeyword banshee but you are here also to stabilize =dev-dotnet/taglib-sharp-2.0.3.0
Comment 3 Raúl Porcel (RETIRED) gentoo-dev 2008-07-29 14:29:20 UTC
Needs latest dev-lang/boo stable...dotnet, is that okay?
Comment 4 Brent Baude (RETIRED) gentoo-dev 2008-07-30 23:32:04 UTC
Marked mono-addins ~ppc.

taglib-sharp was just marked ~ on 7/16 so will need to wait a bit there.

I got a segfault with Banshee.  I'll have to poke it more another time but it looks like something in Mono which does not surprise me a bit.

baude@baudequad ~ $ banshee-1 
[Warn  18:31:03.116] DBus support could not be started. Disabling for this session.
[Info  18:31:03.140] Running Banshee 1.0.0
[Warn  18:31:04.538] Hardware manager extension failed to load - Exception has been thrown by the target of an invocation.
[Warn  18:31:04.538] Service `Banshee.Hardware.HardwareManager' not started: No HardwareManager extensions could be loaded. Hardware support will be disabled.
[Warn  18:31:04.544] Caught an exception - No HardwareManager extensions could be loaded. Hardware support will be disabled. (in `Banshee.Services')
  at Banshee.Hardware.HardwareManager..ctor () [0x00112] in /var/tmp/portage/media-sound/banshee-1.0.0-r1/work/banshee-1-1.0.0/src/Core/Banshee.Services/Banshee.Hardware/HardwareManager.cs:71 
  at <0x00000> <unknown method>
  at (wrapper managed-to-native) System.Reflection.MonoCMethod:InternalInvoke (object,object[])
  at System.Reflection.MonoCMethod.Invoke (System.Object obj, BindingFlags invokeAttr, System.Reflection.Binder binder, System.Object[] parameters, System.Globalization.CultureInfo culture) [0x0003f] in /var/tmp/portage/dev-lang/mono-1.9.1/work/mono-1.9.1/mcs/class/corlib/System.Reflection/MonoMethod.cs:404 

(/usr/lib/banshee-1/Nereid.exe:7268): GLib-GObject-WARNING **: cannot retrieve class for invalid (unclassed) type `(null)'
Stacktrace:

Segmentation fault
Comment 5 Samuli Suominen gentoo-dev 2008-07-31 19:46:11 UTC
(In reply to comment #4)
> I got a segfault with Banshee.  I'll have to poke it more another time but it
> looks like something in Mono which does not surprise me a bit.

Is your session launched with dbus? What about HAL? The messages start of by telling both of them are down, or at least /looking so/. Just trying to get 
a grasp of the enviroment you used.
Comment 6 Samuli Suominen gentoo-dev 2008-08-02 09:26:59 UTC
ppc, loki_val added 1.2.0 to tree..
Comment 7 Santiago M. Mola (RETIRED) gentoo-dev 2008-08-09 14:33:32 UTC
This also needs latest podsleuth, ipod-sharp and mono-zeroconf (which has no prior stable version). Are these ok to go stable?
Comment 8 Paul Philippov 2008-09-02 16:39:31 UTC
can you stabilize at least 0.13.1 for now? recent stable 0.12 depends on deprecated totem ABI and fails to play internet radio streams.
Comment 9 Peter Alfredsen (RETIRED) gentoo-dev 2008-09-02 16:55:18 UTC
(In reply to comment #7)
> This also needs latest podsleuth, ipod-sharp and mono-zeroconf (which has no
> prior stable version). Are these ok to go stable?
> 

Please do. Stabilize these versions:
dev-dotnet/podsleuth-0.6.2
dev-dotnet/mono-zeroconf-0.7.6
dev-dotnet/ipod-sharp-0.8.0
Though some are new in tree, they are just bugfix releases.
Comment 10 Markus Meier gentoo-dev 2008-09-20 12:17:18 UTC
Created attachment 165893 [details]
banshee.log

everything emerges fine, but the banshee app segfaults here on amd64/x86. tested with USE="*" and USE="-*".

Portage 2.1.4.4 (default/linux/x86/2008.0/desktop, gcc-4.1.2, glibc-2.6.1-r0, 2.6.26.3 i686)
=================================================================
System uname: 2.6.26.3 i686 Intel(R) Core(TM)2 Duo CPU T8300 @ 2.40GHz
Timestamp of tree: Sat, 20 Sep 2008 10:04:01 +0000
app-shells/bash:     3.2_p33
dev-java/java-config: 1.3.7, 2.1.6
dev-lang/python:     2.5.2-r7
dev-python/pycrypto: 2.0.1-r6
sys-apps/baselayout: 1.12.11.1
sys-apps/sandbox:    1.2.18.1-r2
sys-devel/autoconf:  2.13, 2.61-r2
sys-devel/automake:  1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.1
sys-devel/binutils:  2.18-r3
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   1.5.26
virtual/os-headers:  2.6.23-r3
ACCEPT_KEYWORDS="x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=i686 -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /opt/openfire/resources/security/ /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config /var/bind /var/lib/hsqldb /var/spool/torque"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/splash /etc/terminfo /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-O2 -march=i686 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="collision-protect distlocks metadata-transfer parallel-fetch sandbox sfperms strict test unmerge-orphans userfetch userpriv usersandbox"
GENTOO_MIRRORS="http://distfiles.gentoo.org http://distro.ibiblio.org/pub/linux/distributions/gentoo"
LDFLAGS="-Wl,-O1"
MAKEOPTS="-j2"
PKGDIR="/mnt/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X acl acpi alsa apache2 berkdb bluetooth branding bzip2 cairo cdr cli cracklib crypt cups dbus doc dri dvd dvdr dvdread eds emboss encode esd evo examples fam firefox fortran gdbm gif gnome gpm gstreamer gtk hal iconv ipv6 isdnlog jpeg kde kerberos ldap libnotify mad midi mikmod mp3 mpeg mudflap ncurses nls nptl nptlonly ogg opengl openmp pam pcre pdf perl png ppds pppd python qt3 qt3support qt4 quicktime readline reflection sdl session source spell spl ssl startup-notification svg sysfs tcpd test tiff truetype unicode usb vorbis win32codecs x86 xml xorg xv zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" USERLAND="GNU" VIDEO_CARDS="fbdev glint i810 mach64 mga neomagic nv r128 radeon savage sis tdfx trident vesa vga via vmware voodoo"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LANG, LC_ALL, LINGUAS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, PORTDIR_OVERLAY
Comment 11 Pacho Ramos gentoo-dev 2008-10-22 21:08:56 UTC
What about stabilizing 1.2.1-r2? Works ok here with USE: aac boo daap encode flac mad podcast test vorbis -debug -doc -ipod -mtp

Portage 2.1.4.5 (default/linux/amd64/2008.0/desktop, gcc-4.1.2, glibc-2.6.1-r0, 2.6.27-gentoo x86_64)
=================================================================
System uname: 2.6.27-gentoo x86_64 AMD Athlon(tm) 64 Processor 3200+
Timestamp of tree: Wed, 22 Oct 2008 07:30:01 +0000
ccache version 2.4 [enabled]
app-shells/bash:     3.2_p33
dev-java/java-config: 1.3.7, 2.1.6
dev-lang/python:     2.5.2-r7
dev-util/ccache:     2.4-r7
dev-util/cmake:      2.4.8
sys-apps/baselayout: 1.12.11.1
sys-apps/sandbox:    1.2.18.1-r2
sys-devel/autoconf:  2.13, 2.61-r2
sys-devel/automake:  1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.1-r1
sys-devel/binutils:  2.18-r3
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   1.5.26
virtual/os-headers:  2.6.23-r3
ACCEPT_KEYWORDS="amd64"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=k8 -O2 -pipe -msse3"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/revdep-rebuild /etc/terminfo /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-march=k8 -O2 -pipe -msse3"
DISTDIR="/usr/distfiles"
FEATURES="autoaddcvs ccache collision-protect cvs distlocks fixpackages metadata-transfer multilib-strict parallel-fetch sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="ftp://ftp.free.fr/mirrors/ftp.gentoo.org"
LANG="es_ES.UTF-8"
LC_ALL="es_ES.UTF-8"
LDFLAGS="-Wl,-O1"
LINGUAS="es es_ES en_US"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage/layman/sunrise /usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="3dnow 3dnowext X a52 aac acl acpi alsa amd64 asf audiofile avahi bash-completion beagle berkdb bzip2 bzlib cairo caps cdb cdda cddb cdinstall cdparanoia cdr cli consolekit cpdflib cpudetection cracklib cross crypt cups curl daap dbus dga divx4linux djvu dlloader dri dts dv dvb dvd dvdr dvdread dvi eds emboss encode epiphany erandom escreen evo evolution exif fam fame fbcon ffmpeg flac foomaticdb fortran ftp fuse galago gb gcj gd ggi gif gimp gimpprint git glitz glut glx gnome gnome-keyring gnome-print gphoto2 gpm gstreamer gtk gtk2 hal hddtemp iconv idn imagemagick imlib inotify isdnlog ithreads jabber java jpeg kdeenablefinal kdehiddenvisibility kpathsea ladspa lame latex lcms libnotify lm_sensors logrotate lzma mad madwifi midi mikmod mime mjpeg mmx mmxext mng mono moonlight motif mp3 mpeg mpi mplayer mudflap multilib musepack musicbrainz nas nautilus ncurses nethack network nls nocardbus nptl nptlonly ntp nvidia ogg oggvorbis openal opengl openmp pam pango pch pcre pdf perl plotutils png posix postscript ppds pppd python qt3 qt3support qt4 quicktime readline reflection remote rtc scanner sdl session slang slp sockets spell spl sse sse2 sse3 ssl startup-notification subversion svg sysfs sysvipc t1lib tcpd theora threads thunderbird tiff timidity totem trayicon truetype unicode usb v4l v4l2 vcd videos vim vorbis wma wmf xattr xcb xcomposite xft xine xml xml2 xorg xpm xulrunner xv xvid xvmc zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="es es_ES en_US" USERLAND="GNU" VIDEO_CARDS="nvidia nv vesa fbdev vga"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 12 Christopher Byrne 2008-10-25 23:14:46 UTC
Stabilizing banshee 1.2.x requires mono-1.2.6 and mono-addins-0.3.1, both of which are currently unstable. They would need to be stabilized first before banshee-1.2 could. 

Note that mono-addins currently pulls in mono-1.9 needlessly: see bug 236169. Although the patch will allow mono-addins to compile against the current stable mono, banshee-1.2 itself will not - it needs at least 1.2.6.

Comment 13 Pacho Ramos gentoo-dev 2008-10-26 11:42:15 UTC
You are true, sorry, I am using mono-1.9.1 :-/
Comment 14 Peter Alfredsen (RETIRED) gentoo-dev 2008-11-24 00:06:00 UTC
The next stable mono-version will be 2.0.1. We'll revisit then.