Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 233018 - sys-apps/portage-2.2_rc3: fails to emerge
Summary: sys-apps/portage-2.2_rc3: fails to emerge
Status: RESOLVED DUPLICATE of bug 224483
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Gentoo Linux bug wranglers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-07-26 19:28 UTC by Antonio Andriollo
Modified: 2008-07-27 12:23 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Antonio Andriollo 2008-07-26 19:28:38 UTC
sys-apps/portage-2.2_rc3: fails to emerge

When trying to "emerge portage" it fails with the following error:

 * Messages for package sys-apps/portage-2.2_rc3:

 *
 * ERROR: sys-apps/portage-2.2_rc3 failed.
 * Call stack:
 *               ebuild.sh, line 1784:  Called dyn_unpack
 *               ebuild.sh, line  677:  Called die
 * The specific snippet of code:
 *      touch "${PORTAGE_BUILDDIR}/.unpacked" || die "IO Failure -- Failed 'touch .unpacked' in ${PORTAGE_BUILDDIR}"
 *  The die message:
 *   IO Failure -- Failed 'touch .unpacked' in /var/tmp/portage/sys-apps/portage-2.2_rc3
 *
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/var/tmp/portage/sys-apps/portage-2.2_rc3/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/sys-apps/portage-2.2_rc3/temp/environment'.
 *


Here the build.log

touch: setting times of `/var/tmp/portage/sys-apps/portage-2.2_rc3/temp/environment.success': Function not implemented
>>> Unpacking source...
>>> Unpacking portage-2.2_rc1.tar.bz2 to /var/tmp/portage/sys-apps/portage-2.2_rc3/work
>>> Unpacking portage-2.2_rc3.patch.bz2 to /var/tmp/portage/sys-apps/portage-2.2_rc3/work
 ^[[32;01m*^[[0m Applying portage-2.2_rc3.patch ...
^[[A^[[97C  ^[[34;01m[ ^[[32;01mok^[[34;01m ]^[[0m
 ^[[32;01m*^[[0m Setting portage.VERSION to 2.2_rc3 ...
touch: setting times of `/var/tmp/portage/sys-apps/portage-2.2_rc3/.unpacked': Function not implemented
 ^[[31;01m*^[[0m
 ^[[31;01m*^[[0m ERROR: sys-apps/portage-2.2_rc3 failed.
 ^[[31;01m*^[[0m Call stack:
 ^[[31;01m*^[[0m               ebuild.sh, line 1784:  Called dyn_unpack
 ^[[31;01m*^[[0m               ebuild.sh, line  677:  Called die
 ^[[31;01m*^[[0m The specific snippet of code:
 ^[[31;01m*^[[0m        touch "${PORTAGE_BUILDDIR}/.unpacked" || die "IO Failure -- Failed 'touch .unpacked' in ${PORTAGE_BUILDDIR}"
 ^[[31;01m*^[[0m  The die message:
 ^[[31;01m*^[[0m   IO Failure -- Failed 'touch .unpacked' in /var/tmp/portage/sys-apps/portage-2.2_rc3
 ^[[31;01m*^[[0m
 ^[[31;01m*^[[0m If you need support, post the topmost build error, and the call stack if relevant.
 ^[[31;01m*^[[0m A complete build log is located at '/var/tmp/portage/sys-apps/portage-2.2_rc3/temp/build.log'.
 ^[[31;01m*^[[0m The ebuild environment file is located at '/var/tmp/portage/sys-apps/portage-2.2_rc3/temp/environment'.
 ^[[31;01m*^[[0m


I don't understand what's wrong, last emerge -uD world failed with a similar error (some kde package).
I've tried to solve with:
1. emerge --sync
2. emerge portage
3. emerge -uD world



Reproducible: Always
Comment 1 Samuli Suominen gentoo-dev 2008-07-27 12:23:12 UTC

*** This bug has been marked as a duplicate of bug 224483 ***