Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 232275 - Vmware-modules-1.0.0.20 / kernel 2.6.26 : field nopage doesn't exist
Summary: Vmware-modules-1.0.0.20 / kernel 2.6.26 : field nopage doesn't exist
Status: RESOLVED DUPLICATE of bug 227303
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Gentoo Linux bug wranglers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-07-18 23:20 UTC by Cyrius
Modified: 2008-07-18 23:37 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
Kernel config (.config,49.64 KB, text/plain)
2008-07-18 23:25 UTC, Cyrius
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Cyrius 2008-07-18 23:20:42 UTC
>>> Emerging (1 of 1) app-emulation/vmware-modules-1.0.0.20 to /
 * VMware-player-2.0.4-93057.i386.tar.gz RMD160 SHA1 SHA256 size ;-) ...                                                                                              [ ok ]
 * checking ebuild checksums ;-) ...                                                                                                                                  [ ok ]
 * checking auxfile checksums ;-) ...                                                                                                                                 [ ok ]
 * checking miscfile checksums ;-) ...                                                                                                                                [ ok ]
 * checking VMware-player-2.0.4-93057.i386.tar.gz ;-) ...                                                                                                             [ ok ]
 * Determining the location of the kernel source code
 * Found kernel source directory:
 *     /usr/src/linux
 * Found kernel object directory:
 *     /lib/modules/2.6.26-gentoo/build
 * Found sources for kernel version:
 *     2.6.26-gentoo
>>> Unpacking source...
>>> Unpacking VMware-player-2.0.4-93057.i386.tar.gz to /var/tmp/portage/app-emulation/vmware-modules-1.0.0.20/work
>>> Unpacking ./vmware-player-distrib/lib/modules/source//vmmon.tar to /var/tmp/portage/app-emulation/vmware-modules-1.0.0.20/work
 * Converting vmmon-only/Makefile to use M= instead of SUBDIRS= ...                                                                                                   [ ok ]
>>> Unpacking ./vmware-player-distrib/lib/modules/source//vmnet.tar to /var/tmp/portage/app-emulation/vmware-modules-1.0.0.20/work
 * Converting vmnet-only/Makefile to use M= instead of SUBDIRS= ...                                                                                                   [ ok ]
>>> Unpacking ./vmware-player-distrib/lib/modules/source//vmblock.tar to /var/tmp/portage/app-emulation/vmware-modules-1.0.0.20/work
 * Converting vmblock-only/Makefile to use M= instead of SUBDIRS= ...                                                                                                 [ ok ]
 * Applying 010_all_kernel-2.6.25.patch ...                                                                                                                           [ ok ]
 * Applying 1.0.0.20-makefile-kernel-dir.patch ...                                                                                                                    [ ok ]
>>> Source unpacked.
>>> Compiling source in /var/tmp/portage/app-emulation/vmware-modules-1.0.0.20/work ...
 * Preparing vmmon module
Using 2.6.x kernel build system.
make -C /lib/modules/2.6.26-gentoo/build M=$PWD SRCROOT=$PWD/. modules
make[1]: Entering directory `/usr/src/linux-2.6.26-gentoo'
make[1]: warning: jobserver unavailable: using -j1.  Add `+' to parent make rule.
  CC [M]  /var/tmp/portage/app-emulation/vmware-modules-1.0.0.20/work/vmmon-only/linux/driver.o
/var/tmp/portage/app-emulation/vmware-modules-1.0.0.20/work/vmmon-only/linux/driver.c:197: error: unknown field 'nopage' specified in initializer
/var/tmp/portage/app-emulation/vmware-modules-1.0.0.20/work/vmmon-only/linux/driver.c:198: warning: initialization from incompatible pointer type
make[3]: *** [/var/tmp/portage/app-emulation/vmware-modules-1.0.0.20/work/vmmon-only/linux/driver.o] Error 1
make[2]: *** [_module_/var/tmp/portage/app-emulation/vmware-modules-1.0.0.20/work/vmmon-only] Error 2
make[1]: *** [sub-make] Error 2
make[1]: Leaving directory `/usr/src/linux-2.6.26-gentoo'
make: *** [vmmon.ko] Error 2


Reproducible: Always

Steps to Reproduce:
1. install kernel 2.6.26
2. emerge vmware-modules
3.

Actual Results:  
>>> Emerging (1 of 1) app-emulation/vmware-modules-1.0.0.20 to /
 * VMware-player-2.0.4-93057.i386.tar.gz RMD160 SHA1 SHA256 size ;-) ...                                                                                              [ ok ]
 * checking ebuild checksums ;-) ...                                                                                                                                  [ ok ]
 * checking auxfile checksums ;-) ...                                                                                                                                 [ ok ]
 * checking miscfile checksums ;-) ...                                                                                                                                [ ok ]
 * checking VMware-player-2.0.4-93057.i386.tar.gz ;-) ...                                                                                                             [ ok ]
 * Determining the location of the kernel source code
 * Found kernel source directory:
 *     /usr/src/linux
 * Found kernel object directory:
 *     /lib/modules/2.6.26-gentoo/build
 * Found sources for kernel version:
 *     2.6.26-gentoo
>>> Unpacking source...
>>> Unpacking VMware-player-2.0.4-93057.i386.tar.gz to /var/tmp/portage/app-emulation/vmware-modules-1.0.0.20/work
>>> Unpacking ./vmware-player-distrib/lib/modules/source//vmmon.tar to /var/tmp/portage/app-emulation/vmware-modules-1.0.0.20/work
 * Converting vmmon-only/Makefile to use M= instead of SUBDIRS= ...                                                                                                   [ ok ]
>>> Unpacking ./vmware-player-distrib/lib/modules/source//vmnet.tar to /var/tmp/portage/app-emulation/vmware-modules-1.0.0.20/work
 * Converting vmnet-only/Makefile to use M= instead of SUBDIRS= ...                                                                                                   [ ok ]
>>> Unpacking ./vmware-player-distrib/lib/modules/source//vmblock.tar to /var/tmp/portage/app-emulation/vmware-modules-1.0.0.20/work
 * Converting vmblock-only/Makefile to use M= instead of SUBDIRS= ...                                                                                                 [ ok ]
 * Applying 010_all_kernel-2.6.25.patch ...                                                                                                                           [ ok ]
 * Applying 1.0.0.20-makefile-kernel-dir.patch ...                                                                                                                    [ ok ]
>>> Source unpacked.
>>> Compiling source in /var/tmp/portage/app-emulation/vmware-modules-1.0.0.20/work ...
 * Preparing vmmon module
Using 2.6.x kernel build system.
make -C /lib/modules/2.6.26-gentoo/build M=$PWD SRCROOT=$PWD/. modules
make[1]: Entering directory `/usr/src/linux-2.6.26-gentoo'
make[1]: warning: jobserver unavailable: using -j1.  Add `+' to parent make rule.
  CC [M]  /var/tmp/portage/app-emulation/vmware-modules-1.0.0.20/work/vmmon-only/linux/driver.o
/var/tmp/portage/app-emulation/vmware-modules-1.0.0.20/work/vmmon-only/linux/driver.c:197: error: unknown field 'nopage' specified in initializer
/var/tmp/portage/app-emulation/vmware-modules-1.0.0.20/work/vmmon-only/linux/driver.c:198: warning: initialization from incompatible pointer type
make[3]: *** [/var/tmp/portage/app-emulation/vmware-modules-1.0.0.20/work/vmmon-only/linux/driver.o] Error 1
make[2]: *** [_module_/var/tmp/portage/app-emulation/vmware-modules-1.0.0.20/work/vmmon-only] Error 2
make[1]: *** [sub-make] Error 2
make[1]: Leaving directory `/usr/src/linux-2.6.26-gentoo'
make: *** [vmmon.ko] Error 2



Portage 2.2_rc1 (default/linux/x86/2008.0, gcc-4.3.1, glibc-2.8_p20080602-r0, 2.6.26-gentoo i686)
=================================================================
System uname: Linux-2.6.26-gentoo-i686-Intel-R-_Core-TM-2_Duo_CPU_T7700_@_2.40GHz-with-glibc2.0
Timestamp of tree: Fri, 18 Jul 2008 16:46:01 +0000
app-shells/bash:     3.2_p39
dev-java/java-config: 1.3.7, 2.1.6-r1
dev-lang/python:     2.4.4-r4, 2.5.2-r5
dev-python/pycrypto: 2.0.1-r6
sys-apps/baselayout: 2.0.0
sys-apps/openrc:     0.2.2
sys-apps/sandbox:    1.2.18.1-r2
sys-devel/autoconf:  2.13, 2.62-r1
sys-devel/automake:  1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.1-r1
sys-devel/binutils:  2.18-r3
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   2.2.4
virtual/os-headers:  2.6.25-r4
ACCEPT_KEYWORDS="x86 ~x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-march=nocona -O2 -pipe -fomit-frame-pointer -mmmx -msse3         -mfpmath=sse -maccumulate-outgoing-args"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/terminfo /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-O2 -march=i686 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="distlocks parallel-fetch preserve-libs sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://mirror.qubenet.net/mirror/gentoo/ http://distfiles.gentoo.org http://www.ibiblio.org/pub/Linux/distributions/gentoo"
LDFLAGS="-Wl,-O1"
LINGUAS="fr"
MAKEOPTS="-j9"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="X a52 aac aalib acl acpi alsa arts audiofile avi berkdb bidi bzip2 bzlib cairo cdda cdparanoia cli cracklib crypt cups curl dbus dell dri dts dvd dvdr dvdread encode fam ffmpeg foomatic fortran freetype gd gdbm gif gimp glibc-omitfp glitz gpm gtk gtk2 hal iconv isdnlog java jpeg jpeg2k kde libwww loop-aes lua mad madwifi matroska midi mmx mng mozilla mp3 mpeg mudflap ncurses nls nptl nptlonly ogg oggvorbis opengl openmp oss pam pcre pdf perl png ppds pppd python qt3 qt4 quicktime rdesktop readline reflection samba sdl session slp spell spl sse sse2 sse3 ssl ssse3 svg svga tcpd theora tiff truetype unicode vmware vorbis wavpack wifi win32codecs wmf wmv x86 xcomposite xorg xscreensaver xv xvid zeroconf zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic auth_digest authn_anon authn_dbd authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock dbd deflate dir disk_cache env expires ext_filter file_cache filter headers ident imagemap include info log_config logio mem_cache mime mime_magic negotiation proxy proxy_ajp proxy_balancer proxy_connect proxy_http rewrite setenvif so speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="evdev mouse keyboard" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="fr" USERLAND="GNU" VIDEO_CARDS="nvidia vesa vga vmware"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG, LC_ALL, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Cyrius 2008-07-18 23:25:20 UTC
Created attachment 160778 [details]
Kernel config
Comment 2 Carsten Lohrke (RETIRED) gentoo-dev 2008-07-18 23:37:26 UTC

*** This bug has been marked as a duplicate of bug 227303 ***