Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 232167 - app-misc/workrave-1.8.5 segmentation fault
Summary: app-misc/workrave-1.8.5 segmentation fault
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: AMD64 Linux
: High normal (vote)
Assignee: Gentoo Linux bug wranglers
Depends on:
Reported: 2008-07-18 09:02 UTC by Maik Nijhuis
Modified: 2008-07-23 07:40 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Maik Nijhuis 2008-07-18 09:02:43 UTC
When starting workrave, it gives a segmentation fault. When I compile it using
"USE=debug emerge workrave" the output is:

>>> GUI::main
>>> System::init
>>> System::init_kde
<<< System::init_kde0
    System::init Locking enabled
<<< System::init
>>> Break:Break
<<< Break:Break
>>> Break:Break
<<< Break:Break
>>> Break:Break
<<< Break:Break
>>> Core::Core
<<< Core::Core
>>> ActivityMonitor::ActivityMonitor
>>> X11InputMonitor::run
>>> X11InputMonitor::run_xrecord
>>> X11InputMonitor::init_xrecord
    X11InputMonitor::init_xrecord use_xrecord= 1
<<< X11InputMonitor::init_xrecord
<<< ActivityMonitor::ActivityMonitor
>>> Core::load_monitor_config
    Core::load_monitor_config Monitor config = 9000 1000 5000
<<< Core::load_monitor_config
>>> GConfConfigurator::add_listener monitor
<<< GConfConfigurator::add_listener
>>> Break::init
>>> Timer::enable micro_pause0
>>> Timer::stop_timer micro_pause0
    Timer::stop_timer last_start_time = 0
    Timer::stop_timer 0
<<< Timer::stop_timer
<<< Timer::enable
>>> Timer::stop_timer micro_pause2
<<< Timer::stop_timer
>>> GConfConfigurator::add_listener timers/micro_pause
<<< GConfConfigurator::add_listener
>>> GConfConfigurator::add_listener gui/breaks/micro_pause
<<< GConfConfigurator::add_listener
<<< Break::init
>>> Break::init
>>> Timer::enable rest_break0
>>> Timer::stop_timer rest_break0
    Timer::stop_timer last_start_time = 0
    Timer::stop_timer 0
<<< Timer::stop_timer
<<< Timer::enable
>>> Timer::stop_timer rest_break2
<<< Timer::stop_timer
>>> GConfConfigurator::add_listener timers/rest_break
<<< GConfConfigurator::add_listener
>>> GConfConfigurator::add_listener gui/breaks/rest_break
<<< GConfConfigurator::add_listener
<<< Break::init
>>> Break::init
>>> Timer::enable daily_limit0
>>> Timer::stop_timer daily_limit0
    Timer::stop_timer last_start_time = 0
    Timer::stop_timer 0
<<< Timer::stop_timer
<<< Timer::enable
>>> Timer::stop_timer daily_limit2
<<< Timer::stop_timer
>>> GConfConfigurator::add_listener timers/daily_limit
<<< GConfConfigurator::add_listener
>>> GConfConfigurator::add_listener gui/breaks/daily_limit
<<< GConfConfigurator::add_listener
<<< Break::init
>>> Statistics::load_current_day
>>> Statistics::load
<<< Statistics::load
<<< Statistics::load_current_day
>>> Statistics::start_new_day
    Statistics::start_new_day New day
<<< Statistics::start_new_day
>>> Statistics::load_history
>>> Statistics::load
<<< Statistics::load
<<< Statistics::load_history
Comment 1 Maik Nijhuis 2008-07-18 09:03:26 UTC
emerge --info:

Portage (default-linux/amd64/2006.1/desktop, gcc-4.1.2, glibc-2.6.1-r0, 2.6.23-gentoo-r3 x86_64)
System uname: 2.6.23-gentoo-r3 x86_64 AMD Athlon(tm) 64 Processor 3200+
Timestamp of tree: Sat, 12 Jul 2008 01:45:01 +0000
distcc 2.18.3 x86_64-pc-linux-gnu (protocols 1 and 2) (default port 3632) [disabled]
app-shells/bash:     3.2_p33
dev-java/java-config: 1.3.7, 2.1.6
dev-lang/python:     2.3.5-r3, 2.4.4-r9
dev-python/pycrypto: 2.0.1-r6
sys-devel/autoconf:  2.13, 2.61-r1
sys-devel/automake:  1.4_p6, 1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.1
sys-devel/binutils:  2.18-r1
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   1.5.26
virtual/os-headers:  2.6.23-r3
CFLAGS="-O3 -fomit-frame-pointer -pipe"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/revdep-rebuild /etc/terminfo /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-O3 -fomit-frame-pointer -pipe"
FEATURES="distlocks metadata-transfer sandbox sfperms strict unmerge-orphans userfetch"
LINGUAS="nl en_US en"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTDIR_OVERLAY="/usr/portage/local/layman/java-overlay /usr/local/portage"
USE="3dnowex X aac acpi alsa amd64 bash-completion branding bzip2 cairo cdr cli cracklib crypt cups dbus divx divx4linux dri dvd dvdr dvdread emboss encode fam fbcon ffmpeg filepicker firefox gdbm gif glut gmedia gpm gstreamer gtk gtk2 hal iconv imap insecure-drivers ipv6 isdnlog jabber java javascript jikes jpeg justify largeterminal live mad midi mozsvg mp3 mpeg msn mudflap ncurses network nls nptl nptlonly nsplugin offensive ogg opengl openmp pam parse-clocks pcre pdf png ppds pppd qt3 qt4 quicktime readline realmedia reflection restrict-javascript rtc sdl session slang spell spl ssl stroke symlink threads tiff truetype unicode vorbis wmp x264 xml xorg xv xvid xvmc zlib" ALSA_CARDS="via82xx" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="nl en_US en" USERLAND="GNU" VIDEO_CARDS="via vesa"
Comment 2 Maik Nijhuis 2008-07-18 09:04:55 UTC
I also tried removing my .workrave directory, but it did not solve the error.
Comment 3 Jeroen Roovers (RETIRED) gentoo-dev 2008-07-18 15:22:15 UTC
Try running workrave in gdb (emerge gdb) or run `ulimit -c unlimited' in your bash shell prior to launching to have a `core' file generated (and then run `gdb workrave core' to get the desired output. Refer to [1] if you need more information about obtaining a backtrace.

Comment 4 Maik Nijhuis 2008-07-23 07:40:52 UTC
Because of the problem, I emerged workrave-1.8.3, so I had a working workrave again.

Now I emerged workrave-1.8.5 again to try gdb on it, but it's not necessary anymore, as it suddenly runs fine. I had done an emerge -auvD world in the meantime, which apparently solved the problem. It will be very difficult to find out which package actually broke workrave, so I won't dig any deeper, unless anyone requests it.