Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 232099 - net-wireless/madwifi-ng-0.9.4 unresolved symbols if CONFIG_MODVERSIONS is set
Summary: net-wireless/madwifi-ng-0.9.4 unresolved symbols if CONFIG_MODVERSIONS is set
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High minor (vote)
Assignee: Steev Klimaszewski (RETIRED)
URL:
Whiteboard:
Keywords:
: 232342 (view as bug list)
Depends on: 237618
Blocks: 232070
  Show dependency tree
 
Reported: 2008-07-17 18:24 UTC by Pacho Ramos
Modified: 2009-01-31 16:09 UTC (History)
9 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
madwifi-ng-0.9.4-r1.ebuild.patch (madwifi-ng-0.9.4-r1.ebuild.patch,1.15 KB, patch)
2008-07-19 06:56 UTC, labor_ratte
Details | Diff
kernel configuration (config,47.03 KB, text/plain)
2008-07-22 00:06 UTC, Diego Elio Pettenò (RETIRED)
Details
madwifi-ng-0.9.4-symvers.patch (madwifi-ng-0.9.4-symvers.patch,1.75 KB, patch)
2008-09-14 10:29 UTC, Peter Volkov (RETIRED)
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Pacho Ramos gentoo-dev 2008-07-17 18:24:58 UTC
I get:
  CC [M]  /var/tmp/portage/net-wireless/madwifi-ng-0.9.4/work/madwifi-0.9.4/net80211/ieee80211_proto.o
  CC [M]  /var/tmp/portage/net-wireless/madwifi-ng-0.9.4/work/madwifi-0.9.4/net80211/ieee80211_scan.o
/var/tmp/portage/net-wireless/madwifi-ng-0.9.4/work/madwifi-0.9.4/net80211/ieee80211_power.c: In function 'ieee80211_pwrsave':
/var/tmp/portage/net-wireless/madwifi-ng-0.9.4/work/madwifi-0.9.4/net80211/ieee80211_power.c:240: error: implicit declaration of function '__skb_append'
make[2]: *** [/var/tmp/portage/net-wireless/madwifi-ng-0.9.4/work/madwifi-0.9.4/net80211/ieee80211_power.o] Error 1
make[2]: *** Waiting for unfinished jobs....
make[1]: *** [_module_/var/tmp/portage/net-wireless/madwifi-ng-0.9.4/work/madwifi-0.9.4/net80211] Error 2
make[1]: Leaving directory `/usr/src/linux-2.6.26-gentoo'
make: *** [all] Error 2


Portage 2.1.4.4 (default/linux/amd64/2008.0/desktop, gcc-4.1.2, glibc-2.6.1-r0, 2.6.25-gentoo-r6 x86_64)
=================================================================
System uname: 2.6.25-gentoo-r6 x86_64 AMD Athlon(tm) 64 Processor 3200+
Timestamp of tree: Thu, 17 Jul 2008 15:30:02 +0000
ccache version 2.4 [enabled]
app-shells/bash:     3.2_p33
dev-java/java-config: 1.3.7, 2.1.6
dev-lang/python:     2.4.4-r13
dev-python/pycrypto: 2.0.1-r6
dev-util/ccache:     2.4-r7
sys-apps/baselayout: 1.12.11.1
sys-apps/sandbox:    1.2.18.1-r2
sys-devel/autoconf:  2.13, 2.61-r2
sys-devel/automake:  1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.1
sys-devel/binutils:  2.18-r3
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   1.5.26
virtual/os-headers:  2.6.23-r3
ACCEPT_KEYWORDS="amd64"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=k8 -O2 -pipe -msse3"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/revdep-rebuild /etc/terminfo /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-march=k8 -O2 -pipe -msse3"
DISTDIR="/usr/distfiles"
FEATURES="autoaddcvs ccache collision-protect cvs distlocks metadata-transfer multilib-strict parallel-fetch sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="ftp://ftp.free.fr/mirrors/ftp.gentoo.org"
LANG="es_ES.UTF-8"
LC_ALL="es_ES.UTF-8"
LDFLAGS="-Wl,-O1"
LINGUAS="es es_ES en_US"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage/layman/sunrise /usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="3dnow 3dnowext X a52 aac acl acpi alsa amd64 asf audiofile avahi bash-completion beagle berkdb bzip2 bzlib cairo caps cdb cdda cddb cdparanoia cdr cli consolekit cpdflib cpudetection cracklib cross crypt cups curl daap dbus dga divx4linux djvu dlloader dri dts dv dvb dvd dvdr dvdread eds emboss encode erandom escreen evo evolution exif fam fame fbcon ffmpeg flac foomaticdb fortran ftp galago gb gcj gd ggi gif gimp gimpprint git glitz glut glx gnome gnome-keyring gnome-print gphoto2 gpm gstreamer gtk gtk2 gtkhtml hal hddtemp iconv idn imagemagick imlib isdnlog ithreads jabber java jpeg kde kdeenablefinal kdehiddenvisibility kpathsea ladspa lame latex lcms libnotify lm_sensors logrotate mad madwifi midi mikmod mime mjpeg mmx mmxext mng mono moonlight motif mp3 mpeg mpi mplayer mudflap multilib musepack musicbrainz nas nautilus ncurses nethack network nls nocardbus nptl nptlonly nvidia ogg oggvorbis openal opengl openmp pam pch pcre pdf perl plotutils png posix ppds pppd python qt3 qt3support qt4 quicktime readline reflection remote rtc scanner sdl session slang slp sockets spell spl sse sse2 sse3 ssl startup-notification subversion svg sysvipc tcltk tcpd theora threads thunderbird tiff timidity tk totem trayicon truetype unicode usb v4l v4l2 vcd videos vim vorbis wma wmf xattr xcb xcomposite xft xine xml xml2 xorg xpm xulrunner xv xvid xvmc zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="es es_ES en_US" USERLAND="GNU" VIDEO_CARDS="nvidia nv vesa fbdev vga"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS


Reproducible: Always
Comment 1 Conrad Kostecki gentoo-dev 2008-07-18 10:45:46 UTC
Same here :(
Comment 2 Mike Auty gentoo-dev 2008-07-18 11:15:18 UTC
Upstream bug tracker appears to have a patch:

http://madwifi.org/ticket/1935
Comment 3 labor_ratte 2008-07-18 20:43:01 UTC
(In reply to comment #2)
> Upstream bug tracker appears to have a patch:
> 
> http://madwifi.org/ticket/1935
> 

Same bug here.

It seems to be that upstream did fix it in their cvs, and this ticket here seems to be more recent/appropriate:
http://madwifi.org/changeset/3696
At bottom of this link is an unified diff for download, I'll try and patch and will see what happens...
Comment 4 labor_ratte 2008-07-19 06:56:57 UTC
Created attachment 160795 [details, diff]
madwifi-ng-0.9.4-r1.ebuild.patch

patch for ebuild to include the linux-2.6.26 patch.

also in my personal overlay i have removed sharutils from depend,
please someone check if this is needed or not.
Comment 5 labor_ratte 2008-07-19 06:59:13 UTC
Applied the patch from
http://madwifi.org/changeset/3696?format=diff&new=3696
and now it compiles fine under linux-2.6.26.

emerge --info
Portage 2.2_rc1 (default/linux/amd64/2008.0/desktop, gcc-4.3.1, glibc-2.8_p20080602-r0, 2.6.26-gentoo x86_64)
=================================================================
System uname: Linux-2.6.26-gentoo-x86_64-AMD_Athlon-tm-_X2_Dual_Core_Processor_BE-2400-with-glibc2.2.5
Timestamp of tree: Fri, 18 Jul 2008 20:00:01 +0000
app-shells/bash:     3.2_p33
dev-lang/python:     2.5.2-r5
dev-python/pycrypto: 2.0.1-r6
sys-apps/baselayout: 2.0.0
sys-apps/openrc:     0.2.5
sys-apps/sandbox:    1.2.18.1-r3
sys-devel/autoconf:  2.13, 2.62-r1
sys-devel/automake:  1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.1-r1
sys-devel/binutils:  2.18-r3
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   1.5.26
virtual/os-headers:  2.6.25-r4
ACCEPT_KEYWORDS="amd64"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/splash /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-march=native -O2 -pipe"
DISTDIR="/var/tmp/distfiles"
FEATURES="distlocks noinfo parallel-fetch preserve-libs sandbox sfperms strict unmerge-orphans userfetch userpriv usersandbox"
GENTOO_MIRRORS="http://distfiles.gentoo.org http://distro.ibiblio.org/pub/linux/distributions/gentoo"
LANG="de_DE.UTF-8"
LC_ALL="de_DE.UTF-8"
LDFLAGS="-Wl,-O1,--hash-style=gnu,--sort-common,--as-needed"
LINGUAS="de"
MAKEOPTS="-j3"
PKGDIR="/var/tmp/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage /usr/local/overlay/hugin /usr/local/layman/desktop-effects"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="3dnow 3dnowext X aac acpi alsa amd64 berkdb branding bzip2 cairo cdr cli cracklib crypt cups dbus dga djvu dri dvd dvdr dvdread emboss encode evo expat fam firefox flac fortran gdbm gif gmp gnome gstreamer gtk hal iconv isdnlog jpeg lcms libnotify mad midi mikmod mmx mmxext mp3 mpeg mudflap multilib ncurses nls nptl nptlonly ogg opengl openmp pcre pdf perl png ppds pppd python qt3support quicktime readline reflection sdl session spl sse sse2 ssl ssse3 startup-notification svg threads tiff truetype unicode vorbis xcb xml xorg xv zlib" ALSA_CARDS="hda-intel" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="de" USERLAND="GNU" VIDEO_CARDS="vesa nv nvidia"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 6 Peter Volkov (RETIRED) gentoo-dev 2008-07-19 13:20:53 UTC
But why do you need this drive with 2.6.26 kernel? That kernel has ath5k driver which is supposed to be better and will be the only supported driver in future. I'm interested are there any regressions in ath5k comparing to madwifi that affects you so you can't use ath5k instead of madwifi?
Comment 7 Jeroen Roovers (RETIRED) gentoo-dev 2008-07-19 15:58:11 UTC
*** Bug 232342 has been marked as a duplicate of this bug. ***
Comment 8 Mike Auty gentoo-dev 2008-07-19 17:40:55 UTC
I haven't recently verified this, but for the 2.6.25 kernel, the ath5k driver was still not able to enter master mode (AP mode for madwifi-ng).  I'm also not certain of the state of injection on the ath5k (whereas madwifi-ng's injection capabilities are well tested).  As such the madwifi-ng driver is still invaluable in certain situations...  5:)
Comment 9 Patrizio Bassi 2008-07-20 08:36:57 UTC
i tried to use the ath5k but seems totally unstable.

i can just ping some machines but no bigger activities.

on my configuration it's totally broken and wpa doesn't work at all...
Comment 10 Patrizio Bassi 2008-07-20 09:20:27 UTC
patch applies but during linking some object are undefined and...
ath_pci: no symbol version for ath_hal_detach
ath_pci: Unknown symbol ath_hal_detach
ath_pci: no symbol version for ieee80211_cipher_none
ath_pci: Unknown symbol ieee80211_cipher_none
ath_pci: no symbol version for ieee80211_note
ath_pci: Unknown symbol ieee80211_note
ath_pci: no symbol version for ieee80211_crypto_delkey
ath_pci: Unknown symbol ieee80211_crypto_delkey
ath_pci: no symbol version for ieee80211_media_change
ath_pci: Unknown symbol ieee80211_media_change
ath_pci: no symbol version for ieee80211_beacon_miss
ath_pci: Unknown symbol ieee80211_beacon_miss
ath_pci: no symbol version for ieee80211_beacon_alloc
ath_pci: Unknown symbol ieee80211_beacon_alloc
ath_pci: no symbol version for ieee80211_getcfframe
ath_pci: Unknown symbol ieee80211_getcfframe
ath_pci: no symbol version for ieee80211_iterate_nodes
ath_pci: Unknown symbol ieee80211_iterate_nodes
ath_pci: no symbol version for ieee80211_vap_attach
ath_pci: Unknown symbol ieee80211_vap_attach
ath_pci: no symbol version for ieee80211_ibss_merge
ath_pci: Unknown symbol ieee80211_ibss_merge
ath_pci: no symbol version for ath_hal_probe
ath_pci: Unknown symbol ath_hal_probe
ath_pci: no symbol version for ieee80211_rate_attach
ath_pci: Unknown symbol ieee80211_rate_attach
ath_pci: no symbol version for ieee80211_rate_detach
ath_pci: Unknown symbol ieee80211_rate_detach
ath_pci: no symbol version for ieee80211_send_qosnulldata
ath_pci: Unknown symbol ieee80211_send_qosnulldata
ath_pci: no symbol version for ieee80211_create_vap
ath_pci: Unknown symbol ieee80211_create_vap
ath_pci: no symbol version for ieee80211_wme_acnames
ath_pci: Unknown symbol ieee80211_wme_acnames
ath_pci: no symbol version for ieee80211_input_all
ath_pci: Unknown symbol ieee80211_input_all
ath_pci: no symbol version for ieee80211_media_status
ath_pci: Unknown symbol ieee80211_media_status
ath_pci: no symbol version for ieee80211_start_running
ath_pci: Unknown symbol ieee80211_start_running
ath_pci: no symbol version for ieee80211_vap_detach
ath_pci: Unknown symbol ieee80211_vap_detach
ath_pci: no symbol version for ieee80211_announce
ath_pci: Unknown symbol ieee80211_announce
ath_pci: no symbol version for ieee80211_mark_dfs
ath_pci: Unknown symbol ieee80211_mark_dfs
ath_pci: no symbol version for ieee80211_chan2ieee
ath_pci: Unknown symbol ieee80211_chan2ieee
ath_pci: no symbol version for ieee80211_state_name
ath_pci: Unknown symbol ieee80211_state_name
ath_pci: no symbol version for ath_hal_init_channels
ath_pci: Unknown symbol ath_hal_init_channels
ath_pci: no symbol version for ieee80211_dturbo_switch
ath_pci: Unknown symbol ieee80211_dturbo_switch
ath_pci: no symbol version for ieee80211_crypto_encap
ath_pci: Unknown symbol ieee80211_crypto_encap
ath_pci: no symbol version for ieee80211_chan2mode
ath_pci: Unknown symbol ieee80211_chan2mode
ath_pci: no symbol version for ieee80211_getrssi
ath_pci: Unknown symbol ieee80211_getrssi
ath_pci: no symbol version for ieee80211_find_txnode
ath_pci: Unknown symbol ieee80211_find_txnode
ath_pci: no symbol version for ath_hal_getwirelessmodes
ath_pci: Unknown symbol ath_hal_getwirelessmodes

so it's still unusable
Comment 11 Steev Klimaszewski (RETIRED) gentoo-dev 2008-07-21 19:56:01 UTC
Committed the patch from upstream, didn't realize this bug existed (was conversating with Flameeyes on IRC) - this should be fixed now.  Please test (no rev-bump)
Comment 12 Diego Elio Pettenò (RETIRED) gentoo-dev 2008-07-21 23:43:09 UTC
Yep here same problem with ath_pci :/
Comment 13 Diego Elio Pettenò (RETIRED) gentoo-dev 2008-07-22 00:06:16 UTC
Created attachment 161061 [details]
kernel configuration
Comment 14 Mike Auty gentoo-dev 2008-07-22 07:24:42 UTC
I get the same error using the patch from [1], which suggests it's an issue with some changes that went into 2.6.26.  I've also noticed some problems with other modules when using modprobe -f (invalid format, although without -f they load just fine), so I think their symbol versioning must've had an overhaul.  [2] seems to suggest there's been some changes around there also...

[1] http://madwifi.org/attachment/ticket/1935/madwifi-dfs-ieee80211-skb-update.patch
[2] http://www.linuxhq.com/kernel/v2.6/26/kernel/module.c
Comment 15 Steev Klimaszewski (RETIRED) gentoo-dev 2008-07-22 07:43:43 UTC
Please try turning off module versioning - I'd asked Diego to, but he was tired of compiling his kernel for the day and didn't get a chance to do it.  Please let me know if that does fix it - if so, then we have a place to go - I don't have module versioning turned on and everything compiles and works fine here, but I'd like to know for sure that this could possibly be the cause.  If I remember correctly, this happened for me before and its why I ended up turning off versioning in the first place.  It would have to be something in there though as ieee80211 itself hasn't changed at all in the kernel
Comment 16 Mike Auty gentoo-dev 2008-07-22 08:22:50 UTC
Hiya Steev,

Yep, that got rid of the dmesg errors.  I'm afraid I can't fully confirm it all works (left the PCMCIA card at work), but previously modprobe ath_pci caused the errors and with module versioning turned off there were no errors.  Seems a bit of a shame, it had been working fine up until this kernel even with module versioning.  Anyway, hope that helps, let me know if there's any other tests I can run...  5:)
Comment 17 Dominik Zajac 2008-07-23 07:09:14 UTC
(In reply to comment #6)
> But why do you need this drive with 2.6.26 kernel? That kernel has ath5k driver
> which is supposed to be better and will be the only supported driver in future.
> I'm interested are there any regressions in ath5k comparing to madwifi that
> affects you so you can't use ath5k instead of madwifi?
> 

here last test using ath5k created an device but i wasn't able to use it.
chipset is:
01:00.0 Ethernet controller: Atheros Communications, Inc. AR5006EG 802.11 b/g Wireless PCI Express Adapter (rev 01)

so only chance is to use madwifi at the moment. 
Comment 18 labor_ratte 2008-07-25 14:03:58 UTC
(In reply to comment #11)
> Committed the patch from upstream, didn't realize this bug existed (was
> conversating with Flameeyes on IRC) - this should be fixed now.  Please test
> (no rev-bump)
> 

I've rebuild the madwifi-ng-0.9.4 with your committed patch, and here it works good with the kernel-2.6.26.
Ealier I'd took the patch from comment #3 which also worked.
My emerge --info is in comment #5.

(In reply to comment #6)
>But why do you need this drive with 2.6.26 kernel? That kernel has ath5k driver
>which is supposed to be better and will be the only supported driver in future.
>I'm interested are there any regressions in ath5k comparing to madwifi that
>affects you so you can't use ath5k instead of madwifi?

Sure, I went ahead and gave the new and shiny ath5k a try (again, like when the 2.6.25 arrived), and it even is able to create the device, but then I've found out that it is still not ready for use with my WPA2 a.k.a wpa_supplicant.
So I am looking forward for the further development of the ath5k.
But for now, users want to have something that they know of if it is working or not, and that is still the madwifi-ng modules.

Comment 19 labor_ratte 2008-07-25 14:16:00 UTC
Please can someone explain to me for what the
DEPEND="app-arch/sharutils"
is needed?
I see no use of that, maybe I'd overlook something?
Comment 20 Patrizio Bassi 2008-07-26 13:58:35 UTC
it compiles but still problems with undefined versions and i don't want to disable versioning in 2.6.26 (in 2.6.25 works like a charm)
Comment 21 Martin Mokrejš 2008-08-01 14:44:06 UTC
(In reply to comment #10)
> patch applies but during linking some object are undefined and...
> ath_pci: no symbol version for ath_hal_detach
> ath_pci: Unknown symbol ath_hal_detach

I hit the same problem. You have to load a kernel driver yourself before loading
ath_pci. It seems to me like broken dependency in modules so that modprobe doesn't
load the deps first.

That's before you have the following in your .config:

#
# Wireless
#
CONFIG_CFG80211=m
CONFIG_NL80211=y
CONFIG_WIRELESS_EXT=y
CONFIG_MAC80211=m
Comment 22 Patrizio Bassi 2008-08-30 07:20:28 UTC
are u aware of any progress here?
Comment 23 Steev Klimaszewski (RETIRED) gentoo-dev 2008-09-12 10:46:01 UTC
Currently going through some things in real life - I haven't forgotten about this at all, I am looking into it still, just, real life has really been kicking me about lately.   I promise I will get to the bottom of this as soon as I can.
Comment 24 Peter Volkov (RETIRED) gentoo-dev 2008-09-13 18:59:21 UTC
(In reply to comment #19)
> Please can someone explain to me for what the DEPEND="app-arch/sharutils"
> is needed?

Seems that previously it was used for uudecode program, but now uudecode is a part of madwifi-ng sources so... DEPEND is dropped. Thank you.

Comment 25 Peter Volkov (RETIRED) gentoo-dev 2008-09-14 10:24:54 UTC
Another workaround for this bug is to enable CONFIG_MODULE_FORCE_LOAD (together with CONFIG_MODVERSIONS). It's good idea to enable that anyway and makes this issue less critical.
Comment 26 Peter Volkov (RETIRED) gentoo-dev 2008-09-14 10:29:16 UTC
Created attachment 165387 [details, diff]
madwifi-ng-0.9.4-symvers.patch

This patch (together with patch for kernel from bug #237616) fixes this issue for me. We have to wait for kernel bug to be closed before applying this one.
Comment 27 Peter Volkov (RETIRED) gentoo-dev 2008-09-14 11:21:25 UTC
Well and patch above just workaround problems in our build system. Seems that real problem was reported in bug 237618... But let's wait for comments of our kernel team.
Comment 28 Peter Volkov (RETIRED) gentoo-dev 2008-10-14 06:02:19 UTC
I've added workaround in madwifi-ng-0.9.4-r1 and now it should work. But, please, keep this bug open, until kernel team handles this situation.
Comment 29 Patrizio Bassi 2008-10-17 23:10:02 UTC
unfortunatly bug 242238 blocks my test on .27
Comment 30 junmin 2008-10-18 23:38:03 UTC
http://madwifi.org/wiki/UserDocs/KernelConfig 

check the kernel configuration
Comment 31 Daniel Drake (RETIRED) gentoo-dev 2008-10-28 23:10:39 UTC
Can someone please confirm when the messages in comment #10 appear (compile time?) and if they actually prevent something from happening, or if they are just spamful warnings?
Comment 32 Peter Volkov (RETIRED) gentoo-dev 2008-10-29 08:40:29 UTC
(In reply to comment #31)
> Can someone please confirm when the messages in comment #10 appear (compile
> time?) and if they actually prevent something from happening, or if they are
> just spamful warnings?

Just did that. If I build this modules without following hack:

# Workaround our build system, bug #232099 (bug #237618 describes details)
touch Module.symvers
for ms in ath net80211 ath_hal ath_rate/{amrr,minstrel,onoe,sample}; do
	ln -s "${S}/Module.symvers" "${ms}"
done

which was added in madwifi-ng-0.9.4-r1 attempt to load module fails:

camobap ~ # modprobe ath_pci
FATAL: Error inserting ath_pci (/lib/modules/2.6.26-openvz.git-35f41f1/net/ath_pci.ko): Unknown symbol in module, or unknown parameter (see dmesg)
camobap

and in dmesg I have:

ath_hal: 0.9.18.0 (AR5210, AR5211, AR5212, RF5111, RF5112, RF2413, RF5413)
wlan: 0.9.4
ath_pci: no symbol version for ieee80211_encap
ath_pci: Unknown symbol ieee80211_encap
ath_pci: no symbol version for ieee80211_input
ath_pci: Unknown symbol ieee80211_input
ath_pci: no symbol version for ieee80211_ifattach
ath_pci: Unknown symbol ieee80211_ifattach
ath_pci: no symbol version for _ath_hal_attach
ath_pci: Unknown symbol _ath_hal_attach
ath_pci: no symbol version for ieee80211_beacon_update
[and so on]

So no, this is not a cosmetic issue.
Comment 33 Leander 2008-11-01 13:43:20 UTC
when I do "modprobe ieee80211"
FATAL: Error inserting ieee80211 /lib/modules/2.6.25-gentoo-r8/kernel/net/ieee80211/ieee80211.ko: Unknown symbol in module, or unknown parameter (see dmesg)

dmesg shows:
ieee80211_crypt: registered algorithm 'NULL'
iee80211: Unknown symbol request_module

Higher up in dmesg, when the system was booting it shows this:
wlan: Unknown symbol request_module

and then:

ath_pci: Unknown symbol ieee80211_check_mic
ath_pci: Unknown symbol ieee80211_encap
...
...
...
and so on..

This problem appears when updating from 2.6.25-r7 to 2.6.25-r8. 
I still depend on the madwifi driver since I have an Atheros AR5007EG, which has no range with the ath5k driver. 

More people with this problem: 
http://www.linuxquestions.org/questions/linux-wireless-networking-41/madwifi-doesnt-like-to-work-problem-might-start-at-emerge.-679865/
Comment 34 Peter Volkov (RETIRED) gentoo-dev 2008-11-01 17:00:53 UTC
Leander, you pointed to the thread with different solutions presented there. Have you tried them? Have you double checked that everything required is enabled in the kernel? If the answer is yes but the problem persists, please, open *new* bug. This bug documents different problem.
Comment 35 Peter Volkov (RETIRED) gentoo-dev 2009-01-31 16:09:45 UTC
This bug was long time ago fixed both in stable and unstable branches. Closing.