Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 231832 - net-libs/xulrunner-1.9-r2 - Unsupported architecture. Supported are: x86, ppc
Summary: net-libs/xulrunner-1.9-r2 - Unsupported architecture. Supported are: x86, ppc
Status: RESOLVED DUPLICATE of bug 231021
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: PPC Linux
: High normal (vote)
Assignee: Mozilla Gentoo Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-07-15 03:08 UTC by Stefan de Konink
Modified: 2008-07-15 13:26 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Stefan de Konink 2008-07-15 03:08:17 UTC
powerpc-unknown-linux-gnu-g++ -DGENTOO_NSPLUGINS_DIR=\"/usr/lib/nsplugins\" -DGENTOO_NSBROWSER_PLUGINS_DIR=\"/usr/lib/nsbrowser/plugins\"  -fno-rtti -fno-handle-exceptions  -Wconversion -Wpointer-arith -Woverloaded-virtual -Wsynth -Wno-ctor-dtor-privacy -Wno-non-virtual-dtor -Wcast-align -Wno-long-long -mcpu=7450 -pipe -mabi=altivec -Wno-return-type -w -fno-strict-aliasing -fshort-wchar -pthread -pipe  -DNDEBUG -DTRIMMED -O1 -fPIC -shared -Wl,-z,defs -Wl,-rpath,'$ORIGIN:$ORIGIN/..' -Wl,-h,libpref.so -o libpref.so  nsPref.o nsPrefBranch.o nsPrefService.o nsPrefsFactory.o prefapi.o prefread.o     -lpthread   -Wl,-rpath,'$ORIGIN:$ORIGIN/..' -Wl,-rpath-link,../../../dist/bin  -L../../../dist/bin -L../../../dist/lib -L../../../dist/bin -lxpcom -lxpcom_core  -L../../../dist/bin -Wl,-R/usr/lib/nspr -L/usr/lib/nspr -lplds4 -lplc4 -lnspr4 -lpthread -ldl  -Wl,--version-script -Wl,../../../build/unix/gnu-ld-scripts/components-version-script -Wl,-Bsymbolic -ldl -lm    
chmod +x libpref.so
/var/tmp/paludis/net-libs-xulrunner-1.9-r2/work/mozilla/config/nsinstall -R -m 755 libpref.so ../../../dist/bin/components
../../../config/elf-dynstr-gc ../../../dist/bin/components/libpref.so
Unsupported architecture. Supported are: x86, ppc
gmake[4]: *** [libs] Error 1
gmake[4]: Leaving directory `/var/tmp/paludis/net-libs-xulrunner-1.9-r2/work/mozilla/modules/libpref/src'
gmake[3]: *** [libs] Error 2
gmake[3]: Leaving directory `/var/tmp/paludis/net-libs-xulrunner-1.9-r2/work/mozilla/modules/libpref'
gmake[2]: *** [libs_tier_necko] Error 2
gmake[2]: Leaving directory `/var/tmp/paludis/net-libs-xulrunner-1.9-r2/work/mozilla'
gmake[1]: *** [tier_necko] Error 2
gmake[1]: Leaving directory `/var/tmp/paludis/net-libs-xulrunner-1.9-r2/work/mozilla'
make: *** [default] Error 2
/usr/libexec/paludis/utils/emake: emake returned error 2

Reproducible: Always

Steps to Reproduce:
1. paludis -i xulrunner
Actual Results:  
x86/ppc? what the heck must the compiler/package/toolchain be thinking, what is this PC? A ppc32?!


paludis 0.28.0
Paludis build information:
    Compiler:
        CXX:                   powerpc-unknown-linux-gnu-g++ 4.1.2 (Gentoo 4.1.2 p1.0.2)
        CXXFLAGS:              -O2 -mcpu=7450 -pipe -maltivec -mabi=altivec
        LDFLAGS:               
        DATE:                  2008-07-10T04:29:35+0200

    Libraries:
        C++ Library:           GNU libstdc++ 20070214

    Reduced Privs:
        reduced_uid:           104
        reduced_uid->name:     paludisbuild
        reduced_uid->dir:      /dev/null
        reduced_gid:           1004
        reduced_gid->name:     paludisbuild

    Paths:
        DATADIR:               /usr/share
        LIBDIR:                /usr/lib
        LIBEXECDIR:            /usr/libexec
        SYSCONFDIR:            /etc
        PYTHONINSTALLDIR:      
        RUBYINSTALLDIR:        

Environment:
    Format:                    paludis
    Config dir:                /etc/paludis
    World file:                /var/lib/portage/world

Repository virtuals:
    format:                    virtuals

Repository installed-virtuals:
    format:                    installed_virtuals
    root:                      /

Repository gentoo:
    format:                    ebuild
    location:                  /usr/portage
    append_repository_name_to_write_cache: true
    binary_destination:        false
    binary_keywords:           
    binary_uri_prefix:         
    builddir:                  /var/tmp/paludis
    cache:                     /usr/portage/metadata/cache
    distdir:                   /usr/portage/distfiles
    eapi_when_unknown:         0
    eapi_when_unspecified:     0
    eclassdirs:                /usr/portage/eclass
    ignore_deprecated_profiles: false
    layout:                    traditional
    names_cache:               /usr/portage/.cache/names
    newsdir:                   /usr/portage/metadata/news
    profile_eapi:              0
    profiles:                  /usr/portage/profiles/default-linux/ppc/ppc32/2007.0
    securitydir:               /usr/portage/metadata/glsa
    setsdir:                   /usr/portage/sets
    sync:                      rsync://192.168.1.3/gentoo-portage
    sync_options:              
    use_manifest:              use
    write_cache:               /var/empty

    Package information:
        app-admin/eselect-compiler: (none)
        app-shells/bash:       3.2_p39
        dev-java/java-config:  1.3.7 2.1.6-r1
        dev-lang/python:       2.4.4-r4 2.5.2-r5
        dev-python/pycrypto:   2.0.1-r6
        dev-util/ccache:       (none)
        dev-util/confcache:    (none)
        sys-apps/baselayout:   2.0.0
        sys-apps/openrc:       0.2.5
        sys-apps/sandbox:      1.2.18.1-r3
        sys-devel/autoconf:    2.13 2.62-r1
        sys-devel/automake:    1.10.1-r1 1.4_p6 1.5 1.6.3 1.7.9-r1 1.8.5-r3 1.9.6-r2
        sys-devel/binutils:    2.18-r3
        sys-devel/gcc-config:  1.4.0-r4
        sys-devel/libtool:     2.2.4
        virtual/os-headers:    2.6.25-r4 (for sys-kernel/linux-headers::installed)
Comment 1 Raúl Porcel (RETIRED) gentoo-dev 2008-07-15 13:26:06 UTC

*** This bug has been marked as a duplicate of bug 231201 ***
Comment 2 Raúl Porcel (RETIRED) gentoo-dev 2008-07-15 13:26:32 UTC
Bah, wrong bug
Comment 3 Raúl Porcel (RETIRED) gentoo-dev 2008-07-15 13:26:41 UTC

*** This bug has been marked as a duplicate of bug 231021 ***