Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 231752 - app-emulation/vmware-modules-1.0.0.{15,17}-r1 fail to compile with kernel 2.6.26
Summary: app-emulation/vmware-modules-1.0.0.{15,17}-r1 fail to compile with kernel 2....
Status: RESOLVED DUPLICATE of bug 227303
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo VMWare Bug Squashers [disabled]
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-07-14 09:44 UTC by Thomas Stein
Modified: 2008-07-15 08:25 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Thomas Stein 2008-07-14 09:44:57 UTC
Hello.

I can not compile vmware-modules on my 2.6.26 system. Beside of that i am a little bit confused which version to use for my vmware workstation. There are so many vmware-modules ebuilds. Not to mention the ones that resides vmware overlay. 

Okay, this is what i get at the moment:
make[1]: Entering directory `/usr/src/linux-2.6.26'
make[1]: warning: jobserver unavailable: using -j1.  Add `+' to parent make rule.
  CC [M]  /var/tmp/portage/app-emulation/vmware-modules-1.0.0.17-r1/work/vmblock-only/linux/block.o
  CC [M]  /var/tmp/portage/app-emulation/vmware-modules-1.0.0.17-r1/work/vmblock-only/linux/control.o
/var/tmp/portage/app-emulation/vmware-modules-1.0.0.17-r1/work/vmblock-only/linux/control.c: In function 'SetupProcDevice':
/var/tmp/portage/app-emulation/vmware-modules-1.0.0.17-r1/work/vmblock-only/linux/control.c:153: error: 'proc_root_fs' undeclared (first use in this function)
/var/tmp/portage/app-emulation/vmware-modules-1.0.0.17-r1/work/vmblock-only/linux/control.c:153: error: (Each undeclared identifier is reported only once
/var/tmp/portage/app-emulation/vmware-modules-1.0.0.17-r1/work/vmblock-only/linux/control.c:153: error: for each function it appears in.)
/var/tmp/portage/app-emulation/vmware-modules-1.0.0.17-r1/work/vmblock-only/linux/control.c: In function 'CleanupProcDevice':
/var/tmp/portage/app-emulation/vmware-modules-1.0.0.17-r1/work/vmblock-only/linux/control.c:213: error: 'proc_root_fs' undeclared (first use in this function)
make[3]: *** [/var/tmp/portage/app-emulation/vmware-modules-1.0.0.17-r1/work/vmblock-only/linux/control.o] Error 1
make[2]: *** [_module_/var/tmp/portage/app-emulation/vmware-modules-1.0.0.17-r1/work/vmblock-only] Error 2
make[1]: *** [sub-make] Error 2
make[1]: Leaving directory `/usr/src/linux-2.6.26'
make: *** [vmblock.ko] Error 2
 *
 * ERROR: app-emulation/vmware-modules-1.0.0.17-r1 failed.
 * Call stack:
 *               ebuild.sh, line   49:  Called src_compile
 *             environment, line 3200:  Called linux-mod_src_compile
 *             environment, line 2419:  Called die
 * The specific snippet of code:
 *               eval "emake HOSTCC=\"$(tc-getBUILD_CC)\"                      CC=\"$(get-KERNEL_CC)\"                                          LDFLAGS=\"$(get_abi_LDFLAGS)\"                                          ${BUILD_FIXES}         ${BUILD_PARAMS}                                          ${BUILD_TARGETS} " || die "Unable to emake HOSTCC="$(tc-getBUILD_CC)" CC="$(get-KERNEL_CC)" LDFLAGS="$(get_abi_LDFLAGS)" ${BUILD_FIXES} ${BUILD_PARAMS} ${BUILD_TARGETS}";
 *  The die message:
 *   Unable to emake HOSTCC=i686-pc-linux-gnu-gcc CC=i686-pc-linux-gnu-gcc LDFLAGS=   auto-build VMWARE_VER=VME_V6 KERNEL_DIR=/usr/src/linux KBUILD_OUTPUT=/lib/modules/2.6.26/build
 *
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/var/tmp/portage/app-emulation/vmware-modules-1.0.0.17-r1/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/app-emulation/vmware-modules-1.0.0.17-r1/temp/environment'.
 *

 * Messages for package app-emulation/vmware-modules-1.0.0.17-r1:

 *
 * ERROR: app-emulation/vmware-modules-1.0.0.17-r1 failed.
 * Call stack:
 *               ebuild.sh, line   49:  Called src_compile
 *             environment, line 3200:  Called linux-mod_src_compile
 *             environment, line 2419:  Called die
 * The specific snippet of code:
 *               eval "emake HOSTCC=\"$(tc-getBUILD_CC)\"                      CC=\"$(get-KERNEL_CC)\"                                          LDFLAGS=\"$(get_abi_LDFLAGS)\"                                          ${BUILD_FIXES}         ${BUILD_PARAMS}                                          ${BUILD_TARGETS} " || die "Unable to emake HOSTCC="$(tc-getBUILD_CC)" CC="$(get-KERNEL_CC)" LDFLAGS="$(get_abi_LDFLAGS)" ${BUILD_FIXES} ${BUILD_PARAMS} ${BUILD_TARGETS}";
 *  The die message:
 *   Unable to emake HOSTCC=i686-pc-linux-gnu-gcc CC=i686-pc-linux-gnu-gcc LDFLAGS=   auto-build VMWARE_VER=VME_V6 KERNEL_DIR=/usr/src/linux KBUILD_OUTPUT=/lib/modules/2.6.26/build
 *
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/var/tmp/portage/app-emulation/vmware-modules-1.0.0.17-r1/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/app-emulation/vmware-modules-1.0.0.17-r1/temp/environment'.

emerge info:

System uname: 2.6.26 i686 AMD Athlon(tm) 64 X2 Dual Core Processor 4800+
Timestamp of tree: Mon, 14 Jul 2008 08:04:01 +0000
app-shells/bash:     3.2_p33
dev-java/java-config: 1.3.7, 2.1.5
dev-lang/python:     2.4.4-r6, 2.5.1-r5
dev-python/pycrypto: 2.0.1-r6
sys-apps/baselayout: 1.12.11.1
sys-apps/sandbox:    1.2.18.1-r2
sys-devel/autoconf:  2.13, 2.61-r1
sys-devel/automake:  1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.1
sys-devel/binutils:  2.18-r1
sys-devel/gcc-config: 1.3.14
sys-devel/libtool:   1.5.26
virtual/os-headers:  2.6.24
ACCEPT_KEYWORDS="x86 ~x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-march=k8 -O2 -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/kde/4.1/env /usr/kde/4.1/share/config /usr/kde/4.1/shutdown /usr/share/config"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-march=k8 -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="distlocks parallel-fetch sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://distfiles.gentoo.org http://distro.ibiblio.org/pub/linux/distributions/gentoo"
LDFLAGS=""
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/portage/local/layman/voip /usr/portage/local/layman/vmware /usr/portage/local/layman/kdesvn-portage /usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="acl berkdb cli cracklib crypt cups dri fortran gdbm gpm iconv isdnlog midi mudflap ncurses nls nptl nptlonly openmp pam pcre perl pppd python readline reflection session spl ssl tcpd unicode x86 xorg zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1  emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m       maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" USERLAND="GNU" VIDEO_CARDS="nvidia"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG, LC_ALL, LINGUAS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS


Reproducible: Always
Comment 1 Mike Auty gentoo-dev 2008-07-14 23:47:17 UTC
Thomas,

Your version of vmware-workstation should know which version of modules it requires, and block all other versions.  Those in the overlay are generally the same as those in the main tree, unless testing a new version.  Each version of workstation/player/server works with only one "version number" of vmware-modules, so whichever one you originally have installed it the right one and an upgrade will consist of re-emerging it.

The modules are currently broken against 2.6.26 because they rely upon the init_mm symbol which was deprecated in 2.6.25 and removed in 2.6.26.  If you require vmware workstation for production purposes, I'm afraid you won't yet be able to use 2.6.26.  Please see the duplicate bug for further details...

*** This bug has been marked as a duplicate of bug 227303 ***
Comment 2 Thomas Stein 2008-07-15 08:25:10 UTC
Thank you for bringing a little bit light into this. Regards t.