Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 231356 - vmware-modules doesn't inform user that certain kernel config is neccessary on gentoo-sources-2.6.25
Summary: vmware-modules doesn't inform user that certain kernel config is neccessary o...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo VMWare Bug Squashers [disabled]
URL:
Whiteboard:
Keywords:
: 235141 (view as bug list)
Depends on:
Blocks:
 
Reported: 2008-07-09 23:07 UTC by Evan Teran
Modified: 2008-12-31 02:53 UTC (History)
5 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Evan Teran 2008-07-09 23:07:21 UTC
vmware-modules doesn't inform user that certain kernel config is necessary on gentoo-sources-2.6.25. Basically, vmware-modules requires the deprecated symbol "init_mm" which is only present in the 2.6.25 sources if the UNUSED_SYMBOLS kernel option is enabled. A likely good solution would be to detect the kernel version and if it is >= 2.6.25, emit a warning about necessary kernel options. Or better yet, detect if the necessary option is enabled.

Reproducible: Always

Steps to Reproduce:
compile vmware-modules on a system running gentoo-sources-2.6.25 without the UNUSED_SYMBOLS option. You will get a warning about the missing "init_mm" symbol and the module will fail to load.
Actual Results:  
You will get a warning about the missing "init_mm" symbol and the module will fail to load.

Expected Results:  
I expect to at least get a warning informing me about possible causes for this missing symbol and what can be done to correct it.

Portage 2.1.4.4 (default/linux/x86/2008.0/desktop, gcc-4.3.1, glibc-2.6.1-r0, 2.6.25-gentoo-r6 i686)
=================================================================
System uname: 2.6.25-gentoo-r6 i686 Intel(R) Core(TM)2 Duo CPU T7700 @ 2.40GHz
Timestamp of tree: Wed, 09 Jul 2008 19:30:01 +0000
app-shells/bash:     3.2_p33
dev-java/java-config: 1.3.7, 2.1.6
dev-lang/python:     2.4.4-r13
dev-python/pycrypto: 2.0.1-r6
sys-apps/baselayout: 1.12.11.1
sys-apps/sandbox:    1.2.18.1-r2
sys-devel/autoconf:  2.13, 2.61-r2
sys-devel/automake:  1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.1
sys-devel/binutils:  2.18-r3
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   1.5.26
virtual/os-headers:  2.6.23-r3
ACCEPT_KEYWORDS="x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-march=core2 -O2 -fomit-frame-pointer -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/terminfo /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-march=core2 -O2 -fomit-frame-pointer -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="collision-protect distlocks metadata-transfer parallel-fetch sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://distfiles.gentoo.org http://distro.ibiblio.org/pub/linux/distributions/gentoo"
LC_ALL="en_US"
LDFLAGS="-Wl,-O1"
LINGUAS="en_US"
MAKEOPTS="-j4"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="   "
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X a52 accessibility acl acpi alsa apache2 arts avahi bash-completion berkdb bluetooth boost branding bzip2 cairo cdr chroot cli cpudetection cracklib crypt cups curl cvs dbus debugger dell dhcp divx doc dri dvd dvdr dvdread eds emboss encode esd evo examples expat fam fat ffmpeg firefox flac gdbm gif glibc-omitfp glitz gmp gnome gnutls gpm gstreamer gtk hal iconv imagemagick innodb inotify ipod ipv6 ipw3945 isdnlog java jpeg jpeg2k kde kdeenablefinal kdehiddenvisibility kerberos lame ldap lesstif libnotify libwww lm_sensors mad mdnsresponder-compat midi mikmod mjpeg mmap mmx mng mp3 mp4 mpeg mpeg2 mplayer mudflap mysql ncurses network-cron nls nptl nptlonly nsplugin ntfs nvidia ogg opengl openmp oss pam pango pcap pch pcre pdf perl php pmu png ppds pppd python qt3 qt3support qt4 quicktime readline real realmedia reflection rtc samba sdl session sockets spell spl sqlite sse sse2 ssl ssse3 startup-notification subversion svg tcl tcpd threads tiff tivo tk truetype unicode usb userlocales utempter v4l vcd vim-syntax vnc vorbis wifi win32codecs wireshark wmf wmp wxwindows x86 xanim xcomposite xine xinerama xml xorg xpm xrandr xrender xscreensaver xulrunner xv xvid zeroconf zip zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic auth_digest authn_anon authn_dbd authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock dbd deflate dir disk_cache env expires ext_filter file_cache filter headers ident imagemap include info log_config logio mem_cache mime mime_magic negotiation proxy proxy_ajp proxy_balancer proxy_connect proxy_http rewrite setenvif so speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse synaptics evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en_US" USERLAND="GNU" VIDEO_CARDS="nvidia"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Michal Kurgan (RETIRED) gentoo-dev 2008-07-26 20:51:20 UTC
Confirmed with stable vanilla 2.6.25.11.
Please add check to vmware-modules for UNUSED_SYMBOLS configuration option.
Comment 2 Cyrius 2008-08-13 12:09:55 UTC
I've added this kernel option dependancy check in the ebuild of the 1.0.0.20 version
see bugg : 227303
Comment 3 Mike Auty gentoo-dev 2008-08-18 21:39:29 UTC
*** Bug 235141 has been marked as a duplicate of this bug. ***
Comment 4 Mike Auty gentoo-dev 2008-08-19 01:12:21 UTC
This has now been fixed in the overlay, thanks to Cyrius for adding it to the ebuild he posted in the other bug.  I've modified it, since this check is only necessary if the kernel version if 2.6.25 or greater, but none-the-less, great work Cyrius, thanks!!!  5:)
Comment 5 Michal Kurgan (RETIRED) gentoo-dev 2008-08-19 03:26:46 UTC
Overlay. Great. When it would hit tree?
Comment 6 Mike Auty gentoo-dev 2008-12-31 02:53:11 UTC
I believe this is no longer necessary is the main tree, so I'm going to mark it as FIXED.  Please let me know if you're still runnning into this as an issue...