Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 231209 - LiveCD sees PATA drives as SCSI/SATA
Summary: LiveCD sees PATA drives as SCSI/SATA
Status: VERIFIED INVALID
Alias: None
Product: Gentoo Release Media
Classification: Unclassified
Component: LiveCD/DVD (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Gentoo Release Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-07-08 18:50 UTC by Scott Smith
Modified: 2008-07-08 20:53 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Scott Smith 2008-07-08 18:50:27 UTC
The LiveCD shows my PATA IDE drives as /dev/sda /dev/sdb and the installer/installed system follows suit.
My pc has two PATA drives ans this is the '/etc/fstab' file on installed system:

-----------------------
/dev/sda3        none            swap            sw              0 0
/dev/sdb2        /       ext3    defaults                0 1
none        /proc     proc    defaults          0 0
none        /dev/shm  tmpfs   defaults          0 0
-----------------------

This should say '/dev/hda3' and '/dev/hdb2'.

If it helps, my machine is installed with (from lspci):

--------------
*-ide
      description: IDE interface
      product: VT82C586A/B/VT82C686/A/B/VT823x/A/C PIPC Bus Master IDE
      vendor: VIA Technologies, Inc.
--------------

Reproducible: Always

Steps to Reproduce:



Expected Results:  
picked up on my machine have PATA hard drives and found '/dev/hdaX', etc.
Comment 1 Scott Smith 2008-07-08 18:57:53 UTC
Sorry, the following is from program 'lshw'

--------------
*-ide
      description: IDE interface
      product: VT82C586A/B/VT82C686/A/B/VT823x/A/C PIPC Bus Master IDE
      vendor: VIA Technologies, Inc.
--------------
Comment 2 Andrew Gaffney (RETIRED) gentoo-dev 2008-07-08 19:53:08 UTC
So...you're complaining because everything worked? It's probably using the new libata PATA drivers instead of the old IDE drivers.
Comment 3 Scott Smith 2008-07-08 20:25:53 UTC
(In reply to comment #2)
> So...you're complaining because everything worked? It's probably using the new
> libata PATA drivers instead of the old IDE drivers.
> 

Still, why use /dev/sda in libata instead of /dev/hda. This doesn't seem the standard to me?
Comment 4 Chris Gianelloni (RETIRED) gentoo-dev 2008-07-08 20:53:55 UTC
The libata drivers use the (much better) SCSI generic interfaces and SCSI framework in the kernel.  Besides, it really was rather stupid, IMO, to have separate naming for IDE and SCSI disks.  At any rate, this is intended behavior and won't be reverted.

Thanks