Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 231037 - Error Listing Kernels in /boot
Summary: Error Listing Kernels in /boot
Status: RESOLVED DUPLICATE of bug 230998
Alias: None
Product: Gentoo Release Media
Classification: Unclassified
Component: Installer (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Gentoo Linux Installer
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-07-07 10:47 UTC by Reeko Savage
Modified: 2008-07-07 10:56 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Reeko Savage 2008-07-07 10:47:26 UTC
From install.log.failed:
GLI: July 07 2008 06:31:23 - Output of Kernel Names:
ls: cannot access /mnt/gentoo/boot/kernel-*: No such file or directory

GLI: July 07 2008 06:31:23 - Exception received during 'Configuring and installing bootloader': BootloaderError :FATAL: _configure_grub: Error listing the kernels in /boot
GLI: July 07 2008 06:31:23 - Traceback (most recent call last):
GLI: July 07 2008 06:31:23 - File "/opt/installer/GLIClientController.py", line 122, in run
    func()
GLI: July 07 2008 06:31:23 - File "/opt/installer/templates/x86ArchitectureTemplate.py", line 46, in install_bootloader
    self._configure_grub()
GLI: July 07 2008 06:31:23 - File "/opt/installer/templates/x86ArchitectureTemplate.py", line 61, in _configure_grub
    raise GLIException("BootloaderError", 'fatal', '_configure_grub', "Error listing the kernels in /boot")
GLI: July 07 2008 06:31:23 - GLIException: BootloaderError :FATAL: _configure_grub: Error listing the kernels in /boot


Reproducible: Didn't try

Steps to Reproduce:
During partitioning, i picked the recommended layout. Then moved on to the last section to set up the boot loader.
Actual Results:  
It failed.

Expected Results:  
A successful install.

I was running this through an emulator. But Gentoo 2007 installed fine in the emulator.
Comment 1 Marijn Schouten (RETIRED) gentoo-dev 2008-07-07 10:53:46 UTC
which emulator and which version, compiled with which use flags.
Comment 2 Dawid Węgliński (RETIRED) gentoo-dev 2008-07-07 10:56:26 UTC

*** This bug has been marked as a duplicate of bug 230998 ***