Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 23093 - K3b/cdrecord crashes when sending CUE sheet when running gs-sources-2.4.21-rc6/8,-2.4.22-pre2, does not crash when running gentoo-sources-r5
Summary: K3b/cdrecord crashes when sending CUE sheet when running gs-sources-2.4.21-rc...
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: x86 Linux
: High critical (vote)
Assignee: (DEPRECATED)
Depends on:
Reported: 2003-06-19 03:31 UTC by Craig Bradney
Modified: 2003-10-31 04:42 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---

My .config for gs-sources 2.4.22 pre2 (.config,23.07 KB, text/plain)
2003-06-30 13:21 UTC, Craig Bradney

Note You need to log in before you can comment on or make changes to this bug.
Description Craig Bradney 2003-06-19 03:31:03 UTC
Regardless of programs running, the whole PC locks up (no response from keyboard
or mouse, num lock goes off, caps/scroll lock go on) when I try to burn a cd
using k3b/cdrecord. Due to my win4lin reliancy I normally have a very stable
system using gs-source rc6 and now with rc8. Writing with gentoo-source r2 and
r5 was possible and still is possible having just rebuilt a new r5 kernel. The
hang happens when it sends the CUE sheet (k3b reports "Sending CUE Sheet"), or
perhaps just after it has finished sending, the next message never appears but
it is not immediately after the sending message appears. The hang also happens
when trying to simulate the record as well.

Reproducible: Always
Steps to Reproduce:
1. Build gssrc8
2. Reboot
3. Burn CD

Actual Results:  
Total Crash. (no response from keyboard or mouse, num lock goes off, caps/scroll
lock go on)

Expected Results:  
Written CD or continued with simulation of writing

Duron 900
512Mb RAM
hda 80gb
hdb 20gb
hdc cd writer IOMEGA  Model: ZIPCD3840INT  Rev: 1.05
hdd cd reader MATSHITA  Model: DVD-ROM SR-8586 Rev: 3Z24
hdc/hdd are used via ide-scsi


Portage 2.0.48-r1 (default-x86-1.4, gcc-3.2.2, glibc-2.3.1-r4)
System uname: 2.4.21_rc8-gss i686 AMD Duron(tm) processor
CONFIG_PROTECT="/etc /var/qmail/control /usr/kde/2/share/config
/usr/kde/3/share/config /usr/X11R6/lib/X11/xkb /usr/kde/3.1/share/config
CONFIG_PROTECT_MASK="/etc/gconf /etc/env.d"
USE="x86 oss 3dnow apm avi crypt cups encode gif jpeg libg++ mikmod mmx mpeg
ncurses nls pdflib png quicktime spell truetype xml2 xmms xv zlib gtkhtml alsa
gdbm berkdb slang readline arts aalib bonobo svga java guile mysql X sdl gpm
tcpd pam libwww ssl perl python esd imlib oggvorbis gnome gtk qt kde motif
opengl mozilla gphoto2 cdr acpi directfb dvd fbcon gtk-html gtk2 imap innodb
moznocompose moznoirc moznomail odbc radeon samba slp usb Xaw3d xml zope -postgres"
CFLAGS="-march=athlon -O3 -pipe"
CXXFLAGS="-O2 -mcpu=i686 -pipe"
FEATURES="sandbox ccache"


Have read about a kernel 2.4.21 hard cash on when writing cds due to
some magic-dev issue but I dont know how to find out about magic-dev. Theres no
process being used called that when Im writing as far as I know.
Comment 1 Craig Bradney 2003-06-19 03:39:20 UTC
My system was built from 1.4-rc4 stage 3, has had emerge -e world when gentoo-sources r2 was current, and is daily rsync'd so all is up to date as far as i know.

drecord 2.01a14 (i686-pc-linux-gnu) Copyright (C) 1995-2003 J
Comment 2 Craig Bradney 2003-06-19 03:39:20 UTC
My system was built from 1.4-rc4 stage 3, has had emerge -e world when gentoo-sources r2 was current, and is daily rsync'd so all is up to date as far as i know.

drecord 2.01a14 (i686-pc-linux-gnu) Copyright (C) 1995-2003 Jörg Schilling
mkisofs 2.01a12 (i686-pc-linux-gnu)
k3b 0.81
running within KDE 3.1.2
Comment 3 Caleb Tennis (RETIRED) gentoo-dev 2003-06-20 07:45:02 UTC
Have you tried the newest k3b and cdrecord in portage? 
Comment 4 Craig Bradney 2003-06-20 09:42:57 UTC
Ok, it looks like a k3b 0.81/cdrecord problem. I am running the latest cdrecord (there is no later even 
in masked builds), but I have now tried the K3b 0.9 pre2 release. Right now it is simulating writing 
perfectly well. I do now note that with k3b 0.9 pre1 there was a note about CUE sheets. 
I seriously thought it was a kernel or module problem though. With same level k3b (0.81) and 
cdrecord (2.01a14) switching from one kernel to the other made the system hang when writing. 
Something in gs-sources rc6 and 8 must make k3b 0.81 incompatible with the 2.01a14 version of 
I guess this one can be closed now. 
Comment 5 Caleb Tennis (RETIRED) gentoo-dev 2003-06-20 13:24:11 UTC
Okay, open it back up or file a new report if something changes. 
Comment 6 Craig Bradney 2003-06-27 13:44:37 UTC
This has reappeared. Last time I wrote about 250mb to a cd. Today I tried to write about 690mb to a cd and once again it hangs. It tests ok but it hangs when writing.
Comment 7 Craig Bradney 2003-06-27 13:46:45 UTC
Sorry, to clarify, it hangs when sending cuesheet if i do single session. If I do multi session it starts writing ok. I came back to the PC after ages and found Pc locked up, Num Lock on, Caps & Scroll Off (ie reverse of what they all were before)
Comment 8 Craig Bradney 2003-06-28 00:43:41 UTC
I meant to say..  Starts writing ok in multisession, but dies soon after.
Comment 9 Seemant Kulleen (RETIRED) gentoo-dev 2003-06-29 03:45:58 UTC
problem exists, still
Comment 10 Craig Bradney 2003-06-29 03:51:56 UTC
Since the last failed burn, I have done the following to make sure things are at least all ok below it: 
emerge -e system 
emerge xfree 
emerge cdrtools 
emerge k3b 
Still same problem. I have built a new gss rc8 kernel without some things and will try again with that. 
Comment 11 Craig Bradney 2003-06-29 08:03:09 UTC
Have just tried again, considering all of the above changes:
Wrote 690mb file to cd ok with gentoo-sources r5 at 1x (thought id do a speed test too)
Failed to write ~250mb file with gs-sources rc8 at 1x. 

The new test gs-sources rc8 kernel was no help.
Comment 12 Craig Bradney 2003-06-29 11:58:32 UTC
FWIW, I tested with pfeifer sources pre11. Having fixed Bug #23683 with the supplied diff, I am now 
booted from that kernel and just wrote at 12x (max for this cdrw). 
Comment 13 Craig Bradney 2003-06-30 13:20:22 UTC
Having found the release of gs-sources 2.4.22 pre2 I have used the same .config and I still get the crash in this kernel.
Comment 14 Craig Bradney 2003-06-30 13:21:14 UTC
Created attachment 14047 [details]
My .config for gs-sources 2.4.22 pre2
Comment 15 Craig Bradney 2003-06-30 15:34:21 UTC
I just created an iso from within k3b . just some files on my hard drive. 
I then successfully wrote the iso using:  
cdrecord speed=12 dev=0,0,0 /tmp/CDROM.iso 
I can mount and read the cd fine. Continuing debugging ... (posting this now in cae system crashes 
at next test) 
Comment 16 Tim Yamin (RETIRED) gentoo-dev 2003-08-26 08:38:39 UTC
You seem to have got this working? Can I resolve the bug, or are you still experiencing problems?
Comment 17 Craig Bradney 2003-08-26 08:46:18 UTC
I have not resolved the issue with this kernel. When the 2.4.22 final gs-sources comes out I will try again.
Comment 18 Brian Jackson (RETIRED) gentoo-dev 2003-09-24 00:47:20 UTC
can you try to revert the brlock and imon patches, and test
Comment 19 Craig Bradney 2003-10-18 10:25:09 UTC
I have just written a multisession cd with k3b 0.90 and gs-sources-2.4.23_pre7.
Will repost when I next write a large CD as this one was only 165mb.
Comment 20 Craig Bradney 2003-10-31 04:42:14 UTC
Wrote an ISO yesterday. This is a dead bug.