Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 230891 - media-plugins/gst-plugins-taglib-0.10.6 fails to compile
Summary: media-plugins/gst-plugins-taglib-0.10.6 fails to compile
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Linux bug wranglers
Depends on:
Reported: 2008-07-05 20:27 UTC by Mehmet Giritli
Modified: 2008-07-05 20:46 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Mehmet Giritli 2008-07-05 20:27:22 UTC
I have media-libs/taglib-1.4-r1 but tried media-libs/taglib-1.5 as well and got the same result.

 * Building external plugin ...
if /bin/sh ../../libtool --tag=CC --mode=compile i686-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I. -I../..    -pthread -I/usr/include/gstreamer-0.10 -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/include/libxml2   -I../../gst-libs -I../../gst-libs -pthread -I/usr/include/gstreamer-0.10 -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/include/libxml2   -Wall  -g   -DGST_DISABLE_DEPRECATED -I/usr/include/taglib   -march=athlon-xp -O2 -pipe -fomit-frame-pointer -MT libgsttaglib_la-gsttaglibmux.lo -MD -MP -MF ".deps/libgsttaglib_la-gsttaglibmux.Tpo" -c -o libgsttaglib_la-gsttaglibmux.lo `test -f 'gsttaglibmux.c' || echo './'`gsttaglibmux.c; \
	then mv -f ".deps/libgsttaglib_la-gsttaglibmux.Tpo" ".deps/libgsttaglib_la-gsttaglibmux.Plo"; else rm -f ".deps/libgsttaglib_la-gsttaglibmux.Tpo"; exit 1; fi
if /bin/sh ../../libtool --tag=CXX --mode=compile i686-pc-linux-gnu-g++ -DHAVE_CONFIG_H -I. -I. -I../..    -pthread -I/usr/include/gstreamer-0.10 -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/include/libxml2   -I../../gst-libs -I../../gst-libs -pthread -I/usr/include/gstreamer-0.10 -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/include/libxml2   -Wall  -g   -DGST_DISABLE_DEPRECATED -I/usr/include/taglib   -march=athlon-xp -O2 -pipe -fomit-frame-pointer -MT libgsttaglib_la-gstid3v2mux.lo -MD -MP -MF ".deps/libgsttaglib_la-gstid3v2mux.Tpo" -c -o libgsttaglib_la-gstid3v2mux.lo `test -f '' || echo './'`; \
	then mv -f ".deps/libgsttaglib_la-gstid3v2mux.Tpo" ".deps/libgsttaglib_la-gstid3v2mux.Plo"; else rm -f ".deps/libgsttaglib_la-gstid3v2mux.Tpo"; exit 1; fi
if /bin/sh ../../libtool --tag=CXX --mode=compile i686-pc-linux-gnu-g++ -DHAVE_CONFIG_H -I. -I. -I../..    -pthread -I/usr/include/gstreamer-0.10 -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/include/libxml2   -I../../gst-libs -I../../gst-libs -pthread -I/usr/include/gstreamer-0.10 -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/include/libxml2   -Wall  -g   -DGST_DISABLE_DEPRECATED -I/usr/include/taglib   -march=athlon-xp -O2 -pipe -fomit-frame-pointer -MT libgsttaglib_la-gstapev2mux.lo -MD -MP -MF ".deps/libgsttaglib_la-gstapev2mux.Tpo" -c -o libgsttaglib_la-gstapev2mux.lo `test -f '' || echo './'`; \
	then mv -f ".deps/libgsttaglib_la-gstapev2mux.Tpo" ".deps/libgsttaglib_la-gstapev2mux.Plo"; else rm -f ".deps/libgsttaglib_la-gstapev2mux.Tpo"; exit 1; fi
mkdir .libs
 i686-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I. -I../.. -pthread -I/usr/include/gstreamer-0.10 -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/include/libxml2 -I../../gst-libs -I../../gst-libs -pthread -I/usr/include/gstreamer-0.10 -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/include/libxml2 -Wall -g -DGST_DISABLE_DEPRECATED -I/usr/include/taglib -march=athlon-xp -O2 -pipe -fomit-frame-pointer -MT libgsttaglib_la-gsttaglibmux.lo -MD -MP -MF .deps/libgsttaglib_la-gsttaglibmux.Tpo -c gsttaglibmux.c  -fPIC -DPIC -o .libs/libgsttaglib_la-gsttaglibmux.o
 i686-pc-linux-gnu-g++ -DHAVE_CONFIG_H -I. -I. -I../.. -pthread -I/usr/include/gstreamer-0.10 -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/include/libxml2 -I../../gst-libs -I../../gst-libs -pthread -I/usr/include/gstreamer-0.10 -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/include/libxml2 -Wall -g -DGST_DISABLE_DEPRECATED -I/usr/include/taglib -march=athlon-xp -O2 -pipe -fomit-frame-pointer -MT libgsttaglib_la-gstid3v2mux.lo -MD -MP -MF .deps/libgsttaglib_la-gstid3v2mux.Tpo -c  -fPIC -DPIC -o .libs/libgsttaglib_la-gstid3v2mux.o
 i686-pc-linux-gnu-g++ -DHAVE_CONFIG_H -I. -I. -I../.. -pthread -I/usr/include/gstreamer-0.10 -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/include/libxml2 -I../../gst-libs -I../../gst-libs -pthread -I/usr/include/gstreamer-0.10 -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/include/libxml2 -Wall -g -DGST_DISABLE_DEPRECATED -I/usr/include/taglib -march=athlon-xp -O2 -pipe -fomit-frame-pointer -MT libgsttaglib_la-gstapev2mux.lo -MD -MP -MF .deps/libgsttaglib_la-gstapev2mux.Tpo -c  -fPIC -DPIC -o .libs/libgsttaglib_la-gstapev2mux.o
 i686-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I. -I../.. -pthread -I/usr/include/gstreamer-0.10 -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/include/libxml2 -I../../gst-libs -I../../gst-libs -pthread -I/usr/include/gstreamer-0.10 -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/include/libxml2 -Wall -g -DGST_DISABLE_DEPRECATED -I/usr/include/taglib -march=athlon-xp -O2 -pipe -fomit-frame-pointer -MT libgsttaglib_la-gsttaglibmux.lo -MD -MP -MF .deps/libgsttaglib_la-gsttaglibmux.Tpo -c gsttaglibmux.c -o libgsttaglib_la-gsttaglibmux.o >/dev/null 2>&1 error: 'GST_TAG_MUSICBRAINZ_SORTNAME' was not declared in this scope
make: *** [libgsttaglib_la-gstid3v2mux.lo] Error 1
make: *** Waiting for unfinished jobs....
 i686-pc-linux-gnu-g++ -DHAVE_CONFIG_H -I. -I. -I../.. -pthread -I/usr/include/gstreamer-0.10 -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/include/libxml2 -I../../gst-libs -I../../gst-libs -pthread -I/usr/include/gstreamer-0.10 -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/include/libxml2 -Wall -g -DGST_DISABLE_DEPRECATED -I/usr/include/taglib -march=athlon-xp -O2 -pipe -fomit-frame-pointer -MT libgsttaglib_la-gstapev2mux.lo -MD -MP -MF .deps/libgsttaglib_la-gstapev2mux.Tpo -c -o libgsttaglib_la-gstapev2mux.o >/dev/null 2>&1
 * ERROR: media-plugins/gst-plugins-taglib-0.10.6 failed.
 * Call stack:
 *     , line   49:  Called src_compile
 *             environment, line 2115:  Called gst-plugins-good_src_compile
 *             environment, line 1493:  Called die
 * The specific snippet of code:
 *       emake || die "compile failure"
 *  The die message:
 *   compile failure
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/var/tmp/portage/media-plugins/gst-plugins-taglib-0.10.6/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/media-plugins/gst-plugins-taglib-0.10.6/temp/environment'.

Reproducible: Always

Portage (default-linux/x86/2007.0, gcc-4.1.2, glibc-2.6.1-r0, 2.6.24-gentoo-r8 i686)
System uname: 2.6.24-gentoo-r8 i686 AMD Athlon(TM) XP 2200+
Timestamp of tree: Tue, 01 Jul 2008 21:00:01 +0000
distcc 2.18.3 i686-pc-linux-gnu (protocols 1 and 2) (default port 3632) [disabled]
ccache version 2.4 [enabled]
app-shells/bash:     3.2_p33
dev-java/java-config: 1.3.7, 2.1.6
dev-lang/python:     2.4.4-r13
dev-python/pycrypto: 2.0.1-r6
dev-util/ccache:     2.4-r7
sys-devel/autoconf:  2.13, 2.61-r2
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.1
sys-devel/binutils:  2.18-r1
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   1.5.26
virtual/os-headers:  2.6.23-r3
CFLAGS="-march=athlon-xp -O2 -pipe -fomit-frame-pointer"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/X11/xkb /usr/share/config /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/splash /etc/terminfo /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-march=athlon-xp -O2 -pipe -fomit-frame-pointer"
FEATURES="ccache distlocks fixpackages metadata-transfer sandbox sfperms strict unmerge-orphans userfetch"
LINGUAS="tr en en_GB en_US"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
USE="3dnow 3dnowext X X509 a52 aac aalib acpi alsa apache2 applet authdaemond autoipd avahi bash-completion beagle berkdb bookmarks branding buffysize bzip2 cairo ccache cdda cddb cdparanoia cdr cdrom clamav clamd colordiff cpudetection cracklib crypt css cups cupsddk dbus device-mapper dga disk-partition djvu dmi dmx dts dvd dvdr dvdread dvi eds enca encode epiphany evo exif extensions fam fasttrack fat fax ffmpeg firefox flac ftp fuse galago gdbm geoip gif gimp glade gnome gnome-keyring gnutls gocr gpg gpgme gpm graphics grub gs gstreamer gtk hal hddtemp howl-compat hpn icons iconv icq id3 id3tag idea idn imap inotify iproute2 irc isc ithreads java java6 javacomm javascript jce jikes jingle jmf jms john jpeg jpeg2k kde keyscrub kolab kpathsea lame latex libcaca libgda libnotify libsamplerate libsexy libvisual linuxthreads-tls lm_sensors logitech-mouse logrotate lvm lzo magic maildir mailwrapper md5sum mdnsresponder-compat mime mimencode mmkeys mmx mmxext mng mono mouse mozdevelop moznoirc moznomail mp3 mpeg msn mudflap musicbrainz nas nautilus ncurses network new-login new-reg-alloc nls nolvm1 nolvmstatic nptl nptlonly nsplugin ntfs nvidia ocamlopt ocrad offensive ogg opengl openmp openssl pam pango pch pcre pdf php pidgin png portaudio posix postscript ppds prediction pstricks pth pulseaudio python qt4 rdesktop readline real remote rss sasl scanner science session sidebar smime smtp sockets sound spamassassin spell spl spoof-source sse ssl startup-notification svg sysfs t1lib taglib tagwriting tcpd tex4ht theora threads tiff tools truetype unicode usb userlocales v4l v4l2 vda vnc vorbis wavpack win32codecs wma wmf x86 xattr xcomposite xine xorg xv xvid xvmc yahoo zeroconf zlib" ALSA_CARDS="via82xx" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic auth_digest authn_anon authn_dbd authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock dbd deflate dir disk_cache env expires ext_filter file_cache filter headers ident imagemap include info log_config logio mem_cache mime mime_magic negotiation proxy proxy_ajp proxy_balancer proxy_connect proxy_http rewrite setenvif so speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="tr en en_GB en_US" USERLAND="GNU" VIDEO_CARDS="nvidia"
Comment 1 Peter Alfredsen (RETIRED) gentoo-dev 2008-07-05 20:42:44 UTC
Fixed in 10.8, according to upstream bug. Confirm?
Comment 2 David Voge 2008-07-05 20:44:01 UTC
in media-plugins/gst-plugins-taglib-0.10.8 this bug is fixed.
Comment 3 Peter Alfredsen (RETIRED) gentoo-dev 2008-07-05 20:46:33 UTC
Thank you. Marking closed.