Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 230621 - amsn failed to start
Summary: amsn failed to start
Status: RESOLVED DUPLICATE of bug 225999
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: AMD64 Linux
: High normal (vote)
Assignee: Gentoo net-im Herd
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-07-03 12:07 UTC by yegle
Modified: 2008-07-04 13:21 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description yegle 2008-07-03 12:07:01 UTC
just finished installing amsn,but it failed to start
Application initialization failed: Can't find a usable tk.tcl in the following directories: 
    /usr/lib64/tcl8.4/tk8.4 /usr/lib64/tk8.4 /usr/lib/tk8.4 /lib/tk8.4 /usr/library /library /tk8.4.18/library

/usr/lib64/tk8.4/tk.tcl: no event type or button # or keysym
no event type or button # or keysym
    while executing
"bind Listbox <MouseWheel> {
        %W yview scroll [expr {- (%D / 120) * 4}] units
    }"
    invoked from within
"if {[tk windowingsystem] eq "classic" || [tk windowingsystem] eq "aqua"} {
    bind Listbox <MouseWheel> {
        %W yview scroll [expr {- (%D)}] uni..."
    (file "/usr/lib64/tk8.4/listbox.tcl" line 181)
    invoked from within
"source /usr/lib64/tk8.4/listbox.tcl"
    (in namespace eval "::" script line 1)
    invoked from within
"namespace eval :: [list source [file join $::tk_library $file.tcl]]"
    (procedure "SourceLibFile" line 2)
    invoked from within
"SourceLibFile listbox"
    (in namespace eval "::tk" script line 4)
    invoked from within
"namespace eval ::tk {
	SourceLibFile button
	SourceLibFile entry
	SourceLibFile listbox
	SourceLibFile menu
	SourceLibFile panedwindow
	SourceLibFile ..."
    invoked from within
"if {$::tk_library ne ""} {
    if {$tcl_platform(platform) eq "macintosh"} {
	proc ::tk::SourceLibFile {file} {
	    if {[catch {
		namespace eval :: ..."
    (file "/usr/lib64/tk8.4/tk.tcl" line 407)
    invoked from within
"source /usr/lib64/tk8.4/tk.tcl"
    ("uplevel" body line 1)
    invoked from within
"uplevel #0 [list source $file]"
/usr/lib/tk8.4/tk.tcl: no event type or button # or keysym
no event type or button # or keysym
    while executing
"bind Listbox <MouseWheel> {
        %W yview scroll [expr {- (%D / 120) * 4}] units
    }"
    invoked from within
"if {[tk windowingsystem] eq "classic" || [tk windowingsystem] eq "aqua"} {
    bind Listbox <MouseWheel> {
        %W yview scroll [expr {- (%D)}] uni..."
    (file "/usr/lib/tk8.4/listbox.tcl" line 181)
    invoked from within
"source /usr/lib/tk8.4/listbox.tcl"
    (in namespace eval "::" script line 1)
    invoked from within
"namespace eval :: [list source [file join $::tk_library $file.tcl]]"
    (procedure "SourceLibFile" line 2)
    invoked from within
"SourceLibFile listbox"
    (in namespace eval "::tk" script line 4)
    invoked from within
"namespace eval ::tk {
	SourceLibFile button
	SourceLibFile entry
	SourceLibFile listbox
	SourceLibFile menu
	SourceLibFile panedwindow
	SourceLibFile ..."
    invoked from within
"if {$::tk_library ne ""} {
    if {$tcl_platform(platform) eq "macintosh"} {
	proc ::tk::SourceLibFile {file} {
	    if {[catch {
		namespace eval :: ..."
    (file "/usr/lib/tk8.4/tk.tcl" line 407)
    invoked from within
"source /usr/lib/tk8.4/tk.tcl"
    ("uplevel" body line 1)
    invoked from within
"uplevel #0 [list source $file]"


This probably means that tk wasn't installed properly.

Error in startup script: no event type or button # or keysym
    while executing
"bind Pixmapscroll <MouseWheel> {
        tk::ScrollByUnits %W v [expr {- (%D)}]
    }"
    invoked from within
"if {![catch {tk windowingsystem} wsystem] && $wsystem == "x11"} {
    bind Pixmapscroll <MouseWheel> {
        tk::ScrollByUnits %W v [expr {- (%D)}]
..."
    (file "pixmapscroll.tcl" line 717)
    invoked from within
"source [file join pixmapscroll.tcl]"
    ("package ifneeded" script)
    invoked from within
"package require pixmapscroll"
    invoked from within
"if { $initialize_amsn == 1 } {

	if {![::picture::Loaded]} {
		if { [OnDarwin] } {	
			tk_messageBox -default ok -message "There's a problem loading a..."
    (file "gui.tcl" line 4)
    invoked from within
"source gui.tcl		"
    ("uplevel" body line 23)
    invoked from within
"uplevel \#0 {

	# amsncore.tcl is already loaded but we'll re-source it here in case we manually do reload_files
	source amsncore.tcl
	source audio.tc..."
    (procedure "reload_files" line 2)
    invoked from within
"reload_files"


Portage 2.2_rc1 (default/linux/amd64/2008.0, gcc-4.3.1, glibc-2.8_p20080602-r0, 2.6.25-gentoo-r5-yegle x86_64)
=================================================================
System uname: Linux-2.6.25-gentoo-r5-yegle-x86_64-Intel-R-_Core-TM-2_CPU_T5600_@_1.83GHz-with-glibc2.2.5
Timestamp of tree: Thu, 03 Jul 2008 10:15:01 +0000
ccache version 2.4 [enabled]
app-shells/bash:     3.2_p39
dev-lang/python:     2.5.2-r5
dev-util/ccache:     2.4-r7
sys-apps/baselayout: 2.0.0
sys-apps/openrc:     0.2.5
sys-apps/sandbox:    1.2.18.1-r3
sys-devel/autoconf:  2.13, 2.62-r1
sys-devel/automake:  1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.1-r1
sys-devel/binutils:  2.18-r2
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   2.2.4
virtual/os-headers:  2.6.25-r4
ACCEPT_KEYWORDS="amd64 ~amd64"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -pipe -march=core2"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT=""
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-O2 -pipe -march=core2"
DISTDIR="/usr/portage/distfiles"
FEATURES="ccache collision-protect distlocks parallel-fetch preserve-libs sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://trumpetti.atm.tut.fi/gentoo/"
LANG="zh_CN.UTF-8"
LDFLAGS=""
LINGUAS="zh zh_CN"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_EXTRA_OPTS="-6"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage/layman/gentoo-china /usr/local/portage/layman/sunrise /home/yegle/portage"
SYNC="rsync://gentoo.mirror.ipv6.e-utp.net/gentoo-portage"
USE="X a52 aac accessibility acpi alsa amd64 avahi bash-completion berkdb bindist bluetooth bzip2 cairo cdda cddb cdio cdparanoia cdr cjk cli cracklib crypt dbus dts dvd dvdr dvdread encode exif ffmpeg flac fontconfig ftp gdbm gif git gpm gtk hal iconv immqt-bc ipv6 isdnlog ithreads jabber javascript jpeg lame libnotify lyrics matroska mdnsresponder-compat midi mime mmx mp3 mpeg msn mudflap multilib ncurses network newspr nptl nptlonly nvidia ogg opengl openmp pch pcre pdf perl pinyin png pppd python qq qt3 qt3support rar rdesktop readline reflection sdl sdl-image session skins spl sqlite sse sse2 sse3 ssl stream subversion svg taglib tcpd theora truetype unicode usb v4l2 vlm vorbis wxwindows x264 xcomposite xine xorg xosd xv xvid xvmc zlib" ALSA_CARDS="hda-intel" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="zh zh_CN" USERLAND="GNU" VIDEO_CARDS="nv nvidia vesa"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS




Reproducible: Always
Comment 1 Olivier Crete (RETIRED) gentoo-dev 2008-07-03 15:17:48 UTC
Do you have dev-lang/tk installed?
Comment 2 Carsten Lohrke (RETIRED) gentoo-dev 2008-07-04 13:21:22 UTC
Um, should not have assigned to you, IM crowd.

*** This bug has been marked as a duplicate of bug 225999 ***