Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 230275 - kdnssd-avahi creates libkdnssd.* in /usr/lib64 kdeaddons expects it at /usr/kde/3.5/lib64
Summary: kdnssd-avahi creates libkdnssd.* in /usr/lib64 kdeaddons expects it at /usr/k...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] KDE (show other bugs)
Hardware: AMD64 Linux
: High normal (vote)
Assignee: Portage team
URL:
Whiteboard:
Keywords:
Depends on: 225429
Blocks: preserve-libs kdeprefix
  Show dependency tree
 
Reported: 2008-06-30 23:02 UTC by Chris Bruner
Modified: 2009-06-08 03:59 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Chris Bruner 2008-06-30 23:02:51 UTC
Building from a clean system, (X isn't working yet so I can't post emerge -info)


Reproducible: Always

Steps to Reproduce:
1.emerge kdnssd-avahi
2.emerge kdeaddons
3.kdeaddons build.log shows couldn't find lib, lib is in /usr/lib64
Comment 1 Darren Dale 2008-10-01 12:59:51 UTC
Perhaps I am seeing a related problem. portage keeps reporting: 

!!! existing preserved libs:
>>> package: kde-misc/kdnssd-avahi-0.1.2-r1
 *  - /usr/lib64/libkdnssd.so.1
 *      used by /usr/kde/3.5/bin/atlantik (kde-base/atlantik-3.5.10)
 *      used by /usr/kde/3.5/bin/atlantikdesigner (kde-base/atlantikdesigner-3.5.10)
 *      used by /usr/kde/3.5/bin/katomic (kde-base/katomic-3.5.10)
 *      used by 37 other files
 *  - /usr/lib64/libkdnssd.so.1.0.0
 *      used by /usr/kde/3.5/bin/atlantik (kde-base/atlantik-3.5.10)
 *      used by /usr/kde/3.5/bin/atlantikdesigner (kde-base/atlantikdesigner-3.5.10)
 *      used by /usr/kde/3.5/bin/katomic (kde-base/katomic-3.5.10)
 *      used by 37 other files
Use emerge @preserved-rebuild to rebuild packages using these libraries


I have run "emerge @preserved-rebuild" twice, with no improvement.


$ emerge --info
Portage 2.2_rc11 (default/linux/amd64/2008.0/desktop, gcc-4.3.1, glibc-2.8_p20080602-r0, 2.6.26-gentoo-r1 x86_64)
=================================================================
System uname: Linux-2.6.26-gentoo-r1-x86_64-Dual_Core_AMD_Opteron-tm-_Processor_275-with-glibc2.2.5
Timestamp of tree: Wed, 01 Oct 2008 12:05:01 +0000
app-shells/bash:     3.2_p39
dev-java/java-config: 1.3.7, 2.1.6-r1
dev-lang/python:     2.5.2-r8
sys-apps/baselayout: 2.0.0
sys-apps/openrc:     0.2.5
sys-apps/sandbox:    1.2.18.1-r3
sys-devel/autoconf:  2.13, 2.63
sys-devel/automake:  1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.1-r1
sys-devel/binutils:  2.18-r3
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   2.2.6a
virtual/os-headers:  2.6.26
ACCEPT_KEYWORDS="amd64 ~amd64"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -march=k8 -mtune=k8 -pipe -fomit-frame-pointer"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/kde/4.0/env /usr/kde/4.0/share/config /usr/kde/4.0/shutdown /usr/share/config /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/eselect/postgresql /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/terminfo /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-O2 -march=k8 -mtune=k8 -pipe -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
FEATURES="collision-protect distlocks fixpackages parallel-fetch preserve-libs protect-owned sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://distfiles.gentoo.org http://distro.ibiblio.org/pub/linux/distributions/gentoo"
LANG="en_US.UTF-8"
LC_ALL="en_US.UTF-8"
LDFLAGS="-Wl,-O1"
LINGUAS="en en_US"
MAKEOPTS="-j5"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/layman/soor-overlay /usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="3dnow X aac acl acpi alsa amd64 apache2 atlas avahi bash-completion berkdb blas bluetooth bookmarks branding bzip2 cairo cblas cdr cli cracklib crypt ctype cups dbus dirac doc dri dvd dvdr dvdread eds emacs emboss encode esd evo examples f77 fam fftw firefox foomativdb fortran gdbm gfortran gif gimpprint glitz gpm gstreamer gtk hal iconv imagemagick imap isdnlog ivman java jpeg jpeg2k kde kdrive kerberos lapack latex ldap libnotify lzo mad mdnsresponder-compat midi mikmod mime mmap mmx mozbranding mozilla mozsvg mp3 mpeg mplayer mudflap multilib multislot mysql ncurses newspr nptl nptlonly nsplugin ogg opengl openmp oss pam pcre pdf perl pertty pic png postgres ppds pppd python qt3 qt3support qt4 quicktime readline reflection rss samba sdl session spell spl sse sse2 ssl startup-notification subversion svg symlink sysfs tcltk tcpd tetex threads tiff tk transparency truetype ubuntu umfpack unicode usb v4l v4l2 vorbis webdav winbind xcomposite xfs xft xinerama xml xorg xulrunner xv zeroconf zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic auth_digest authn_anon authn_dbd authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock dbd deflate dir disk_cache env expires ext_filter file_cache filter headers ident imagemap include info log_config logio mem_cache mime mime_magic negotiation proxy proxy_ajp proxy_balancer proxy_connect proxy_http rewrite setenvif so speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="evdev keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en en_US" USERLAND="GNU" VIDEO_CARDS="nvidia vga nv"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 2 Jorge Manuel B. S. Vicetto Gentoo Infrastructure gentoo-dev 2008-10-04 17:51:05 UTC
(In reply to comment #1)
> Perhaps I am seeing a related problem. portage keeps reporting: 
> 
> !!! existing preserved libs:
> >>> package: kde-misc/kdnssd-avahi-0.1.2-r1
>  *  - /usr/lib64/libkdnssd.so.1
>  *      used by /usr/kde/3.5/bin/atlantik (kde-base/atlantik-3.5.10)

This seems a known portage bug that's caused by having a lib changing dir - did you move from -kdeprefix to kdeprefix or the reverse?
In that case, yYou may want to run "portageq list_preserved_libs /" to get a list of the libs and remove them.
Comment 3 Jorge Manuel B. S. Vicetto Gentoo Infrastructure gentoo-dev 2008-10-11 18:31:34 UTC
I'm reassigning this bug to the portage team.
Comment 4 Zac Medico gentoo-dev 2008-11-01 03:22:12 UTC
This should be fixed by the code from bug #225429. It will be released in 2.2_rc13.
Comment 5 Zac Medico gentoo-dev 2008-11-02 00:57:33 UTC
This should be fixed in 2.2_rc13. Please reopen if the problem persists.
Comment 6 Jan Beinersdorf 2009-06-07 23:04:47 UTC
Don't know if this is related or if this needs to be opened again, but I have the following problem:

Upgrading from kde-meta-3.5.9 to 3.5.10, while emerging atlantik I get the error message that libkdnssd.* could not be linked. (Same is true for all the following packages.) kdnssd-avahi is installed and libs are in /usr/kde/3.5/lib64, but ld looks for them in /usr/lib64.

There are no preserved libs on my system, portageq list_preserved_libs / returns nothing.

Also, I'm moving from kdeprefix to -kdeprefix.

As a quick and dirty workaround I linked the libs to where they are expected and it seems to work so far.

----------

~ # emerge --info
Portage 2.2_rc33 (default/linux/amd64/2008.0, gcc-4.3.2, glibc-2.8_p20080602-r1, 2.6.28-gentoo-r5 x86_64)
=================================================================
System uname: Linux-2.6.28-gentoo-r5-x86_64-AMD_Phenom-tm-_9950_Quad-Core_Processor-with-glibc2.2.5
Timestamp of tree: Sun, 07 Jun 2009 22:00:17 +0000
distcc 3.1 x86_64-pc-linux-gnu [disabled]
ccache version 2.4 [enabled]
app-shells/bash:     3.2_p39
dev-java/java-config: 1.3.7-r1, 2.1.7
dev-lang/python:     2.4.4-r13, 2.5.4-r2
dev-python/pycrypto: 2.0.1-r6
dev-util/ccache:     2.4-r7
dev-util/cmake:      2.6.2-r1
sys-apps/baselayout: 1.12.11.1
sys-apps/sandbox:    1.6-r2
sys-devel/autoconf:  2.13, 2.63
sys-devel/automake:  1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.2
sys-devel/binutils:  2.18-r3
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   1.5.26
virtual/os-headers:  2.6.27-r2
ACCEPT_KEYWORDS="amd64"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=barcelona -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/splash /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-march=barcelona -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="ccache distlocks fixpackages parallel-fetch preserve-libs protect-owned sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://distfiles.gentoo.org http://distro.ibiblio.org/pub/linux/distributions/gentoo"
LANG="de_DE.UTF-8@euro"
LDFLAGS="-Wl,-O1"
LINGUAS="de en us"
MAKEOPTS="-j6"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/overlays"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="3dnow 3dnowext X a52 aac accessibility acl acpi alsa amd64 amr apache2 apm arts audiofile avahi avi bcmath berkdb binfilter bzip2 cairo calendar cdda cddb cdio cdparanoia cdr cli cpudetection cracklib crypt css cups curl dbus dga divx4linux dri dvd dvdr dvdread eds encode esd exif expat fam ffmpeg flac foomaticdb fortran garmin gd gdbm gif gimp glib glut gmp gphoto2 gpm gstreamer gtk gtk2 gtkhtml guile hal iconv icq idn imagemagick imlib ip3100 ip3300 ipv6 isdnlog java javascript joystick jpeg jpeg2k junit kde kqemu lcms ldap libwww lm_sensors lua mad madwifi matroska mdnsresponder-compat mhash midi mikmod mjpeg mmx mmxext mng motif mozdevelop mozilla mozsvg mozxmlterm mp3 mp4 mpeg mpeg2 mplayer msn mudflap multilib musepack mysql ncurses networking nls nptl nptlonly nsplugin ntfs ogg oggvorbis openal opengl openmp oscar overlays pam pcre pdf pdflib perl php plotutils png posix postscript povray ppds pppd python qt qt3 qt3support qt4 quicktime readline reflection reiserfs ruby samba scanner sdk sdl session slang smp sndfile softmmu sound sox speex spell spl sqlite sse sse2 sse3 ssl stream subtitles svg sysfs tcl tcltk tcpd tetex threads tidy tiff timidity tk truetype udev unicode upnp usb vcd vorbis wmf wxwindows x264 xcomposite xine xinerama xml xml2 xorg xulrunner xv xvid xvmc zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic auth_digest authn_anon authn_dbd authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock dbd deflate dir disk_cache env expires ext_filter file_cache filter headers ident imagemap include info log_config logio mem_cache mime mime_magic negotiation proxy proxy_ajp proxy_balancer proxy_connect proxy_http rewrite setenvif so speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="de en us" USERLAND="GNU" VIDEO_CARDS="fglrx vesa"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LC_ALL, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 7 Zac Medico gentoo-dev 2009-06-08 03:59:41 UTC
(In reply to comment #6)
> There are no preserved libs on my system, portageq list_preserved_libs /
> returns nothing.

This bug was about an issue with preserve-libs, so your issue seems unrelated.