Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 230043 - app-mobilephone/bitpim-1.0.5 fails to build with gcc 4.3
Summary: app-mobilephone/bitpim-1.0.5 fails to build with gcc 4.3
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Gentoo Mobile Phone Developers (INACTIVE)
Depends on:
Blocks: gcc-4.3
  Show dependency tree
Reported: 2008-06-29 15:52 UTC by A Frederick Christensen
Modified: 2008-07-01 18:57 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---

Build log for bitpim 1.0.5 with gcc-4.3 failure (bitpim-1.0.5-with-gcc-4.3-build-fail,3.73 KB, text/plain)
2008-06-29 16:00 UTC, A Frederick Christensen
bitpim-1.0.5 patch for GCC 4.3 (bitpim-1.0.5-gcc-4.3-fix.patch,728 bytes, patch)
2008-06-30 06:31 UTC, A Frederick Christensen
Details | Diff
New ebuild for bitpim-1.0.5 with GCC 4.3 patch (bitpim-1.0.5.ebuild,4.69 KB, text/plain)
2008-06-30 06:35 UTC, A Frederick Christensen

Note You need to log in before you can comment on or make changes to this bug.
Description A Frederick Christensen 2008-06-29 15:52:13 UTC
bitpim 1.0.5 is the only remaining bitpim atom in portage. Using gcc 4.3.1, an attempt to build bitpim always dies with complaints of "error: XXXX was not declared in this scope" where memcpy, strncpy, and memset are the funtions (XXXX), and avi_file.cxx and bmp_file.cxx are the source files generating the complaint. Reading bug reports like 229063, I believe that this is a gcc 4.3 issue. I have not tried to compile with other versions of gcc. Bitpim is not important enough to me to revert.

Reproducible: Always
Comment 1 A Frederick Christensen 2008-06-29 16:00:15 UTC
Created attachment 158865 [details]
Build log for bitpim 1.0.5 with gcc-4.3 failure
Comment 2 A Frederick Christensen 2008-06-29 16:02:23 UTC
Portage 2.2_rc1 (default-linux/x86/2007.0, gcc-4.3.1, glibc-2.8_p20080602-r0, 2.6.25-tuxonice-r5 i686)
System uname: Linux-2.6.25-tuxonice-r5-i686-Intel-R-_Pentium-R-_M_processor_1500MHz-with-glibc2.0
Timestamp of tree: Sun, 29 Jun 2008 09:15:03 +0000
ccache version 2.4 [enabled]
app-shells/bash:     3.2_p39
dev-java/java-config: 1.3.7, 2.1.6
dev-lang/python:     2.5.2-r5
dev-python/pycrypto: 2.0.1-r6
dev-util/ccache:     2.4-r7
sys-apps/baselayout: 2.0.0
sys-apps/openrc:     0.2.5
sys-devel/autoconf:  2.13, 2.62
sys-devel/automake:  1.4_p6, 1.5, 1.7.9-r1, 1.9.6-r2, 1.10.1-r1
sys-devel/binutils:  2.18-r2
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   2.2.4
virtual/os-headers:  2.6.25-r4
CFLAGS="-O2 -march=pentium-m -pipe -fomit-frame-pointer"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5/e
xt-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/splash /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-O2 -march=pentium-m -pipe -fomit-frame-pointer"
FEATURES="ccache distlocks parallel-fetch preserve-libs sandbox sfperms strict unmerge-orphans userfetch"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfile
s --exclude=/local --exclude=/packages"
USE="X a52 aac aalib acl acpi alsa apache2 bash-completion branding bzip2 cddb cdr cli cracklib crypt cups dri dts dvd dvdr dvdread ffmpeg fortran gdbm
 gif gpm iconv imap ipv6 isdnlog javascript jpeg libao libcaca midi mmx mp3 mpeg mplayer mudflap mysql ncurses nls nptl nptlonly nsplugin ocamlopt offe
nsive opengl openmp pam pcre perl png pppd python readline reflection sasl sdl session slang spell spl sse sse2 ssl syslog tcpd tiff truetype unicode u
sb vim-syntax wifi win32codecs x86 xorg xv xvid zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1       emu10k1x ens137
0 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m      maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw a
sym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" APACH
E2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz
_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config l
ogio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="mouse 
keyboard evdev synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en" USERLAND="GNU
" VIDEO_CARDS="radeon vesa"
Comment 3 A Frederick Christensen 2008-06-29 16:18:09 UTC
Adding "#include <cstring>"
to both the avi_file.cxx and the bmp_file.cxx
will resolve this issue.
Comment 4 A Frederick Christensen 2008-06-30 06:31:21 UTC
Created attachment 158913 [details, diff]
bitpim-1.0.5 patch for GCC 4.3
Comment 5 A Frederick Christensen 2008-06-30 06:35:32 UTC
Created attachment 158915 [details]
New ebuild for bitpim-1.0.5 with GCC 4.3 patch

With this ebuild and the patch, bitpim 1.0.5 compiled happily for me. However, bitpim itself still silently dies when I run it. This has happened (without the gcc issues involved) several times for me in the past when python, wxpython, or bitpim have updated. I've already rebuild python/wxpython, and bitpim still does the silent death routine, but hey, at least it builds.
Comment 6 Alin Năstac (RETIRED) gentoo-dev 2008-07-01 16:29:59 UTC
Did you saw any QA notices while building wxpython or bitpim?
Comment 7 Alin Năstac (RETIRED) gentoo-dev 2008-07-01 17:13:29 UTC
According to bug 230363, bitpim-1.0.5 needs on dev-python/apsw- Please check if the new version of apsw fixes your problem.
Comment 8 A Frederick Christensen 2008-07-01 17:26:14 UTC
(In reply to comment #7)
> According to bug 230363, bitpim-1.0.5 needs on dev-python/apsw- Please
> check if the new version of apsw fixes your problem.

I just rebuilt both wxpython and bitpim. No QA notices in either one.
Apsw fixes the silent bitpim death at runtime (Thank You!).
It seems the poster of bug 230363 is correct, and bitpim SHOULD depend on apsw.

I still need the patch I posted above to get bitpim to compile with gcc 4.3. Older gcc versions will auto-inlcude simple libs that are not #included like <cstring>, it seems. 4.3 will not.
Comment 9 Alin Năstac (RETIRED) gentoo-dev 2008-07-01 18:57:34 UTC
Fixed in cvs, without revision bump. Thanks!