Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 229063 - media-video/streamdvd-0.4-r1 / gcc-4.3 - error: ‘INT_MAX’ was not declared in this scope
Summary: media-video/streamdvd-0.4-r1 / gcc-4.3 - error: ‘INT_MAX’ was not declared in...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: media-video herd
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: gcc-4.3
  Show dependency tree
 
Reported: 2008-06-23 15:52 UTC by Ely Levy
Modified: 2008-07-09 09:24 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
Patch for compilation with gcc-4.3 (streamdvd-0.4-gcc-4.3.patch,1.22 KB, patch)
2008-07-07 21:38 UTC, Bert Karwatzki
Details | Diff
ebuild for patch above (streamdvd-0.4-r2.ebuild,1.58 KB, text/plain)
2008-07-07 21:39 UTC, Bert Karwatzki
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ely Levy 2008-06-23 15:52:52 UTC
media-video/streamdvd-0.4-r1 doesn't compile with libc 2.8_p20080602


Reproducible: Always




>>> Unpacking source...
>>> Unpacking streamdvd-0.4.tar.gz to /var/tmp/portage/media-video/streamdvd-0.4-r1/work
 * Applying streamdvd-0.4.patch ...
  [ ok ]
 * Applying streamdvd-0.4-makefile.patch ...
  [ ok ]
 * Applying streamdvd-0.4-gcc41.patch ...
  [ ok ]
 * Applying streamdvd-0.4-libdvdread.patch ...
  [ ok ]
>>> Source unpacked.
>>> Compiling source in /var/tmp/portage/media-video/streamdvd-0.4-r1/work/StreamDVD-0.4 ...
mplex/inputstrm.cpp: In constructor ‘ElementaryStream::ElementaryStream(IBitStream&, Multiplexor&, ElementaryStream::stream_kind)’:
mplex/inputstrm.cpp:80: error: ‘INT_MAX’ was not declared in this scope
mplex/mplex.cpp: In constructor ‘CmdLineMultiplexJob::CmdLineMultiplexJob(int, int*, int)’:
mplex/mplex.cpp:292: warning: deprecated conversion from string constant to ‘char*’
mplex/multiplexor.cpp: In member function ‘void Multiplexor::OutputDVDPriv2()’:
mplex/multiplexor.cpp:1453: error: ‘memset’ was not declared in this scope
mplex/padstrm.cpp: In member function ‘virtual unsigned int PaddingStream::ReadPacketPayload(uint8_t*, unsigned int)’:
mplex/padstrm.cpp:38: error: ‘memset’ was not declared in this scope
mplex/padstrm.cpp: In member function ‘virtual unsigned int VCDAPadStream::ReadPacketPayload(uint8_t*, unsigned int)’:
mplex/padstrm.cpp:44: error: ‘memset’ was not declared in this scope
mplex/padstrm.cpp: In member function ‘virtual unsigned int DVDPriv2Stream::ReadPacketPayload(uint8_t*, unsigned int)’:
mplex/padstrm.cpp:50: error: ‘memset’ was not declared in this scope
mplex/zalphastrm_in.cpp: In member function ‘virtual void ZAlphaStream::ScanFirstSeqHeader()’:
mplex/zalphastrm_in.cpp:82: error: ‘memcpy’ was not declared in this scope
make: *** [all] Error 1
 * 
 * ERROR: media-video/streamdvd-0.4-r1 failed.
 * Call stack:
 *               ebuild.sh, line   49:  Called src_compile
 *             environment, line 2076:  Called die
 * The specific snippet of code:
 *       emake CC="$(tc-getCC)" CXX="$(tc-getCXX)" all addon || die
 *  The die message:
 *   (no error message)
 * 
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/var/tmp/portage/media-video/streamdvd-0.4-r1/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/media-video/streamdvd-0.4-r1/temp/environment'.
 *
Comment 1 Jeroen Roovers (RETIRED) gentoo-dev 2008-06-23 16:13:19 UTC
Looks like a strictness bug against gcc 4.3, not related to glibc 2.8.
Comment 2 Bert Karwatzki 2008-07-07 21:38:15 UTC
Created attachment 159830 [details, diff]
Patch for compilation with gcc-4.3
Comment 3 Bert Karwatzki 2008-07-07 21:39:34 UTC
Created attachment 159832 [details]
ebuild for patch above
Comment 4 Peter Alfredsen (RETIRED) gentoo-dev 2008-07-09 09:24:32 UTC
+  09 Jul 2008; Peter Alfredsen <loki_val@gentoo.org>
+  +files/streamdvd-0.4-gcc43.patch, streamdvd-0.4-r1.ebuild:
+  Fix for gcc-4.3, bug #229063. Thanks to Bert Karwatzki <spasswolf@web.de>.
+