Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 228373 - net-im/licq-1.3.5 / glibc 2.8 - fifo.cpp:181: error: 'INT_MAX' was not declared in this scope
Summary: net-im/licq-1.3.5 / glibc 2.8 - fifo.cpp:181: error: 'INT_MAX' was not declar...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo net-im Herd
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: glibc-2.8
  Show dependency tree
 
Reported: 2008-06-19 15:30 UTC by Vladimir Smirnov (RETIRED)
Modified: 2008-07-04 15:20 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
patch for licq. (licq-1.3.5.ebuild,4.67 KB, patch)
2008-06-19 15:33 UTC, Vladimir Smirnov (RETIRED)
Details | Diff
patch. (licq-1.3.5-glibc-2.8.patch,1.19 KB, patch)
2008-06-19 15:34 UTC, Vladimir Smirnov (RETIRED)
Details | Diff
fixed typo. (licq-1.3.5-glibc-2.8.patch,1.19 KB, patch)
2008-06-19 15:58 UTC, Vladimir Smirnov (RETIRED)
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Vladimir Smirnov (RETIRED) gentoo-dev 2008-06-19 15:30:37 UTC
fifo.cpp:181: error: 'INT_MAX' was not declared in this scope
Comment 1 Vladimir Smirnov (RETIRED) gentoo-dev 2008-06-19 15:33:26 UTC
Created attachment 157627 [details, diff]
patch for licq.

should fix this issue.
Comment 2 Vladimir Smirnov (RETIRED) gentoo-dev 2008-06-19 15:34:05 UTC
Created attachment 157629 [details, diff]
patch.

sorry. wrong file... 1-st one was ebuild...
Comment 3 Vladimir Smirnov (RETIRED) gentoo-dev 2008-06-19 15:58:30 UTC
Created attachment 157657 [details, diff]
fixed typo.
Comment 4 Petr Zima 2008-06-22 12:45:58 UTC
I guess this bug is a (partial) duplicate of bug #218814, where I posted similar patch. IMHO this bug is related rather to gcc-4.3 than to glibc-2.8.
Comment 5 Vladimir Smirnov (RETIRED) gentoo-dev 2008-06-22 13:19:39 UTC
(In reply to comment #4)
> I guess this bug is a (partial) duplicate of bug #218814, where I posted
> similar patch. IMHO this bug is related rather to gcc-4.3 than to glibc-2.8.
> 

It seems that it is glibc-related. limits.h is glibc's header and some changes in glibc 2.8 requers that limits.h must be included in source code of apps.
Maybe it is partial duplicate, but only partial. Look carefully at patch. It is a bit larger, but it didn't fix  automake bugs (that are caused by gcc).
Comment 6 Petr Zima 2008-06-30 09:05:02 UTC
(In reply to comment #5)
> It seems that it is glibc-related. limits.h is glibc's header and some changes
> in glibc 2.8 requers that limits.h must be included in source code of apps.
> Maybe it is partial duplicate, but only partial. Look carefully at patch. It is
> a bit larger, but it didn't fix  automake bugs (that are caused by gcc).
> 

I already know, your patch does not fix the automake stuff. Apart from that, there is another difference in way, how the INT_MAX issue is fixed. You include <limits.h>, which, of course, is part of glibc. However, in bug #218814 we include <climits>, which is part of gcc. It is the recommended way of fixing INT_MAX errors described at http://gcc.gnu.org/gcc-4.3/porting_to.html. So that is why I think it is rather gcc related. On the other hand <climits> is a C++ header, which includes <limits.h> itself, so maybe your solution is better and it should be decided by the developers.
Comment 7 Vladimir Smirnov (RETIRED) gentoo-dev 2008-06-30 09:59:54 UTC
I've got my variant from http://www.mail-archive.com/licq-dev@googlegroups.com/msg00730.html
This bug appears if glibc 2.8 is installed, no matter if gcc version is 4.2 or 4.3. That's why I think it is glibc-related.
Comment 8 Santiago M. Mola (RETIRED) gentoo-dev 2008-07-04 15:20:12 UTC
Fixed in 1.3.5-r1. Thanks for the patches!