Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 228345 - Subversion is linked against old libpq
Summary: Subversion is linked against old libpq
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Linux bug wranglers
Depends on:
Reported: 2008-06-19 13:11 UTC by Johannes Bauer
Modified: 2008-06-20 18:03 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Johannes Bauer 2008-06-19 13:11:54 UTC
I updated my postgres from 8.0 to 8.3, which included an update from libpq4 to libpq5. Now whenever I emerge subversion, it *still* is linked against libpq4, although libpq4 is not installed any more in my system.

svn: error while loading shared libraries: cannot open shared object file: No such file or directory

Reproducible: Always

Steps to Reproduce:
1. emerge subversion
2. svn

Actual Results:  
svn: error while loading shared libraries: cannot open shared object file: No such file or directory

Expected Results:  
Working svn!

joe [~]: ldd `which svn` =>  (0x00007fffa63fe000) => /usr/lib64/ (0x00002aea049a4000) => /usr/lib64/ (0x00002aea04bcd000) => /usr/lib64/ (0x00002aea04dff000) => /usr/lib64/ (0x00002aea05005000) => /usr/lib64/ (0x00002aea0520d000) => /usr/lib64/ (0x00002aea05414000) => /usr/lib64/ (0x00002aea05635000) => /usr/lib64/ (0x00002aea0583b000) => /usr/lib64/ (0x00002aea05a57000) => /usr/lib64/ (0x00002aea05c80000) => /usr/lib64/ (0x00002aea05e93000) => /usr/lib64/ (0x00002aea060b0000) => /usr/lib64/ (0x00002aea062bc000) => /usr/lib64/ (0x00002aea064ef000) => /usr/lib64/ (0x00002aea0670b000) => /usr/lib64/ (0x00002aea06811000) => /usr/lib64/ (0x00002aea06b2a000) => /usr/lib64/ (0x00002aea06d4a000) => /usr/lib64/ (0x00002aea06fa4000) => /usr/lib64/ (0x00002aea070c5000) => /lib/ (0x00002aea07309000) => /lib/ (0x00002aea0750e000) => /lib/ (0x00002aea07717000) => /lib/ (0x00002aea0794b000) => /usr/lib64/ (0x00002aea07b67000) => /usr/lib64/ (0x00002aea07d87000) => /usr/lib64/ (0x00002aea07fd2000) => /usr/lib64/ (0x00002aea0834a000) => /lib/ (0x00002aea0867e000) => /lib/ (0x00002aea08882000) => /lib/ (0x00002aea08b04000) => /lib/ (0x00002aea08c18000)
	/lib64/ (0x00002aea04788000) => not found
joe [~]: 
joe [~]: ls /usr/lib/libpq*
-rw-r--r-- 1 root root 222K   19.06.2008 14:07:14 /usr/lib/libpq-5.a
lrwxrwxrwx 1 root root    9   19.06.2008 15:01:15 /usr/lib/libpq.a -> libpq-5.a
lrwxrwxrwx 1 root root   12   19.06.2008 14:07:16 /usr/lib/ ->
lrwxrwxrwx 1 root root   12   19.06.2008 14:07:16 /usr/lib/ ->
-rwxr-xr-x 1 root root 127K   19.06.2008 14:07:14 /usr/lib/
Comment 1 Johannes Bauer 2008-06-19 13:13:32 UTC
Portage (default-linux/amd64/2007.0, gcc-4.1.2, glibc-2.6.1-r0, x86_64)
System uname: x86_64 Intel(R) Core(TM)2 CPU 6400 @ 2.13GHz
Timestamp of tree: Mon, 09 Jun 2008 09:30:01 +0000
app-shells/bash:     3.2_p33
dev-java/java-config: 1.3.7, 2.1.6
dev-lang/python:     2.4.4-r13
dev-python/pycrypto: 2.0.1-r6
sys-devel/autoconf:  2.13, 2.61-r1
sys-devel/automake:  1.4_p6, 1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.1
sys-devel/binutils:  2.18-r1
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   1.5.26
virtual/os-headers:  2.6.23-r3
CFLAGS="-O2 -pipe -march=nocona"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-O2 -pipe -march=nocona"
FEATURES="distlocks metadata-transfer parallel-fetch sandbox sfperms strict unmerge-orphans userfetch"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTDIR_OVERLAY="/usr/portage/local/layman/sunrise /usr/local/portage"
USE="3dnow 3dnowext X a52 aac acl acpi aiglx alsa amd64 apache2 avi bash-completion berkdb bluetooth bzip2 cairo cddb cdparanoia cdr cli cracklib crypt cups dri dts dvb dvd dvdr dvdread encode exif fbcon ffmpeg flac foomaticdb gd gdbm gimp gimpprint gnome gpm gstreamer gtk gtk2 iconv ipv6 isdnlog jpeg kqemu lirc loop-aes midi mikmod mmx mmxext mng mp3 mpeg ncurses nls nodrm nptl nptlonly nsplugin nvidia ogg oggvorbis opengl openmp openntpd oss pam pcre perl png postgres postscript ppds pppd readline recode reflection replytolist rtc rtsp samba sasl session smartcard smp snmp spl sqlite sse sse2 ssl subversion svg tcpd theora threads truetype unicode usb v4l v4l2 vorbis xanim xinerama xorg xvid zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="de" USERLAND="GNU" VIDEO_CARDS="nvidia"

Comment 2 DEMAINE Benoît-Pierre, aka DoubleHP 2008-06-19 15:24:08 UTC
This typically sounds like "I forgot to run revdep-rebuild". Please read basic update guides.

If revdep-rebuild does not detects breakage, report the problem as such. If application is broken after recomiling it, specify this explicitely.
Comment 3 DEMAINE Benoît-Pierre, aka DoubleHP 2008-06-19 15:26:10 UTC
steps for a clean update system:

emerge -DaNuv world
elogv # or elogviewer or enotice
revdep-rebuild # several times until no more rebuild.

All this should be run at least once a month.
Comment 4 Jeroen Roovers (RETIRED) gentoo-dev 2008-06-19 17:02:03 UTC
Please run revdep-rebuild from the app-portage/gentoolkit package as suggested and reopen this bug report (with more information) if that does not solve the issue.
Comment 5 Jeroen Roovers (RETIRED) gentoo-dev 2008-06-19 17:11:25 UTC
Comment 6 Johannes Bauer 2008-06-20 17:56:00 UTC
It actually was a dependency of apache2/php5 pulled in by subversion. I ran revdep-rebuild, but the necessary packages were not rebuilt/detected. Emerged them manually and now it works.
Comment 7 DEMAINE Benoît-Pierre, aka DoubleHP 2008-06-20 18:03:12 UTC
if revdep-rebuild did not find the problem, emerge -DaNuv world should have; if not, you could have open a bug against emerge, being unable to reinstall missing deps.

If you ran manually emerge, without option -1, you put in your world libs that are dep, what will prevent in the futur, their removal as deps, the day you want to to remove apache and it's useless deps.

I think you fixed the actual bug, but the bad way.