Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 226801 - net-misc/d4x: patch (d4x-2.5.7.1-gentoo.patch) changes both autotools source and result
Summary: net-misc/d4x: patch (d4x-2.5.7.1-gentoo.patch) changes both autotools source ...
Status: RESOLVED WONTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Desktop Misc. Team
URL:
Whiteboard:
Keywords:
: 226409 (view as bug list)
Depends on:
Blocks: bad-autotools 271645
  Show dependency tree
 
Reported: 2008-06-14 17:17 UTC by Diego Elio Pettenò (RETIRED)
Modified: 2009-08-10 08:41 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Diego Elio Pettenò (RETIRED) gentoo-dev 2008-06-14 17:17:22 UTC
The patch in summary is touching both Makefile.in and Makefile.am, probably to avoid autotools rebuild.

This treatment is usually reserved for a few selected system packages that cannot have their autotool scripts rebuilt.

This _could_ cause maintainermode-driven rebuild (see http://blog.flameeyes.eu/articles/2008/06/13/maintaner-mode ), which is something we should be avoiding as much as possible.

Please just patch Makefile.am and/or configure.in/.ac and rebuild autotools, unless you have very good reasons not to.
Comment 1 Krzysztof Pawlik (RETIRED) gentoo-dev 2008-06-17 12:58:44 UTC
*** Bug 226409 has been marked as a duplicate of this bug. ***
Comment 2 Samuli Suominen gentoo-dev 2009-08-10 08:41:25 UTC
gone