Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 226443 - app-cdr/xcdroast: autotools are being rebuilt through maintainer-mode
Summary: app-cdr/xcdroast: autotools are being rebuilt through maintainer-mode
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: optical media herd
URL:
Whiteboard:
Keywords:
: 255800 (view as bug list)
Depends on: 269032
Blocks: bad-autotools
  Show dependency tree
 
Reported: 2008-06-13 20:45 UTC by Diego Elio Pettenò (RETIRED)
Modified: 2009-06-01 20:22 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Diego Elio Pettenò (RETIRED) gentoo-dev 2008-06-13 20:45:45 UTC
Rebuilding autotools through maintainer-mode is _not_ good, because it usually means you forget to add dependencies, and they'll magically use the same version as used by upstream, which might not be what the user have installed at all.

If you patch Makefile.am or configure.in/configure.ac you _have to_ use autotools.eclass and eautomake/eautoreconf. Exceptions are granted _only_ for system packages that would make it impossible to run autotools during stagebuilding.

Please fix your package.
Comment 1 Diego Elio Pettenò (RETIRED) gentoo-dev 2009-02-09 04:04:25 UTC
*** Bug 255800 has been marked as a duplicate of this bug. ***
Comment 2 Samuli Suominen gentoo-dev 2009-06-01 20:22:38 UTC
fixed with _alpha16