Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 226127 - net-mail/courier-imap-4.1.2-r1 fails with libtool 2.2.4
Summary: net-mail/courier-imap-4.1.2-r1 fails with libtool 2.2.4
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Robin Johnson
URL:
Whiteboard:
Keywords: InVCS
: 232664 (view as bug list)
Depends on:
Blocks: libtool-2.2
  Show dependency tree
 
Reported: 2008-06-12 20:17 UTC by Dan Coats
Modified: 2008-08-20 11:01 UTC (History)
8 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
ebuild w/ recursive autoreconf. (courier-imap-4.1.2-r1.ebuild,8.06 KB, text/plain)
2008-06-15 13:40 UTC, Michael Brakemeier
Details
ERROR: net-mail/courier-imap-4.1.2-r1 failed (build.log,147.45 KB, text/plain)
2008-06-29 14:15 UTC, Moonfire
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Dan Coats 2008-06-12 20:17:38 UTC
courier-imap-4.1.2-r1 fails with libtool 2.2.4

Reproducible: Always

Steps to Reproduce:
1.emerge =net-mail/courier-imap-4.1.2-r1 with libtool-2.2.4
2.
3.

Actual Results:  
Compiling atotimet.c
Compiling atouidt.c
Compiling changeuidgid.c
./libtool: line 466: CDPATH: command not found
./libtool: line 466: CDPATH: command not found
./libtool: line 466: CDPATH: command not found
./libtool: line 1158: func_opt_split: command not found
./libtool: line 1158: func_opt_split: command not found
libtool: Version mismatch error.  This is libtool 2.2.4, but the
libtool: definition of this LT_INIT comes from an older release.
libtool: You should recreate aclocal.m4 with macros from libtool 2.2.4
libtool: and run autoconf again.
./libtool: line 1158: func_opt_split: command not found
libtool: Version mismatch error.  This is libtool 2.2.4, but the
libtool: definition of this LT_INIT comes from an older release.
libtool: You should recreate aclocal.m4 with macros from libtool 2.2.4
libtool: and run autoconf again.
libtool: Version mismatch error.  This is libtool 2.2.4, but the
libtool: definition of this LT_INIT comes from an older release.
libtool: You should recreate aclocal.m4 with macros from libtool 2.2.4
libtool: and run autoconf again.
make[3]: *** [atotimet.lo] Error 1
make[3]: *** Waiting for unfinished jobs....
make[3]: *** [atouidt.lo] Error 1
make[3]: *** [changeuidgid.lo] Error 1
make[3]: Leaving directory `/var/tmp/portage/net-mail/courier-imap-4.1.2-r1/work/courier-imap-4.1.2/numlib'
make[2]: *** [all] Error 2
make[2]: Leaving directory `/var/tmp/portage/net-mail/courier-imap-4.1.2-r1/work/courier-imap-4.1.2/numlib'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/net-mail/courier-imap-4.1.2-r1/work/courier-imap-4.1.2'
make: *** [all] Error 2
 * 
 * ERROR: net-mail/courier-imap-4.1.2-r1 failed.


Expected Results:  
compile

# emerge --info
Portage 2.1.5.4 (default/linux/x86/2008.0/desktop, gcc-4.2.4, glibc-2.8_p20080602-r0, 2.6.25-gentoo-r4 i686)
=================================================================
System uname: 2.6.25-gentoo-r4 i686 AMD Athlon(tm) XP 2500+
Timestamp of tree: Wed, 11 Jun 2008 14:45:02 +0000
ccache version 2.4 [disabled]
app-shells/bash:     3.2_p39
dev-java/java-config: 1.3.7, 2.1.6
dev-lang/python:     2.4.4-r6, 2.5.2-r4
dev-python/pycrypto: 2.0.1-r6
dev-util/ccache:     2.4-r7
sys-apps/baselayout: 2.0.0
sys-apps/openrc:     0.2.5
sys-apps/sandbox:    1.2.18.1-r2
sys-devel/autoconf:  2.13, 2.62
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.1-r1
sys-devel/binutils:  2.18-r1
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   2.2.4
virtual/os-headers:  2.6.25-r4
ACCEPT_KEYWORDS="x86 ~x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=athlon-xp -pipe -fomit-frame-pointer"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/kde/4.0/env /usr/kde/4.0/share/config /usr/kde/4.0/shutdown /usr/share/config /var/bind /var/lib/hsqldb /var/qmail/alias /var/qmail/control /var/vpopmail/etc"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/splash /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-O2 -march=athlon-xp -pipe -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
FEATURES="distlocks parallel-fetch sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://gentoo.osuosl.org/ http://gentoo.cites.uiuc.edu/pub/gentoo/ http://open-systems.ufl.edu/mirrors/gentoo http://mirrors.acm.cs.rpi.edu/gentoo/"
LANG="en_US.utf8"
LDFLAGS=""
LINGUAS="en"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/portage/local/layman/nx /usr/portage/local"
SYNC="rsync://rsync.namerica.gentoo.org/gentoo-portage"
USE="3dnow 3dnowext X a52 aac accessibility acl acpi adns aiglx aim alsa apache2 arts audiofile avahi bash-completion bcmath berkdb bidi bindinst bluetooth branding browserplugin bzip2 cairo calendar caps cdr cli cracklib crypt cups curlwrappers dbus dedicated dga dio divx divx4linux dlloader dri dts dvd dvdr dvdread eds emacs emacs-w3 emboss emerald encode erandom escreen esd ethereal etwin evo examples expat fam fastcgi fbcon fbcondecor ffmpeg firefox font fortran ftp gd gdbm gif glitz glut gnome gnusetup gnutls gpm gs gstreamer gtk gtkhtml hal hardened iconv imap immqt-bc inifile innodb ipod ipv6 isdnlog ithreads java javascript jp2 jpeg jpeg2k kde kerberos krb4 ldap libcaca libclamv libffi libnotify live lm_sensors lzo mad maildir mailwrapper midi mikmod milter mime ming mmap mmx modplug mono motif mozbranding mp3 mp4 mpeg mpi msn mudflap musicbrainz ncurses nls nptl nptlonly nsplugin nvidia oav objc ogg opengl openmp oracle oscar oss pam pcre pdf perl php pic png portaudio posix ppds pppd python qt3 qt3support qt4 quicktime readline real realmedia reflection samba sdl session shared spell spl sqlite sse ssl startup-notification svg symlink tcltktcpd tcpd test threads tiff truetype type1 unicode urandom usb usepackagedmakefiles userlocales vcd vhosts videos vorbis win32codecs wma wmf wxwindows x86 xcomposite xinerama xml xorg xpm xprint xrandr xv xvid xvmc yahoo zeroconf zlib" ALSA_CARDS="intel8x0" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic auth_digest authn_anon authn_dbd authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock dbd deflate dir disk_cache env expires ext_filter file_cache filter headers ident imagemap include info log_config logio mem_cache mime mime_magic negotiation proxy proxy_ajp proxy_balancer proxy_connect proxy_http rewrite setenvif so speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en" USERLAND="GNU" VIDEO_CARDS="nv nvidia vesa"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Rafał Mużyło 2008-06-12 22:40:47 UTC
Could you post full build log ?
Cause what happened is obvious, the question is why didn't macro get updated, while script was.
Comment 2 Rafał Mużyło 2008-06-12 23:04:54 UTC
I've got a bad feeling about this.
Try adding eautoreconf run in ${S}/numlib
If that gets you further, but it stops in a different dir with the same error,
try removing all of the eautoreconf lines except the one in ${S},
but remove AT_NO_RECURSIVE="true" from the call.
Comment 3 Dan Coats 2008-06-13 12:54:25 UTC
link to net-mail:courier-imap-4.1.2-r1:20080613-123959.log
http://rafb.net/p/2ATSnU89.html
Comment 4 Rafał Mużyło 2008-06-13 14:32:40 UTC
First of all, it's a very bad practice to use pastebin-alikes for bugzilla.
Bugzilla is meant to be permanent.
Try following suggestion from comment 2.
By now, I think that the second part applies: a full recursive eautoreconf will be necessary.
Comment 5 Michael Brakemeier 2008-06-15 13:40:40 UTC
Created attachment 156895 [details]
ebuild w/ recursive autoreconf.
Comment 6 Michael Brakemeier 2008-06-15 13:44:37 UTC
Using autoreconf in recursive mode as suggested in comment #2 works fine here.
Attached changed ebuild.

Portage 2.1.5.5 (default/linux/x86/2008.0/desktop, gcc-4.3.1, glibc-2.8_p20080602-r0, 2.6.25-gentoo-r4 i686)
=================================================================
System uname: 2.6.25-gentoo-r4 i686 Intel(R) Pentium(R) M processor 1.86GHz
Timestamp of tree: Sun, 15 Jun 2008 12:45:01 +0000
app-shells/bash:     3.2_p39
dev-java/java-config: 1.3.7, 2.1.6
dev-lang/python:     2.5.2-r4
sys-apps/baselayout: 2.0.0
sys-apps/openrc:     0.2.5
sys-apps/sandbox:    1.2.18.1-r2
sys-devel/autoconf:  2.13, 2.62
sys-devel/automake:  1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.1-r1
sys-devel/binutils:  2.18-r1
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   2.2.4
virtual/os-headers:  2.6.25-r4
ACCEPT_KEYWORDS="x86 ~x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-march=pentium-m -mtune=pentium-m -O3 -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-march=pentium-m -mtune=pentium-m -O3 -pipe"
[...]
Comment 7 Dan Coats 2008-06-16 19:20:03 UTC
the new ebuild fails for me also.
CONFIG_FILES=deliverquota.html CONFIG_HEADERS= /bin/sh ./config.status
CONFIG_FILES=maildirmake.html CONFIG_HEADERS= /bin/sh ./config.status
CONFIG_FILES=deliverquota.8 CONFIG_HEADERS= /bin/sh ./config.status
config.status: creating deliverquota.html
config.status: creating maildirmake.html
config.status: creating deliverquota.8
config.status: executing depfiles commands
config.status: executing depfiles commands
config.status: executing libtool commands
config.status: executing depfiles commands
config.status: executing libtool commands
config.status: executing libtool commands
mv: cannot stat `libtoolT': No such file or directory
CONFIG_FILES=maildirmake.1 CONFIG_HEADERS= /bin/sh ./config.status
CONFIG_FILES=maildiracl.html CONFIG_HEADERS= /bin/sh ./config.status
CONFIG_FILES=maildiracl.1 CONFIG_HEADERS= /bin/sh ./config.status
config.status: creating maildirmake.1
config.status: creating maildiracl.html
config.status: creating maildiracl.1
config.status: executing depfiles commands
config.status: executing depfiles commands
config.status: executing libtool commands
config.status: executing depfiles commands
config.status: executing libtool commands
config.status: executing libtool commands
mv: cannot stat `libtoolT': No such file or directory
echo -lfam >maildir.libdeps
cp: cannot stat `libtoolT': No such file or directory
chmod: cannot access `libtool': No such file or directory
make  all-am
make[3]: Entering directory `/var/tmp/portage/net-mail/courier-imap-4.1.2-r1/work/courier-imap-4.1.2/maildir'
/bin/sh ./libtool --tag=CC   --mode=compile i686-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I.     -O2 -march=athlon-xp -pipe -fomit-frame-pointer -Wall -I./.. -I.. -MT autoresponse.lo -MD -MP -MF .deps/autoresponse.Tpo -c -o autoresponse.lo autoresponse.c
mv -f .deps/autoresponse.Tpo .deps/autoresponse.Plo
mv: cannot stat `.deps/autoresponse.Tpo': No such file or directory
make[3]: *** [autoresponse.lo] Error 1
make[3]: Leaving directory `/var/tmp/portage/net-mail/courier-imap-4.1.2-r1/work/courier-imap-4.1.2/maildir'
make[2]: *** [all] Error 2
make[2]: Leaving directory `/var/tmp/portage/net-mail/courier-imap-4.1.2-r1/work/courier-imap-4.1.2/maildir'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/net-mail/courier-imap-4.1.2-r1/work/courier-imap-4.1.2'
make: *** [all] Error 2
 * 
 * ERROR: net-mail/courier-imap-4.1.2-r1 failed.
 * Call stack:
 *               ebuild.sh, line   49:  Called src_compile
 *             environment, line 2555:  Called die
 * The specific snippet of code:
 *       emake || die "emake failed"
 *  The die message:
 *   emake failed
 * 
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/var/log/portage/net-mail:courier-imap-4.1.2-r1:20080616-182602.log'.
 * The ebuild environment file is located at '/var/tmp/portage/net-mail/courier-imap-4.1.2-r1/temp/environment'.
 * 
Comment 8 Rafał Mużyło 2008-06-16 23:37:52 UTC
Well, if it wasn't for the fact, that it happens before emake,
I'd say these are parallel make issues.
It looks like your emerge runs itself twice or something (a threading issue ?).
Comment 9 Dan Coats 2008-06-17 15:20:04 UTC
I don't know , its only the attached ebuild that does this.
Comment 10 Moonfire 2008-06-29 14:15:27 UTC
Created attachment 158859 [details]
ERROR: net-mail/courier-imap-4.1.2-r1 failed

Hi,

i have the same problem, but an other step at the emerge.
Have a look to attached build.log.
I have re-create all autobuild tools, but it wont help.

BR Maik
Comment 11 Rafał Mużyło 2008-07-01 11:13:38 UTC
What was your result with the ebuild from comment 5 ?
Comment 12 Moonfire 2008-07-01 16:52:59 UTC
(In reply to comment #11)
> What was your result with the ebuild from comment 5 ?
> 

OK, in the portage-tree -r1 is allready exist (this don't work).
I have renamed this ebuild from here as -r2 and build this without errors.

good work
Comment 13 Gregg Casillo 2008-07-19 02:25:27 UTC
I also confirm the attached ebuild (also renamed to -r2 here) works for me. Thanks!
Comment 14 Jeroen Roovers gentoo-dev 2008-07-22 16:05:03 UTC
*** Bug 232664 has been marked as a duplicate of this bug. ***
Comment 15 Ryan Nanney 2008-07-29 14:33:31 UTC
(In reply to comment #5)
> Created an attachment (id=156895) [edit]
> ebuild w/ recursive autoreconf.
> 

I put the ebuild from comment 5 in 
/usr/portage/net-mail/courier-imap/courier-imap-4.1.2-r2.ebuild

then #! emerge courier-imap-4.1.2-r2.ebuild
results in
Traceback (most recent call last):
  File "/usr/bin/emerge", line 18, in <module>
    retval = _emerge.emerge_main()
  File "/usr/lib/portage/pym/_emerge/__init__.py", line 13444, in emerge_main
    myopts, myaction, myfiles, spinner)
  File "/usr/lib/portage/pym/_emerge/__init__.py", line 12504, in action_build
    retval, favorites = mydepgraph.select_files(myfiles)
  File "/usr/lib/portage/pym/_emerge/__init__.py", line 4795, in select_files
    portdb.aux_get(mykey, self._mydbapi_keys))
  File "/usr/lib/portage/pym/portage/dbapi/porttree.py", line 404, in aux_get
    raise KeyError(mycpv)
KeyError: 'net-mail/courier-imap-4.1.2-r2'
Comment 16 Patrick McLean gentoo-dev 2008-07-29 20:19:45 UTC
net-mail/courier-imap-4.4.1 which uses recursive eautoreconf is now in portage.
Comment 17 Laurence Withers 2008-08-20 11:01:51 UTC
Any chance of a 4.1.2-r3 in the meantime? 4.4.1 dies with a segfault for me. I'll post a bug when I have more to go on than just "dies with a segfault".