Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 225447 - dev-libs/gnome-build-0.3.0: compile failure (field ‘reg’ has incomplete type)
Summary: dev-libs/gnome-build-0.3.0: compile failure (field ‘reg’ has incomplete type)
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] GNOME (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Saleem Abdulrasool (RETIRED)
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: glibc-2.8
  Show dependency tree
 
Reported: 2008-06-08 21:02 UTC by yumiko
Modified: 2008-07-08 14:57 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Build log (build.log,54.17 KB, text/plain)
2008-06-08 21:04 UTC, yumiko
Details
patched ebuild (gnome-build-0.3.0.ebuild,1.11 KB, text/plain)
2008-06-12 12:21 UTC, Kristiaan Lenaerts
Details

Note You need to log in before you can comment on or make changes to this bug.
Description yumiko 2008-06-08 21:02:43 UTC
* ERROR: dev-libs/gnome-build-0.3.0 failed.
 * Call stack:
 *               ebuild.sh, line   49:  Called src_compile
 *             environment, line 2576:  Called gnome2_src_compile
 *             environment, line 1957:  Called die
 * The specific snippet of code:
 *       emake || die "compile failure"
 *  The die message:
 *   compile failure

Reproducible: Always

Steps to Reproduce:
1.emerge gnome-build.

Actual Results:  
Compilation failed.

Expected Results:  
Comilation succeded.

Portage 2.1.5.4 (default/linux/x86/2008.0, gcc-4.1.2, glibc-2.8_p20080602-r0, 2.6.24-gentoo-r5 i686)
=================================================================
System uname: 2.6.24-gentoo-r5 i686 AMD Athlon(tm) XP 2500+
Timestamp of tree: Sun, 08 Jun 2008 12:39:02 +0000
app-shells/bash:     3.2_p39
dev-java/java-config: 1.3.7, 2.1.6
dev-lang/python:     2.4.4-r6, 2.5.2-r4
dev-python/pycrypto: 2.0.1-r6
sys-apps/baselayout: 2.0.0
sys-apps/openrc:     0.2.5
sys-apps/sandbox:    1.2.18.1-r2
sys-devel/autoconf:  2.13, 2.62
sys-devel/automake:  1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.1-r1
sys-devel/binutils:  2.18-r1
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   1.5.26
virtual/os-headers:  2.6.25-r3
ACCEPT_KEYWORDS="x86 ~x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=i686 -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-O2 -march=i686 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="distlocks parallel-fetch sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://mirrors.sec.informatik.tu-darmstadt.de/gentoo/ http://ftp-stud.fht-esslingen.de/pub/Mirrors/gentoo/ http://pandemonium.tiscali.de/pub/gentoo/ http://gentoo.prz.rzeszow.pl http://gentoo.zie.pg.gda.pl http://gentoo.po.opole.pl "
LANG="en_GB.UTF-8"
LDFLAGS=""
LINGUAS="en_GB"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/portage/local/layman/desktop-effects"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="3dnow 3dnowext X a52 aac acl acpi alsa anthy apm berkdb bidi bzip2 cairo cddb cdr chasen cjk cli color-console cracklib crypt cups dbus dga dri dvd dvdr dvdread encode exit expat fastcgi ffmpeg flac fortran ftp gdbm gif glade gnome gpm gtk hal iconv ipv6 isdnlog joystick jpeg libnotify libsamplerate lua mad matroska midi mmx mp3 mplayer mudflap musepack mysql nautilus ncurses nls nptl nptlonly nsplugin ogg opengl openmp pam pcre pdf perl php png pppd python readline reflection rtc samba scim session sourceview spell spl sse ssl svg tcpd theora threads tiff truetype tta unicode usb vorbis wavpack win32codecs wma wmf x264 x86 xml xorg xosd xpm xv xvid xvmc zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="mouse keyboard wacom joystick" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en_GB" USERLAND="GNU" VIDEO_CARDS="fglrx"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 yumiko 2008-06-08 21:04:00 UTC
Created attachment 156005 [details]
Build log
Comment 2 Gilles Dartiguelongue gentoo-dev 2008-06-08 21:17:28 UTC
which version of glib and gdl do you have ?
Comment 3 Pat Erley 2008-06-08 23:18:22 UTC
I am also running into this same build error.

glib 2.16.3 and 1.2.10-r5
gdl 0.7.11
Comment 4 Juergen Rose 2008-06-09 03:39:52 UTC
The same here with  dev-libs/glib-2.16.3 and  dev-libs/gdl-0.7.11.
Comment 5 Rémi Cardona (RETIRED) gentoo-dev 2008-06-09 08:58:47 UTC
Looks like glibc 2.8 breakage :) yay phun!
Comment 6 Sven Müller 2008-06-10 12:20:34 UTC
Same here
also glibc-2.8_p20080602 installed
Comment 7 Felix Apitzsch 2008-06-10 13:49:06 UTC
I've got the same libs and the same problem.

http://blog.flameeyes.eu/articles/2008/06/09/recognising-glibc-2-8-failures
lists it as a usual problem with glibc 2.8

Adding "append-flags -D_GNU_SOURCE" to the ebuild didn't help. And I don't know how to add limits.h (which one or where to add).

Any ideas?

Comment 8 Daniel Gryniewicz (RETIRED) gentoo-dev 2008-06-11 19:24:51 UTC
Not maintained by gnome.
Comment 9 Kristiaan Lenaerts 2008-06-12 12:21:45 UTC
Created attachment 156483 [details]
patched ebuild

This is the ebuild I used to install gnome-build.
Comment 10 Felix Apitzsch 2008-06-12 19:49:53 UTC
Your patched ebuild worked for me, too.
It was (nearly) identical to the one I made for myself and reported not to work. My fault: I added the "append-flags -D_GNU_SOURCE", but forgot the "inherit flag-o-matic". Doesn't work without it.
Comment 11 Colin Bennett 2008-06-17 13:42:23 UTC
Kristiaan Lenaerts' fixed ebuild in comment #9 makes it work for me!
Comment 12 Mathieu Segaud 2008-06-26 10:25:06 UTC
(In reply to comment #11)
> Kristiaan Lenaerts' fixed ebuild in comment #9 makes it work for me!
> 

as dev-zero pointed out about the same issue on freeradius, this works, but, in the long-run, this is not the way to do this. Better to provide an ebuild that explicitly patch configure.(in|ac) to have it do the job it should do. Because this problem is independant on Gentoo as soon as glibc 2.8 is used by other distros.
Comment 13 Rémi Cardona (RETIRED) gentoo-dev 2008-07-08 14:57:49 UTC
Ok, I've added a even simpler patch to append the flag. Next versions of gnome-build won't need this hack because the offending code has just been completely removed. I wanted to backport the patch but it was just too big.

Fixed in portage without a revbump.

Thanks