Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 225429 - FEATURES="preserve-libs": sys-devel/gcc (and others) libraries needlessly preserved when moved
Summary: FEATURES="preserve-libs": sys-devel/gcc (and others) libraries needlessly pre...
Status: RESOLVED FIXED
Alias: None
Product: Portage Development
Classification: Unclassified
Component: Core (show other bugs)
Hardware: All All
: High minor (vote)
Assignee: Portage team
URL:
Whiteboard:
Keywords: InVCS
: 232784 240367 (view as bug list)
Depends on:
Blocks: preserve-libs 210077 230275
  Show dependency tree
 
Reported: 2008-06-08 19:19 UTC by Arfrever Frehtes Taifersar Arahesis (RETIRED)
Modified: 2008-11-02 00:56 UTC (History)
6 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Arfrever Frehtes Taifersar Arahesis (RETIRED) gentoo-dev 2008-06-08 19:19:20 UTC
I downgraded sys-devel/gcc-4.2.4 to sys-devel/gcc-4.2.3 and some libraries were needlessly preserved:

!!! existing preserved libs:
>>> package: sys-devel/gcc-4.2.3
 *  - /usr/lib/gcc/i686-pc-linux-gnu/4.2.4/libgcc_s.so
 *  - /usr/lib/gcc/i686-pc-linux-gnu/4.2.4/libgomp.so
 *  - /usr/lib/gcc/i686-pc-linux-gnu/4.2.4/libgomp.so.1
 *  - /usr/lib/gcc/i686-pc-linux-gnu/4.2.4/libstdc++.so
 *  - /usr/lib/gcc/i686-pc-linux-gnu/4.2.4/libstdc++.so.6
 *  - /usr/lib/gcc/i686-pc-linux-gnu/4.2.4/libgcc_s.so.1
 *  - /usr/lib/gcc/i686-pc-linux-gnu/4.2.4/libgomp.so.1.0.0
 *  - /usr/lib/gcc/i686-pc-linux-gnu/4.2.4/libstdc++.so.6.0.9
Use emerge @preserved-rebuild to rebuild packages using these libraries

Next I reinstalled virtual/opengl and these libraries were unpreserved:

<<< !needed   sym /usr/lib/gcc/i686-pc-linux-gnu/4.2.4/libgcc_s.so
<<< !needed   sym /usr/lib/gcc/i686-pc-linux-gnu/4.2.4/libgomp.so
<<< !needed   sym /usr/lib/gcc/i686-pc-linux-gnu/4.2.4/libgomp.so.1
<<< !needed   sym /usr/lib/gcc/i686-pc-linux-gnu/4.2.4/libstdc++.so
<<< !needed   sym /usr/lib/gcc/i686-pc-linux-gnu/4.2.4/libstdc++.so.6
<<< !needed   obj /usr/lib/gcc/i686-pc-linux-gnu/4.2.4/libgcc_s.so.1
<<< !needed   obj /usr/lib/gcc/i686-pc-linux-gnu/4.2.4/libgomp.so.1.0.0
<<< !needed   obj /usr/lib/gcc/i686-pc-linux-gnu/4.2.4/libstdc++.so.6.0.9
Comment 1 Vlastimil Babka (Caster) (RETIRED) gentoo-dev 2008-10-07 07:48:45 UTC
*** Bug 232784 has been marked as a duplicate of this bug. ***
Comment 2 Vlastimil Babka (Caster) (RETIRED) gentoo-dev 2008-10-07 07:52:04 UTC
Same with media-libs/libkipi-0.1.6 - 0.1.6-r1 upgrade (move from /usr/lib to kde prefix). On emerge @preserved-rebuild the depending packages keep linking to the preserved versions... I guess the workaround is to delete the old libraries manually and emerge @preserved-rebuild to relink and clean it up?
Comment 3 Vlastimil Babka (Caster) (RETIRED) gentoo-dev 2008-10-07 07:58:27 UTC
(In reply to comment #2)
> I guess the workaround is to delete the old
> libraries manually and emerge @preserved-rebuild to relink and clean it up?
 
Hm no, after the manual rm the @preserved-rebuild becomes empty set, leaving the files missing in CONTENTS. Not totally clean but bearable I guess...
Comment 4 Zac Medico gentoo-dev 2008-10-07 15:23:57 UTC
*** Bug 240367 has been marked as a duplicate of this bug. ***
Comment 5 Graham Murray 2008-10-08 05:55:09 UTC
(In reply to comment #3)
> Hm no, after the manual rm the @preserved-rebuild becomes empty set, leaving
> the files missing in CONTENTS. Not totally clean but bearable I guess...
> 

Or note which packages are in @preserved-rebuild and manually re-emerge them after deleting the old libraries.
Comment 6 Zac Medico gentoo-dev 2008-10-30 03:05:23 UTC
This is fixed in svn r11746.
Comment 7 Zac Medico gentoo-dev 2008-10-30 04:09:19 UTC
Actually, the fix in svn r11746 will only work after /etc/ld.so.conf has been updated with the new paths. I guess we'll have to trigger the relevant code right after ld.so.conf has been updated.
Comment 8 Zac Medico gentoo-dev 2008-10-30 08:10:24 UTC
Should be all fixed now, as of r11749.
Comment 9 Zac Medico gentoo-dev 2008-11-02 00:56:38 UTC
This is fixed in 2.2_rc13.