Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 225393 - dev-libs/libnl-1.1-r1 /w glibc-2.8 update: ULONG_MAX undeclared
Summary: dev-libs/libnl-1.1-r1 /w glibc-2.8 update: ULONG_MAX undeclared
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Library (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Netmon Herd
URL:
Whiteboard:
Keywords:
: 225497 (view as bug list)
Depends on:
Blocks: glibc-2.8
  Show dependency tree
 
Reported: 2008-06-08 17:17 UTC by Tobias Senner
Modified: 2008-06-09 08:06 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tobias Senner 2008-06-08 17:17:33 UTC
Build fails:
In file included from addr.c:29:
../include/netlink-local.h: In function '__str2type':
../include/netlink-local.h:218: error: 'ULONG_MAX' undeclared (first use in this function)
../include/netlink-local.h:218: error: (Each undeclared identifier is reported only once
../include/netlink-local.h:218: error: for each function it appears in.)
../include/netlink-local.h: In function '__list_str2type':
../include/netlink-local.h:239: error: 'ULONG_MAX' undeclared (first use in this function)
make[2]: *** [addr.o] Error 1
make[2]: *** Waiting for unfinished jobs....
In file included from cache.c:44:
../include/netlink-local.h: In function '__str2type':
../include/netlink-local.h:218: error: 'ULONG_MAX' undeclared (first use in this function)
../include/netlink-local.h:218: error: (Each undeclared identifier is reported only once
../include/netlink-local.h:218: error: for each function it appears in.)
../include/netlink-local.h: In function '__list_str2type':
../include/netlink-local.h:239: error: 'ULONG_MAX' undeclared (first use in this function)
In file included from attr.c:13:
../include/netlink-local.h: In function '__str2type':
../include/netlink-local.h:218: error: 'ULONG_MAX' undeclared (first use in this function)
../include/netlink-local.h:218: error: (Each undeclared identifier is reported only once
../include/netlink-local.h:218: error: for each function it appears in.)
../include/netlink-local.h: In function '__list_str2type':
../include/netlink-local.h:239: error: 'ULONG_MAX' undeclared (first use in this function)
make[2]: *** [cache.o] Error 1
make[2]: *** [attr.o] Error 1
make[1]: *** [all] Error 2
make: *** [all] Error 2

Patch from http://www.mail-archive.com/pld-cvs-commit@lists.pld-linux.org/msg142643.html
fixed it.

# cat files/libnl-1.1-ULONG_MAX.patch
--- libnl-1.1/include/netlink-local.h.orig	2008-06-08 19:09:20.000000000 +0200
+++ libnl-1.1/include/netlink-local.h	2008-06-08 19:09:33.000000000 +0200
@@ -26,6 +26,7 @@
 #include <sys/socket.h>
 #include <inttypes.h>
 #include <assert.h>
+#include <limits.h>
 
 #include <arpa/inet.h>
 #include <netdb.h>



Reproducible: Always
Comment 1 Peter Volkov (RETIRED) gentoo-dev 2008-06-09 07:56:21 UTC
*** Bug 225497 has been marked as a duplicate of this bug. ***
Comment 2 Peter Volkov (RETIRED) gentoo-dev 2008-06-09 08:06:53 UTC
Thank you for report. Fixed in CVS.