Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 225369 - net-nds/openldap-2.3.41-r1 fails to compile with glibc-2.8 (storage size of 'peercred' isn't known)
Summary: net-nds/openldap-2.3.41-r1 fails to compile with glibc-2.8 (storage size of '...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High normal with 1 vote (vote)
Assignee: LDAP Herd
URL:
Whiteboard:
Keywords:
: 225515 225897 226103 (view as bug list)
Depends on:
Blocks: glibc-2.8
  Show dependency tree
 
Reported: 2008-06-08 15:13 UTC by Daniel Drake (RETIRED)
Modified: 2008-07-20 10:19 UTC (History)
34 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
openldap2-add-gnu-source.diff (openldap2-add-gnu-source.diff,371 bytes, text/plain)
2008-06-09 12:01 UTC, Timo Gurr (RETIRED)
Details
Fixed error and other distro's patch (openldap-2.3.41-r1-fixed-peercred-error.patch,385 bytes, patch)
2008-06-12 09:51 UTC, Tom-Steve Watzke
Details | Diff
Fixed ebuild now patching the src file. (openldap-2.3.41-r1.ebuild,17.35 KB, text/plain)
2008-06-12 09:54 UTC, Tom-Steve Watzke
Details
folder including updated ebuild, patch and manifest ready for an overlay (net-nds.tar.gz,13.92 KB, text/plain)
2008-06-15 14:28 UTC, Billy DeVincentis
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Daniel Drake (RETIRED) gentoo-dev 2008-06-08 15:13:55 UTC
cc -O2 -march=prescott -fomit-frame-pointer -pipe -I../../include        -I../../include   -I/usr/include/db4.5    -I/usr/include/db4.5  -c -o getpeereid.o getpeereid.c
getpeereid.c: In function 'getpeereid':
getpeereid.c:52: error: storage size of 'peercred' isn't known

line 52 is:
        struct ucred peercred;

top of the file has:
#if HAVE_SYS_UCRED_H
#if HAVE_GRP_H
#include <grp.h>        /* for NGROUPS on Tru64 5.1 */
#endif
#include <sys/ucred.h>
#endif

my system does not have sys/ucred.h and hence HAVE_SYS_UCRED_H is not defined.

found a fix from another distro:
http://recipes.gobolinux.org/r/?list=OpenLDAP&ver=2.3.39-r2&file=01-ucred.patch
no idea if it's correct

Portage 2.1.5.4 (default-linux/x86/2007.0/desktop, gcc-4.2.4, glibc-2.8_p20080602-r0, 2.6.25-gentoo-r4 i686)
=================================================================
System uname: 2.6.25-gentoo-r4 i686 Genuine Intel(R) CPU T2500 @ 2.00GHz
Timestamp of tree: Sun, 08 Jun 2008 14:00:01 +0000
app-shells/bash:     3.2_p39
dev-lang/python:     2.5.2-r4
dev-python/pycrypto: 2.0.1-r6
sys-apps/baselayout: 2.0.0
sys-apps/openrc:     0.2.5
sys-apps/sandbox:    1.2.18.1-r2
sys-devel/autoconf:  2.13, 2.62
sys-devel/automake:  1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.1-r1
sys-devel/binutils:  2.18-r1
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   1.5.26
virtual/os-headers:  2.6.25-r3
ACCEPT_KEYWORDS="x86 ~x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=prescott -fomit-frame-pointer -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/terminfo /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-O2 -march=prescott -fomit-frame-pointer -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoaddcvs candy cvs distlocks noinfo parallel-fetch sandbox sfperms strict unmerge-orphans userfetch userpriv usersandbox"
GENTOO_MIRRORS="http://distfiles.gentoo.org http://distro.ibiblio.org/pub/linux/distributions/gentoo"
LANG="en_GB.utf8"
LDFLAGS="-Wl,--as-needed -Wl,-O1 -Wl,--sort-common"
LINGUAS="en_GB"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_EXTRA_OPTS="--exclude=metadata.xml --exclude=ChangeLog"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage /usr/portage/local/layman/brontes3d"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X aac acpi aiglx alsa bash-completion cairo cddb cdparanoia cdr custom-cflags daap dbus dell dri dvd dvdr dvdread firefox gnome gtk gtk2 hal id3 jpeg lame libnotify mad mmx mono mozbranding moznocompose moznoirc moznomail mp3 no-old-linux nptl nptlonly opengl pdf png rtc smp sse sse2 ssl startup-notification svg threads tiff truetype truetype-fonts x86 xcb xorg xulrunner xvid" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 	emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m 	maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="evdev keyboard mouse synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en_GB" USERLAND="GNU" VIDEO_CARDS="fbdev vesa vga i810"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS
Comment 1 Jose daLuz 2008-06-08 18:43:08 UTC
Same error here, after update to glibc 2.8_p20080602.

Portage 2.1.5.4 (default-linux/amd64/2007.0/desktop, gcc-4.3.0, glibc-2.8_p20080602-r0, 2.6.25-gentoo-r4 x86_64)
=================================================================
System uname: 2.6.25-gentoo-r4 x86_64 AMD Athlon(tm) 64 X2 Dual Core Processor 6000+
Timestamp of tree: Sun, 08 Jun 2008 01:35:01 +0000
ccache version 2.4 [enabled]
app-shells/bash:     3.2_p39
dev-java/java-config: 1.3.7, 2.1.6
dev-lang/python:     2.5.2-r4
dev-python/pycrypto: 2.0.1-r6
dev-util/ccache:     2.4-r7
sys-apps/baselayout: 2.0.0
sys-apps/openrc:     0.2.5
sys-apps/sandbox:    1.2.18.1-r2
sys-devel/autoconf:  2.13, 2.62
sys-devel/automake:  1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.1-r1
sys-devel/binutils:  2.18-r1
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   2.2.4
virtual/os-headers:  2.6.25-r3
ACCEPT_KEYWORDS="amd64 ~amd64"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=k8 -O2 -pipe -ggdb -msse3"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-march=k8 -O2 -pipe -ggdb -msse3"
DISTDIR="/usr/portage/distfiles"
FEATURES="ccache distlocks fixpackages parallel-fetch sandbox sfperms splitdebug strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://gentoo.osuosl.org/ http://distro.ibiblio.org/pub/linux/distributions/gentoo/"
LANG="en_US.UTF-8"
LC_ALL="en_US.UTF-8"
LDFLAGS=""
LINGUAS="en"
MAKEOPTS="-j4"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/overlays/paludis-extras /usr/local/overlays/sunrise /usr/local/overlays/gnome /usr/local/overlays/mainline /usr/local/overlays/desktop-effects /usr/local/overlays/vmware /usr/local/overlays/berkano /usr/local/overlays/myoverlay"
SYNC="rsync://rsync.us.gentoo.org/gentoo-portage"
USE="X a52 aac acl acpi alsa amd64 amr bash-completion berkdb bluetooth bzip2 cairo cdda cdr cli cracklib crypt css cups dbus dri dts dvd dvdr dvdread eds emboss encode esd evo fam ffmpeg flac fortran gdbm gif glitz gnome gpm gstreamer gtk hal iconv ipv6 isdnlog java jpeg kde kdehiddenvisibility kerberos ldap libnotify mad midi mikmod mmx mono mp3 mpeg mudflap ncurses nls nptl nptlonly ogg opengl openmp pam pcre pdf perl pic png pppd python qt3support qt4 quicktime readline reflection ruby samba sdl session spell spl sqlite sse sse2 ssl svg tcpd theora tiff truetype unicode usb userlocales vcd vorbis x264 xml xorg xulrunner xv xvid zlib" ALSA_CARDS="cmipci hdaintel" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en" USERLAND="GNU" VIDEO_CARDS="nvidia"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 2 Markus Ullmann (RETIRED) gentoo-dev 2008-06-09 08:46:43 UTC
*** Bug 225515 has been marked as a duplicate of this bug. ***
Comment 3 Timo Gurr (RETIRED) gentoo-dev 2008-06-09 12:01:20 UTC
Created attachment 156071 [details]
openldap2-add-gnu-source.diff

Patch borrowed from openSUSE, couldn't test if it works yet since all my machines are compiling glibc at the moment, but it looks pretty much the same like the patch which will be needed for cups.
Comment 4 Daniel Drake (RETIRED) gentoo-dev 2008-06-09 12:14:14 UTC
that fixes it, thanks
Comment 5 Bob Raitz 2008-06-10 20:53:20 UTC
(In reply to comment #4)
> that fixes it, thanks
> 

So, the question is, for those of use who now have the problem, when is the fix going to hit portage?
Comment 6 Bernard Cafarelli gentoo-dev 2008-06-11 13:26:36 UTC
*** Bug 225897 has been marked as a duplicate of this bug. ***
Comment 7 Guillaume Castagnino 2008-06-11 13:34:14 UTC
Hi,

Just to inform that the same fix apply to openldap-2.4.10
Comment 8 Tom-Steve Watzke 2008-06-12 09:51:43 UTC
Created attachment 156475 [details, diff]
Fixed error and other distro's patch

I just made a patch and ebuild according to this error and bug.
Comment 9 Tom-Steve Watzke 2008-06-12 09:54:01 UTC
Created attachment 156477 [details]
Fixed ebuild now patching the src file.

Ebuild using the patch.
Comment 10 Carsten Lohrke (RETIRED) gentoo-dev 2008-06-12 23:16:57 UTC
*** Bug 226103 has been marked as a duplicate of this bug. ***
Comment 11 Billy DeVincentis 2008-06-15 14:10:04 UTC
This fix works for me!!
Comment 12 Billy DeVincentis 2008-06-15 14:28:17 UTC
Created attachment 156915 [details]
folder including updated ebuild, patch and manifest ready for an overlay
Comment 13 James Shaw (Simba7) 2008-06-18 17:41:59 UTC
(In reply to comment #12)
> Created an attachment (id=156915) [edit]
> folder including updated ebuild, patch and manifest ready for an overlay
> 

Adding support for db-4.6 would be a huge plus.
Comment 14 Ian Abbott 2008-06-23 17:10:24 UTC
I see net-nds/openldap-2.3.41-r1.ebuild now includes the following in src_compile():

	#Fix for glibc-2.8 and ucred. Bug 228457.
	append-flags -D_GNU_SOURCE

Should that have used 'append-cppflags' or does it make no difference?
Comment 15 zym 2008-06-28 15:06:30 UTC
if 'append-flags -D_GNU_SOURCE' works for both 2.4.x and 2.3.x, should we fix version 2.4.x too? I still can not build openldap 2.4.10.

getpeereid.c: In function 'lutil_getpeereid':
getpeereid.c:64: error: storage size of 'peercred' isn't known
make[2]: *** [getpeereid.o] Error 1
make[2]: *** Waiting for unfinished jobs....
make[2]: Leaving directory `/var/tmp/portage/net-nds/openldap-2.4.10/work/openldap-2.4.10/libraries/liblutil'
make[1]: *** [all-common] Error 1
make[1]: Leaving directory `/var/tmp/portage/net-nds/openldap-2.4.10/work/openldap-2.4.10/libraries'
make: *** [all-common] Error 1
 * 
 * ERROR: net-nds/openldap-2.4.10 failed.
Comment 16 valentin 2008-06-29 12:54:12 UTC
(In reply to comment #15)
> if 'append-flags -D_GNU_SOURCE' works for both 2.4.x and 2.3.x, should we fix
> version 2.4.x too? I still can not build openldap 2.4.10.
> 
> getpeereid.c: In function 'lutil_getpeereid':
> getpeereid.c:64: error: storage size of 'peercred' isn't known
> make[2]: *** [getpeereid.o] Error 1
> make[2]: *** Waiting for unfinished jobs....
> make[2]: Leaving directory
> `/var/tmp/portage/net-nds/openldap-2.4.10/work/openldap-2.4.10/libraries/liblutil'
> make[1]: *** [all-common] Error 1
> make[1]: Leaving directory
> `/var/tmp/portage/net-nds/openldap-2.4.10/work/openldap-2.4.10/libraries'
> make: *** [all-common] Error 1
>  * 
>  * ERROR: net-nds/openldap-2.4.10 failed.
> 

i've first tried with adding vanilla di glibc and then adding the workaround for glibc i was able to compile openldap 2.4.10.
Comment 17 Peter Alfredsen (RETIRED) gentoo-dev 2008-07-20 10:19:09 UTC
Fixed in CVS with append-flags