Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 225103 - emerge fails when installing/upgrading ruby, boost or cups
Summary: emerge fails when installing/upgrading ruby, boost or cups
Status: VERIFIED WONTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: AMD64 Linux
: High major (vote)
Assignee: Gentoo Linux bug wranglers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-06-06 10:47 UTC by LanoxxthShaddow
Modified: 2008-06-14 11:21 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build log file from ruby (build.log,23.80 KB, text/plain)
2008-06-06 10:49 UTC, LanoxxthShaddow
Details
ruby environment file (environment,123.20 KB, text/plain)
2008-06-06 10:50 UTC, LanoxxthShaddow
Details
boost build.log (build.log,2.21 KB, text/plain)
2008-06-06 10:51 UTC, LanoxxthShaddow
Details
environment file for boost (environment,120.75 KB, text/plain)
2008-06-06 10:51 UTC, LanoxxthShaddow
Details

Note You need to log in before you can comment on or make changes to this bug.
Description LanoxxthShaddow 2008-06-06 10:47:55 UTC
Emerging boost, ruby or cups fails for no obvious reasons.

Reproducible: Always

Steps to Reproduce:
1. emerge -av --upgrade --deep --newuse world
2. process starts, some ebuilds complete
3. at a certain process, in my case ruby, boost or cups the process fails

Actual Results:  
Compiling fails with the errors posted below.

Expected Results:  
The compilation should have succeeded.

below are build.log, environment, uname -a, emerge -pv coreutils (i reinstalled it too

uname -a: Linux pluto 2.6.25-tuxonice-r1 #3 SMP PREEMPT Tue May 6 14:29:33 CEST 2008 x86_64 Intel(R) Core(TM)2 Duo CPU T7100 @ 1.80GHz GenuineIntel GNU/Linux

sudo emerge -pv coreutils
Password: 

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R   ] sys-apps/coreutils-6.10-r2  USE="acl nls (-selinux) -static -vanilla -xattr" 0 kB 

Total: 1 package (1 reinstall), Size of downloads: 0 kB
Comment 1 LanoxxthShaddow 2008-06-06 10:49:36 UTC
Created attachment 155701 [details]
build log file from ruby

out put from emerge
Comment 2 LanoxxthShaddow 2008-06-06 10:50:22 UTC
Created attachment 155703 [details]
ruby environment file

this file was mentioned in build.log
Comment 3 LanoxxthShaddow 2008-06-06 10:51:01 UTC
Created attachment 155705 [details]
boost build.log
Comment 4 LanoxxthShaddow 2008-06-06 10:51:25 UTC
Created attachment 155707 [details]
environment file for boost
Comment 5 LanoxxthShaddow 2008-06-06 10:58:56 UTC
Portage 2.1.4.4 (default-linux/amd64/2007.0, gcc-4.1.2, glibc-2.6.1-r0, 2.6.25-tuxonice-r1 x86_64)
=================================================================
System uname: 2.6.25-tuxonice-r1 x86_64 Intel(R) Core(TM)2 Duo CPU T7100 @ 1.80GHz
Timestamp of tree: Thu, 05 Jun 2008 22:45:03 +0000
app-shells/bash:     3.2_p33
dev-java/java-config: 1.3.7, 2.1.6
dev-lang/python:     2.4.4-r13
dev-python/pycrypto: 2.0.1-r6
sys-apps/baselayout: 1.12.11.1
sys-apps/sandbox:    1.2.18.1-r2
sys-devel/autoconf:  2.13, 2.61-r1
sys-devel/automake:  1.4_p6, 1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.1
sys-devel/binutils:  2.18-r1
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   1.5.26
virtual/os-headers:  2.6.23-r3
ACCEPT_KEYWORDS="amd64"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -pipe -march=nocona"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config /var/bind"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/revdep-rebuild /etc/terminfo /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-O2 -pipe -march=nocona"
DISTDIR="/usr/portage/distfiles"
FEATURES="distlocks metadata-transfer sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://ftp-stud.fht-esslingen.de/pub/Mirrors/gentoo/ ftp://ftp-stud.fht-esslingen.de/pub/Mirrors/gentoo/ http://78.46.32.117/ ftp://ftp.mneisen.org/gentoo http://linux.rz.ruhr-uni-bochum.de/download/gentoo-mirror/ http://ftp.club-internet.fr/pub/mirrors/gentoo"
LANG="en_GB.UTF-8"
LINGUAS="en en_GB de zh_CN"
MAKEOPTS="-j -l 4.0"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="X aac aalib acl acpi alsa amd64 arts automount berkdb cjk cli cracklib cups dbus directfb doc dri dvb dvd fortran gdbm gnutls gpm gtk hal hdaps iconv ipv6 ipw4965 isdnlog java jpeg kde mad midi mmx mp3 mudflap ncurses netboot nls nptl nptlonly ntfs opengl openmp oss pam pcre pdf perl png pppd python qt3 qt3support qt4 rdesktop readline reflection resolvconf samba session smp spl sse sse2 ssl svg swat tcpd tiff truetype unicode upnp vorbis wavpack winbind wmf wxwindows xorg zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="evdev keyboard mouse synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en en_GB de zh_CN" USERLAND="GNU" VIDEO_CARDS="i810"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, LDFLAGS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, PORTDIR_OVERLAY

Comment 6 Jeroen Roovers gentoo-dev 2008-06-06 12:59:27 UTC
MAKEOPTS="-j -l 4.0"

You probably don't want to set -j except as -jN where N denotes the number of concurrent processes. Please see if that fixes the issue.
Comment 7 Jeroen Roovers gentoo-dev 2008-06-06 13:48:57 UTC
The boost build simply fails because apparently the MAKEOPTS variable gets mangled in the ebuild:

   NUMJOBS=$(sed -e 's/.*\(\-j[ 0-9]\+\) .*/\1/' <<< ${MAKEOPTS})

which results in 4.0 being a make target. There has been much discussion on the gentoo-dev mailing list about valid values for MAKEOPTS, and I think it was generally agreed that only -j is regarded as valid.
Comment 8 Jeroen Roovers gentoo-dev 2008-06-07 14:51:26 UTC
MAKEOPTS=-j[N] it is.
Comment 9 LanoxxthShaddow 2008-06-14 11:21:42 UTC
(In reply to comment #8)
> MAKEOPTS=-j[N] it is.
> 

yes, that did it. Thanks alot. :-)