Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 224683 - Samba-3.2.0_pre2 cannot find provided shared libraries
Summary: Samba-3.2.0_pre2 cannot find provided shared libraries
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo's SAMBA Team
Depends on:
Reported: 2008-06-02 23:30 UTC by dynamotwain
Modified: 2008-09-07 13:38 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description dynamotwain 2008-06-02 23:30:41 UTC
Samba 3.2.0_pre2 binaries cannot find shared libraries in the /usr/lib/samba directory. smbd, nmbd, smbclient, etc link to and, preventing them from loading, rendering samba unusable.

I resolved the problem by adding a file to /etc/env.d containing
LDPATH="/usr/lib/samba" and running env-update, but in theory the problem could be solved by injecting rpath linker flags into the Samba ebuild.

In any case, there is a dynamic linking issue that prevents launching any samba 3.2.0 binaries without manual "tweaking".
Comment 1 Jeroen Roovers (RETIRED) gentoo-dev 2008-06-03 01:46:07 UTC
Your `emerge --info' too, please.
Comment 2 dynamotwain 2008-06-03 02:12:32 UTC
Portage (default/linux/x86/2008.0, gcc-4.1.2, glibc-2.6.1-r0, 2.6.25-tuxonice-r3 i686)
System uname: 2.6.25-tuxonice-r3 i686 Intel(R) Pentium(R) M processor 1.86GHz
Timestamp of tree: Mon, 02 Jun 2008 05:20:01 +0000
app-shells/bash:     3.2_p33
dev-java/java-config: 1.3.7, 2.1.4
dev-lang/python:     2.5.2-r4
dev-python/pycrypto: 2.0.1-r6
sys-apps/baselayout: 2.0.0
sys-apps/openrc:     0.2.5
sys-devel/autoconf:  2.13, 2.61-r1
sys-devel/automake:  1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.1
sys-devel/binutils:  2.18-r1
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   1.5.26
virtual/os-headers:  2.6.23-r3
CFLAGS="-O2 -march=i686 -march=pentium3 -mtune=pentium-m -pipe"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/kde/4.0/env /usr/kde/4.0/share/config /usr/kde/4.0/shutdown /usr/share/config /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/splash /etc/terminfo /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-O2 -march=i686 -march=pentium3 -mtune=pentium-m -pipe"
FEATURES="distlocks metadata-transfer parallel-fetch sandbox sfperms strict unmerge-orphans userfetch"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTDIR_OVERLAY="/usr/local/portage/layman/vmware /usr/local/portage/layman/desktop-effects /usr/local/portage/layman/x11 /usr/local/portage/layman/bazaar /usr/local/portage/local"
USE="X X509 a52 aac accessibility acl acpi ads aiglx aim alsa animation ao aoss apache2 applet artworkextra asf async avahi bash-completion berkdb binfilter blender-game bogofilter bonjour branding bzip2 bzr cairo cardbus cdda cddb cdparanoia cdr cgi chm cli cracklib crypt cscope css cups curl daap dbus dhcp dmi dri dssi dts dv dvd dvdr dvdread dvi effects emerald enblend encode exif fam fat fbcon fbcondecor fbsplash ffmpeg firefox flac fortran galago gconf gd gdbm gif gimp git glib glitz glx gnome gnome-keyring gnome-print gpg gphoto2 gpm graphics gs gsf gstreamer gtk gtkhtml gtksourceview gtkspell hal hbci hdri howl-compat iconv id3 ieee1394 imagemagick imlib inkjar ipod iptc ipv6 isdnlog jack javascript jikes joystick jpeg jpeg2k kdeenablefinal ladcca ladspa laptop latin1 lcms libnotify libsamplerate lirc lzo mad maildir mdnsresponder-compat midi mjpeg mng modplug mono mozbranding mozdevelop mp3 mp4 mpeg mplayer msn mtp mudflap music musicbrainz nautilus ncurses netbeans network networkmanager newspr nls nptl nptlonly ntp offensive ofx ogg oggvorbis openal openexr opengl opengl-video opengl-xvmc openmp oscar pam pango pcmcia pcre pdf perl pidgin plugin png postscript pppd prediction profile pvr python qt3 qt3support qt4 quicktime quotas quotes raw readline reflection replaygain rtc samba sasl scanner sdk sdl session sftp sift silc skey skins slp smbkrb5passwd sndfile sound sounds soup speex spell spl sqlite sqlite3 ssl startup-notification stream stroke subtitles subversion svg sysfs tagwriting talkfilters tcpd teletext tetex theora threads thumbnailing thunderbird tiff timidity tokenizer tracker transcode truetype unicode unsupported upnp urandom usb userlocales v4l v4l2 vhosts videos vim vim-pager vim-syntax vim-with-x vlm vorbis webdav widescreen wifi winbind wma wxwindows x264 x86 xanim xcb xcomposite xetex xine xinerama xml xorg xosd xprint xrandr xscreensaver xv xvid xvmc zlib zvbi" ALSA_CARDS="hda-intel virmidi" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic auth_digest authn_anon authn_dbd authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock dbd deflate dir disk_cache env expires ext_filter file_cache filter headers ident imagemap include info log_config logio mem_cache mime mime_magic negotiation proxy proxy_ajp proxy_balancer proxy_connect proxy_http rewrite setenvif so speling status unique_id userdir usertrack vhost_alias" APACHE2_MPMS="worker" CAMERAS="canon ptp2" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en_US" LIRC_DEVICES="devinput mceusb2" USERLAND="GNU" VIDEO_CARDS="nvidia vesa"
Comment 3 Alois Hammer 2008-07-02 13:21:26 UTC
Just for reference, I tested this against samba-3.2.0 final by creating a slightly modified ebuild with SRC_URI="mirror://samba/${MY_P}.tar.gz" to pick up the release code.  Same library bug as previously described.
Comment 4 Tiziano Müller (RETIRED) gentoo-dev 2008-09-07 13:38:09 UTC
Solved in my overlay.