Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 224089 - media-plugins/audacious-plugins-1.5.1 - cdio/cdda.h: No such file or directory
Summary: media-plugins/audacious-plugins-1.5.1 - cdio/cdda.h: No such file or directory
Status: VERIFIED INVALID
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Tony Vroon
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-05-29 13:03 UTC by Kiril Vladimirov
Modified: 2008-05-31 19:00 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Kiril Vladimirov 2008-05-29 13:03:24 UTC
I a bug with audacious-plugins 1.5.1. When I install audacious 
1.5.1, audacious-plugins depends on it. But in the middle of compiling of
audacious-plugins it just... 
Entering directory demac.
Successfully generated dependencies.
Successfully compiled plugin.c.
Successfully compiled apev2.c.
Successfully compiled ape.c.
Successfully compiled apedec.c.
Successfully linked demac.so.
Leaving directory demac.
Entering directory cdaudio-ng.
cdaudio-ng.c:40:23: error: cdio/cdda.h: No such file or directory
make[6]: *** [cdaudio-ng.dep] Error 1
Failed to generate dependencies!
make[5]: *** [depend] Error 1
make[4]: *** [all] Error 1
make[3]: *** [subdirs] Error 1
make[2]: *** [all] Error 1
make[1]: *** [subdirs] Error 1
make: *** [all] Error 1

!!! ERROR in media-plugins/audacious-plugins-1.5.1:
!!! In src_compile at line 3610
!!! make failed

!!! Call stack:
!!!    * src_compile
(/var/tmp/paludis/media-plugins-audacious-plugins-1.5.1/temp/loadsaveenv:3610)
!!!    * ebuild_f_compile (/usr/libexec/paludis/0/src_compile.bash:49)
!!!    * ebuild_main (/usr/libexec/paludis/ebuild.bash:460)
!!!    * main (/usr/libexec/paludis/ebuild.bash:479)

diefunc: making ebuild PID 27504 exit with error
die trap: exiting with error.

Install error:
  * In program paludis (--checks none --dl-reinstall if-use-changed) -i world:
  * When performing install action from command line:
  * When executing install task:
  * When installing 'media-plugins/audacious-plugins-1.5.1:0::gentoo':
  * Install error: Install failed for
'media-plugins/audacious-plugins-1.5.1:0::gentoo'



Summary of failures:

* media-plugins/audacious-plugins-1.5.1:0::gentoo: failure

Total: 3 packages, 2 successes, 0 skipped, 1 failure, 0 unreached

Resume command: paludis --log-level qa --install --add-to-world-spec 'world'
--serialised 0.25
'package;=dev-libs/libmcs-0.7.1-r2:0::gentoo;installed;has_all_deps;S'
'package;=media-sound/audacious-1.5.1:0::gentoo;installed;has_all_deps;S'
'package;=media-plugins/audacious-plugins-1.5.1:0::gentoo;installed;has_all_deps;P'

 * No unread news items found

 * Searching for configuration files requiring action...
 * No configuration file updates required

gentoo #

I have this problem with portage, too.

Reproducible: Always

Steps to Reproduce:
1.I sync package manager(paludis -s )
2.Executing paludis -i world
3.Then media-sound/audacious-1.5.1 and media-plugins/audacious-plugins want to be updated.
4.media-sound/audacious-1.5.1 is compiling at well, but media-plugins/audacious-plugin-1.5.1 doesn't

Actual Results:  
I have to downgrade audacious to 1.5.0 if I want it works.
Comment 1 Jeroen Roovers (RETIRED) gentoo-dev 2008-05-29 15:39:33 UTC
Is dev-libs/libcdio installed?
Comment 2 Jeroen Roovers (RETIRED) gentoo-dev 2008-05-29 15:40:01 UTC
Oh, and your something-resembling-emerge--info, please.
Comment 3 Kiril Vladimirov 2008-05-30 12:19:32 UTC
Yes I have libcdio installed. 

nc@gentoo ~ $ eix --installed dev-libs/libcdio
[D] dev-libs/libcdio
     Available versions:  0.73 0.73[1] 0.78.2 0.78.2[1] 0.78.2-r3 0.78.2-r3[1] 0.78.2-r4 0.78.2-r4[1] ~0.79-r1 ~0.79-r1[1] {cddb minimal nls nocxx}
     Installed versions:  0.79-r1[1](06:00:07 PM 05/24/2008)(minimal nls -cddb -nocxx)
     Homepage:            http://www.gnu.org/software/libcdio/
     Description:         A library to encapsulate CD-ROM reading and control

[1] "gentoo" /usr/paludis
nc@gentoo ~ $ paludis --info
paludis 0.26.1
Paludis build information:
    Compiler:
        CXX:                   i686-pc-linux-gnu-g++ 4.1.2 (Gentoo 4.1.2 p1.0.2)
        CXXFLAGS:              -march=prescott -O2 -pipe -fomit-frame-pointer
        LDFLAGS:               
        DATE:                  2008-05-05T01:01:45+0300

    Libraries:
        C++ Library:           GNU libstdc++ 20070214

    Reduced Privs:
        reduced_uid:           1000
        reduced_uid->name:     nc
        reduced_uid->dir:      /home/nc
        reduced_gid:           100
        reduced_gid->name:     users

    Paths:
        DATADIR:               /usr/share
        LIBDIR:                /usr/lib
        LIBEXECDIR:            /usr/libexec
        SYSCONFDIR:            /etc
        PYTHONINSTALLDIR:      /usr/lib/python2.4/site-packages
        RUBYINSTALLDIR:        /usr/lib/ruby/site_ruby/1.8/i686-linux

Repository virtuals:
    format:                    virtuals

Repository installed-virtuals:
    format:                    installed_virtuals
    root:                      /

Repository gentoo:
    format:                    ebuild
    location:                  /usr/paludis
    append_repository_name_to_write_cache: true
    binary_destination:        false
    binary_keywords:           
    binary_uri_prefix:         
    builddir:                  /var/tmp/paludis
    cache:                     /usr/paludis/metadata/cache
    distdir:                   /usr/paludis/distfiles
    eapi_when_unknown:         0
    eapi_when_unspecified:     0
    eclassdirs:                /usr/paludis/eclass
    ignore_deprecated_profiles: false
    layout:                    traditional
    names_cache:               /usr/paludis/.cache/names
    newsdir:                   /usr/paludis/metadata/news
    profile_eapi:              0
    profiles:                  /usr/paludis/profiles/default/linux/x86/2008.0
    securitydir:               /usr/paludis/metadata/glsa
    setsdir:                   /usr/paludis/sets
    sync:                      rsync://rsync.gentoo.bg/gentoo-portage/
    sync_options:              
    use_manifest:              use
    write_cache:               /var/cache/paludis/metadata

    Package information:
        app-admin/eselect-compiler: (none)
        app-shells/bash:       3.2_p33
        dev-java/java-config:  1.3.7 2.1.6
        dev-lang/python:       2.4.4-r13
        dev-python/pycrypto:   2.0.1-r6
        dev-util/ccache:       2.4-r7
        dev-util/confcache:    (none)
        sys-apps/baselayout:   1.12.11.1
        sys-apps/openrc:       (none)
        sys-apps/sandbox:      1.2.18.1-r2
        sys-devel/autoconf:    2.13 2.61-r1
        sys-devel/automake:    1.10.1 1.5 1.6.3 1.7.9-r1 1.8.5-r3 1.9.6-r2
        sys-devel/binutils:    2.18-r1
        sys-devel/gcc-config:  1.4.0-r4
        sys-devel/libtool:     1.5.26
        virtual/os-headers:    2.6.23-r3 (for sys-kernel/linux-headers::installed)

Repository installed:
    format:                    vdb
    location:                  /var/db/pkg
    builddir:                  /var/tmp/paludis
    names_cache:               /var/db/pkg/.cache/names
    provides_cache:            /var/db/pkg/.cache/provides
    root:                      /

Repository paludis-extras:
    format:                    ebuild
    location:                  /var/paludis/repositories/paludis-extras
    append_repository_name_to_write_cache: true
    binary_destination:        false
    binary_keywords:           
    binary_uri_prefix:         
    builddir:                  /var/tmp/paludis
    cache:                     /var/empty
    distdir:                   /usr/paludis/distfiles
    eapi_when_unknown:         0
    eapi_when_unspecified:     0
    eclassdirs:                /usr/paludis/eclass /var/paludis/repositories/paludis-extras/eclass
    ignore_deprecated_profiles: false
    layout:                    traditional
    master_repository:         gentoo
    names_cache:               /var/paludis/repositories/paludis-extras/.cache/names
    newsdir:                   /var/paludis/repositories/paludis-extras/metadata/news
    profile_eapi:              0
    profiles:                  /usr/paludis/profiles/default/linux/x86/2008.0
    securitydir:               /var/paludis/repositories/paludis-extras/metadata/glsa
    setsdir:                   /var/paludis/repositories/paludis-extras/sets
    sync:                      rsync://rsync.paludis-extras.org/paludis-extras
    sync_options:              
    use_manifest:              use
    write_cache:               /var/empty

Repository kde4-experimental:
    format:                    ebuild
    location:                  /var/paludis/repositories/kde
    append_repository_name_to_write_cache: true
    binary_destination:        false
    binary_keywords:           
    binary_uri_prefix:         
    builddir:                  /var/tmp/paludis
    cache:                     /var/empty
    distdir:                   /usr/paludis/distfiles
    eapi_when_unknown:         0
    eapi_when_unspecified:     0
    eclassdirs:                /usr/paludis/eclass /var/paludis/repositories/kde/eclass
    ignore_deprecated_profiles: false
    layout:                    traditional
    master_repository:         gentoo
    names_cache:               /var/paludis/repositories/kde/.cache/names
    newsdir:                   /var/paludis/repositories/kde/metadata/news
    profile_eapi:              0
    profiles:                  /usr/paludis/profiles/default/linux/x86/2008.0
    securitydir:               /var/paludis/repositories/kde/metadata/glsa
    setsdir:                   /var/paludis/repositories/kde/sets
    sync:                      git://www2.mailstation.de/git/genkde4svn.git
    sync_options:              
    use_manifest:              use
    write_cache:               /var/cache/paludis/metadata


No packages were specified on the command line, so detailed information is not
available (Paludis can display detailed information for both installed and
installable packages).

nc@gentoo ~ $ 
Comment 4 Tony Vroon gentoo-dev 2008-05-31 15:26:25 UTC
chainsaw@prometheus ~ $ qfile /usr/include/cdio/cdda.h
dev-libs/libcdio (/usr/include/cdio/cdda.h)

Remerge libcdio.
Comment 5 Kiril Vladimirov 2008-05-31 19:00:45 UTC
(In reply to comment #4)
> chainsaw@prometheus ~ $ qfile /usr/include/cdio/cdda.h
> dev-libs/libcdio (/usr/include/cdio/cdda.h)
> 
> Remerge libcdio.
> 
Huh.... the problem is not solved just with remerdge libcdio :)
I found that, if it compiled with "minimal" flag it doesn't create this cdda.h file. 

I set -minimal for dev-libs/libcdio and after remerge, audacious-plugins-1.5.1 is compiling as well :P