Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 222719 - openrc failes to build with CFLAGS="-march=k8"
Summary: openrc failes to build with CFLAGS="-march=k8"
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] baselayout (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo's Team for Core System packages
Depends on:
Reported: 2008-05-18 20:41 UTC by Christoph Brill (egore) (RESIGNED)
Modified: 2008-05-31 09:05 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Christoph Brill (egore) (RESIGNED) 2008-05-18 20:41:58 UTC
I tried to build openrc-0.2.4-r1 on my system today. It failed with

libeinfo.So: file not recognized: File format not recognized

When I changed my CFLAGS from

-O2 -pipe -ggdb -march=k8


-O2 -pipe -ggdb -mtune=k8

it worked fine. I'm not sure if this is openrc's fault or if this bug shold be filed against toolchain.

Note: I cannot post emerge --info right now since I cannot start X or anything.

Reproducible: Always
Comment 1 Doug Goldstein (RETIRED) gentoo-dev 2008-05-19 14:35:56 UTC
Your toolchain is totally hosed because I build all my boxes with "-march=k8 -O2 -pipe -ggdb"

Rebuild gcc, binutils, and glibc.
Comment 2 SpanKY gentoo-dev 2008-05-31 06:56:17 UTC
my guess is your binutils is screwed up ... you cannot downgrade/use older versions after compiling gcc against newer ones
Comment 3 Christoph Brill (egore) (RESIGNED) 2008-05-31 09:05:16 UTC
I can confirm that my binutils were completely broken. It hat something to do with my software raid which failed and resynced. The resynced state was horribly broken. The suggestion by Doug fixed the issues for me. Also an additional "qcheck -a" showed some other problems.

Thank's for the hint for binutils! I already rebuilt gcc and glibc, but binutils was missing.