Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 222069 - app-emulation/wine-1.1.7 - src_test() fails, Error: Too many output files
Summary: app-emulation/wine-1.1.7 - src_test() fails, Error: Too many output files
Status: VERIFIED WONTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: AMD64 Linux
: High minor (vote)
Assignee: Wine Maintainers
URL:
Whiteboard:
Keywords:
: 227957 238317 (view as bug list)
Depends on:
Blocks:
 
Reported: 2008-05-14 11:55 UTC by Jeremy Murphy
Modified: 2009-09-30 11:11 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jeremy Murphy 2008-05-14 11:55:03 UTC
During build, make fails with "Error: Too many output files." during winetest.


Reproducible: Always

Steps to Reproduce:
1. emerge wine
2.
3.

Actual Results:  
cp ../../dlls/wininet/tests/wininet_test.exe.so wininet_test.exe && x86_64-pc-linux-gnu-strip wininet_test.exe
rm -f winhelp && ln -s ../../tools/winewrapper winhelp
cp ../../dlls/winmm/tests/winmm_test.exe.so winmm_test.exe && x86_64-pc-linux-gnu-strip winmm_test.exe
x86_64-pc-linux-gnu-gcc -c -I. -I. -I../../include -I../../include   -D_REENTRANT -fPIC -Wall -pipe -fno-strict-aliasing -Wdeclaration-after-statement -Wwrite-strings -Wpointer-arith  -O2 -pipe -march=nocona  -o macro.lex.yy.o macro.lex.yy.c
cp ../../dlls/winspool.drv/tests/winspool.drv_test.exe.so winspool.drv_test.exe && x86_64-pc-linux-gnu-strip winspool.drv_test.exe
cp ../../dlls/wintrust/tests/wintrust_test.exe.so wintrust_test.exe && x86_64-pc-linux-gnu-strip wintrust_test.exe
cp ../../dlls/ws2_32/tests/ws2_32_test.exe.so ws2_32_test.exe && x86_64-pc-linux-gnu-strip ws2_32_test.exe
rm -f winetest && ln -s ../../tools/winewrapper winetest
../../tools/wrc/wrc --nostdinc -I. -I. -I../../include -I../../include   -DBUILD_SHA1=\"`GIT_DIR=../../.git git rev-parse HEAD 2>/dev/null`\" -fowinetest.res winetest.rc
Error: Too many output files.
make[2]: *** [winetest.res] Error 2
make[2]: Leaving directory `/var/tmp/portage/app-emulation/wine-1.0_rc1/work/wine-1.0-rc1/programs/winetest'
make[1]: *** [winetest] Error 2
make[1]: *** Waiting for unfinished jobs....


Expected Results:  
Successful emerge.

Portage 2.1.4.4 (default-linux/amd64/2007.0/desktop, gcc-4.1.2, glibc-2.6.1-r0, 2.6.24-gentoo-r8 x86_64)
=================================================================
System uname: 2.6.24-gentoo-r8 x86_64 Intel(R) Core(TM)2 CPU 6300 @ 1.86GHz
Timestamp of tree: Wed, 14 May 2008 06:15:01 +0000
distcc 2.18.3 x86_64-pc-linux-gnu (protocols 1 and 2) (default port 3632) [disabled]
app-shells/bash:     3.2_p33
dev-java/java-config: 1.3.7, 2.1.6
dev-lang/python:     2.4.4-r9, 2.5.1-r2
dev-python/pycrypto: 2.0.1-r6
sys-apps/baselayout: 1.12.11.1
sys-apps/sandbox:    1.2.18.1-r2
sys-devel/autoconf:  2.13, 2.61-r1
sys-devel/automake:  1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.1
sys-devel/binutils:  2.18-r1
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   1.5.26
virtual/os-headers:  2.6.23-r3
ACCEPT_KEYWORDS="amd64"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -pipe -march=nocona"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/revdep-rebuild /etc/splash /etc/terminfo /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-O2 -pipe -march=nocona"
DISTDIR="/home/distfiles"
FEATURES="collision-protect distlocks fixpackages metadata-transfer parallel-fetch prelink sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://ftp.swin.edu.au/gentoo "
LANG="en_AU.UTF-8"
LC_ALL="en_AU.UTF-8"
LINGUAS="en_AU en_AU.UTF-8 en_GB en_GB.UTF-8"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.au.gentoo.org/gentoo-portage"
USE="X a52 aac aalib acpi alsa amd64 berkdb branding bzip2 cairo cddb cdr cli cracklib crypt cups dbus dia doc dvd dvdr dvdread emboss encode fam ffmpeg fftw firefox flac fortran gdbm gif gnome gnutls gpm graphviz gstreamer gtk hal iconv icq ipod ipv6 isdnlog java javascript jpeg jpeg2k kde libnotify lm_sensors lzo mad matroska midi mikmod mmap mmx mng mp3 mpeg mplayer msn mudflap mysql mysqli ncurses nls nptl nptlonly nsplugin ntfs offensive ogg opengl openmp pam pcre pdf png pppd python qt3 qt3support qt4 quicktime readline reflection samba sdl session sharedmem spell spl sqlite sqlite3 sse sse2 ssl svg syslog tcpd theora tiff timidity truetype unicode usb vcd vorbis wavpack wxwindows xcomposite xml xorg xpm xv xvid xvmc zlib" ALSA_CARDS="hda-intel" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en_AU en_AU.UTF-8 en_GB en_GB.UTF-8" USERLAND="GNU" VIDEO_CARDS="nvidia"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LDFLAGS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, PORTDIR_OVERLAY


This error does not occur on my x86 laptop that has essentially the same configuration.
Comment 1 Matt McAdoo 2008-05-16 14:53:26 UTC
Confirming this bug.  I receive the same error on my laptop (Dell Latitude D820) but not on my desktop (P4 2.4GHz Dell PowerEdge 400SC)


Portage 2.1.5 (default-linux/x86/2006.1/desktop, gcc-4.2.3, glibc-2.7-r2, 2.6.24-hardened i686)
=================================================================
System uname: 2.6.24-hardened i686 Genuine Intel(R) CPU T2300 @ 1.66GHz
Timestamp of tree: Thu, 15 May 2008 13:35:01 +0000
distcc 2.18.3 i686-pc-linux-gnu (protocols 1 and 2) (default port 3632) [enabled]
ccache version 2.4 [disabled]
app-shells/bash:     3.2_p39
dev-java/java-config: 1.3.7, 2.1.6
dev-lang/python:     2.4.4-r9, 2.5.2-r3
dev-python/pycrypto: 2.0.1-r6
dev-util/ccache:     2.4-r7
sys-apps/baselayout: 2.0.0
sys-apps/openrc:     0.2.4-r1
sys-apps/sandbox:    1.2.18.1-r2
sys-devel/autoconf:  2.13, 2.62
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.1-r1
sys-devel/binutils:  2.18-r1
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   1.5.26
virtual/os-headers:  2.6.25-r3
ACCEPT_KEYWORDS="x86 ~x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -g -ggdb -march=prescott -mtune=prescott -msse3 -mmmx -mfpmath=sse -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /opt/openfire/resources/security/ /var/bind /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/terminfo /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-O2 -g -ggdb -march=prescott -mtune=prescott -msse3 -mmmx -mfpmath=sse -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="candy distcc distlocks fixpackages loadpolicy parallel-fetch sandbox sfperms splitdebug strict unmerge-orphans userfetch userpriv usersandbox"
GENTOO_MIRRORS="http://distfiles.gentoo.org http://www.ibiblio.org/pub/Linux/distributions/gentoo"
LANG="en_US.utf8"
LC_ALL="en_US.utf8"
LDFLAGS="-Wl,-O1 -Wl,--enable-new-dtags -Wl,--sort-common"
LINGUAS="en en_US"
MAKEOPTS="-j5"
PKGDIR="/home/mcadoo/Desktop"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/home/portage"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/portage/local/layman/sunrise /usr/portage/local/layman/gnash-cvs /usr/portage/local/layman/java-overlay /usr/portage/local/layman/webapps-experimental"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X a52 aac aalib acpi alsa apache2 applet artworkextra aspnet aspnet2 aspnetedit audacious avahi bash-completion berkdb bitmap-fonts blas bluetooth bogofilter bonobo boo boost branding bzip2 bzlib cairo cdda cddb cdio cdparanoia cdr cgi chm cli corba cracklib crypt cups d dbus debug dell device-mapper disk-partition diskio djvu dmi dmx dri dv dvd dvdnav dvdr dvdread dvi eds elf emboss en encode epiphany evdev evo exif extensions extra-algorithms extras extrax fam fame ffmpeg fixme flac fontconfig fortran fuse gajim galago gcj gcl gd gdbm gedit gif gimp glitz gnokii gnome gnome-keyring gnutls gocr gpgme gpm grammar gsf gsm gstreamer gtk gtk2 guile hal hardware-carrier hbci ical iconv idle ieee1394 imagemagick imap inkjar ipv6 irda irmc isdnlog jabber jack jack-tmpfs java javascript jingle john joystick jpeg jpeg2k kerberos keyring l7static lapack laptop latex lcms ldap libcaca libgda libnotify libsexy libwww lm_sensors logrotate lzma lzo mad madwifi math matroska mbox mdnsresponder-compat midi mikmod mjpeg mmx mmxext mng mono mp2 mp3 mpeg mplayer msn mudflap mysql nas nautilus ncurses netbeans network networking networkmanager nfs nptl nptlonly nsplugin nss obex objc objc++ objc-gc ocrad odbc odk offensive ofx ogg ole openal opengl openmp pam pango parse-clocks pcmcia pcre pda pdf perl php plotutils plugin plugins png pop postgres ppds pppd pulseaudio python qt3support quicktime rar readline reflection regex rpm rtc rtsp samba sasl scanner sdl sensord session shout skins smime smp sms sndfile snmp sockets sound speex spell spl srv sse sse2 sse3 ssl stream subversion svg swat sysfs syslog t1lib tcl tcltk tcpd tesseract tetex theora thesaurus threads threadsonly tidy tiff tk tordns tracker transmitter trayicon truetype truetype-fonts type1-fonts udev unicode usb usb-audio userlocales v4l vim vim-syntax vim-with-x vlm vorbis webdav wifi win32codecs winbind wireless wireshark wma wmf wxwindows x264 x86 xamin xchatdccserver xforms xhtml xinerama xml xml2 xmlreader xmlrpc xorg xosd xpm xprint xscreensaver xsl xulrunner xv xvid xvmc yahoo zip zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 	emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m 	maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="synaptics evdev joystick mouse keyboard" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en en_US" USERLAND="GNU" VIDEO_CARDS="i810"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 2 Daniel Rudolph 2008-05-22 09:01:06 UTC
Fix of some sort:

Apparently there is a name collision of some sort;
it works after you unmerge app-misc/git.
I didn't reemerge app-misc/git, but that should be no problem.

1. emerge -vC app-misc/git
2. emerge -vu app-emulation/wine
Comment 3 SpanKY gentoo-dev 2008-06-18 10:24:06 UTC
*** Bug 227957 has been marked as a duplicate of this bug. ***
Comment 4 Jeremy Murphy 2008-08-12 04:56:41 UTC
Bump.  This bug still exists in wine-1.1.0.
Comment 5 Thomas Beutin 2008-08-17 14:45:52 UTC
The same compile problem with app-emulation/wine-1.1.0 here. Unmerging app-misc/git fixed the problem. Reemerging app-misc/git after installing wine was no problem.
Comment 6 SpanKY gentoo-dev 2008-09-25 00:11:18 UTC
*** Bug 238317 has been marked as a duplicate of this bug. ***
Comment 7 Jeremy Murphy 2008-10-27 01:48:59 UTC
<bump> This bug still exists in wine-1.1.7 (on ~amd64 at least).
Comment 8 Daniel Tourde 2008-10-29 12:36:32 UTC
And on wine 1.1.4 on x86 gcc 3.4.6
Comment 9 Honza 2009-05-03 12:32:31 UTC
Just hit this bug on app-emulation/wine-1.1.12 (on x86 gcc 3.4.6)
Comment 10 Mike 2009-08-31 12:03:39 UTC
(In reply to comment #9)
> Just hit this bug on app-emulation/wine-1.1.12 (on x86 gcc 3.4.6)
> 

As suggested, try to --unmerge app-misc/git , which is a "GNU Interactive Tools - increase speed and efficiency of most daily task" and doesn't really work like dev-util/git , the the revision control system.

The invocation of

../../tools/wrc/wrc --nostdinc -I. -I. -I../../include -I../../include   -DBUILD_SHA1=\"`GIT_DIR=../../.git git rev-parse HEAD 2>/dev/null`\" -fowinetest.res winetest.rc

should be changed to prevent that ambiguation.
Comment 11 Jeremy Murphy 2009-09-30 11:10:51 UTC
I don't actually use app-misc/git and I don't it's such a big deal.
Comment 12 Jeremy Murphy 2009-09-30 11:11:42 UTC
+think

I do think, really I do.