Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 221129 - app-crypt/steghide-0.5.1 fails w/ gcc-4.3.0
Summary: app-crypt/steghide-0.5.1 fails w/ gcc-4.3.0
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] GCC Porting (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: No maintainer - Look at https://wiki.gentoo.org/wiki/Project:Proxy_Maintainers if you want to take care of it
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: gcc-4.3
  Show dependency tree
 
Reported: 2008-05-09 20:41 UTC by Peter Alfredsen (RETIRED)
Modified: 2008-05-13 20:42 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
steghide-0.5.1.ebuild.patch (steghide-0.5.1.ebuild.patch,1.52 KB, patch)
2008-05-09 20:44 UTC, Peter Alfredsen (RETIRED)
Details | Diff
steghide-0.5.1-gcc43.patch (steghide-0.5.1-gcc43.patch,10.20 KB, patch)
2008-05-09 20:47 UTC, Peter Alfredsen (RETIRED)
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Peter Alfredsen (RETIRED) gentoo-dev 2008-05-09 20:41:27 UTC
EncryptionMode.cc:107: warning: deprecated conversion from string constant to ‘char*’
EncryptionMode.cc:107: warning: deprecated conversion from string constant to ‘char*’
EncryptionMode.cc:107: warning: deprecated conversion from string constant to ‘char*’
EncryptionMode.cc:107: warning: deprecated conversion from string constant to ‘char*’
EncryptionMode.cc:107: warning: deprecated conversion from string constant to ‘char*’
EncryptionMode.cc:107: warning: deprecated conversion from string constant to ‘char*’
EncryptionMode.cc:107: warning: deprecated conversion from string constant to ‘char*’
EncryptionMode.cc:107: warning: deprecated conversion from string constant to ‘char*’
if i686-pc-linux-gnu-g++ -DHAVE_CONFIG_H -I. -I. -I..  -DLOCALEDIR=\"/usr/share/locale\"   -O2 -Wall -MT Extractor.o -MD -MP -MF ".deps/Extractor.Tpo" \
          -c -o Extractor.o `test -f 'Extractor.cc' || echo './'`Extractor.cc; \
        then mv ".deps/Extractor.Tpo" ".deps/Extractor.Po"; \
        else rm -f ".deps/Extractor.Tpo"; exit 1; \
        fi
In file included from /usr/lib/gcc/i686-pc-linux-gnu/4.3.0/include/g++-v4/ext/hash_set:64,
                 from wrapper_hash_set.h:32,
                 from SampleValue.h:27,
                 from Extractor.cc:27:
/usr/lib/gcc/i686-pc-linux-gnu/4.3.0/include/g++-v4/backward/backward_warning.h:32:2: warning: #warning This file includes at least one deprecated or antiquated header which may be removed without further notice at a future date. Please use a non-deprecated interface with equivalent functionality instead. For a listing of replacement headers and interfaces, consult the file backward_warning.h. To disable this warning use -Wno-deprecated.
if i686-pc-linux-gnu-g++ -DHAVE_CONFIG_H -I. -I. -I..  -DLOCALEDIR=\"/usr/share/locale\"   -O2 -Wall -MT Graph.o -MD -MP -MF ".deps/Graph.Tpo" \
          -c -o Graph.o `test -f 'Graph.cc' || echo './'`Graph.cc; \
        then mv ".deps/Graph.Tpo" ".deps/Graph.Po"; \
        else rm -f ".deps/Graph.Tpo"; exit 1; \
        fi
if i686-pc-linux-gnu-g++ -DHAVE_CONFIG_H -I. -I. -I..  -DLOCALEDIR=\"/usr/share/locale\"   -O2 -Wall -MT JpegFile.o -MD -MP -MF ".deps/JpegFile.Tpo" \
          -c -o JpegFile.o `test -f 'JpegFile.cc' || echo './'`JpegFile.cc; \
        then mv ".deps/JpegFile.Tpo" ".deps/JpegFile.Po"; \
        else rm -f ".deps/JpegFile.Tpo"; exit 1; \
        fi
In file included from /usr/lib/gcc/i686-pc-linux-gnu/4.3.0/include/g++-v4/ext/hash_set:64,
                 from wrapper_hash_set.h:32,
                 from SampleValue.h:27,
                 from JpegSampleValue.h:24,
                 from JpegFile.cc:31:
/usr/lib/gcc/i686-pc-linux-gnu/4.3.0/include/g++-v4/backward/backward_warning.h:32:2: warning: #warning This file includes at least one deprecated or antiquated header which may be removed without further notice at a future date. Please use a non-deprecated interface with equivalent functionality instead. For a listing of replacement headers and interfaces, consult the file backward_warning.h. To disable this warning use -Wno-deprecated.
if i686-pc-linux-gnu-g++ -DHAVE_CONFIG_H -I. -I. -I..  -DLOCALEDIR=\"/usr/share/locale\"   -O2 -Wall -MT JpegSampleValue.o -MD -MP -MF ".deps/JpegSampleValue.Tpo" \
          -c -o JpegSampleValue.o `test -f 'JpegSampleValue.cc' || echo './'`JpegSampleValue.cc; \
        then mv ".deps/JpegSampleValue.Tpo" ".deps/JpegSampleValue.Po"; \
        else rm -f ".deps/JpegSampleValue.Tpo"; exit 1; \
        fi
In file included from /usr/lib/gcc/i686-pc-linux-gnu/4.3.0/include/g++-v4/ext/hash_set:64,
                 from wrapper_hash_set.h:32,
                 from SampleValue.h:27,
                 from Edge.h:24,
                 from Graph.cc:28:
/usr/lib/gcc/i686-pc-linux-gnu/4.3.0/include/g++-v4/backward/backward_warning.h:32:2: warning: #warning This file includes at least one deprecated or antiquated header which may be removed without further notice at a future date. Please use a non-deprecated interface with equivalent functionality instead. For a listing of replacement headers and interfaces, consult the file backward_warning.h. To disable this warning use -Wno-deprecated.
Graph.cc: In member function ‘void Graph::printVerboseInfo()’:
Graph.cc:226: error: ‘ULONG_MAX’ was not declared in this scope
make[2]: *** [Graph.o] Error 1
make[2]: *** Waiting for unfinished jobs....
In file included from /usr/lib/gcc/i686-pc-linux-gnu/4.3.0/include/g++-v4/ext/hash_set:64,
                 from wrapper_hash_set.h:32,
                 from SampleValue.h:27,
                 from JpegSampleValue.h:24,
                 from JpegSampleValue.cc:25:
/usr/lib/gcc/i686-pc-linux-gnu/4.3.0/include/g++-v4/backward/backward_warning.h:32:2: warning: #warning This file includes at least one deprecated or antiquated header which may be removed without further notice at a future date. Please use a non-deprecated interface with equivalent functionality instead. For a listing of replacement headers and interfaces, consult the file backward_warning.h. To disable this warning use -Wno-deprecated.
make[2]: Leaving directory `/var/tmp/portage/app-crypt/steghide-0.5.1/work/steghide-0.5.1/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/app-crypt/steghide-0.5.1/work/steghide-0.5.1'
make: *** [all] Error 2
Comment 1 Peter Alfredsen (RETIRED) gentoo-dev 2008-05-09 20:44:38 UTC
Created attachment 152695 [details, diff]
steghide-0.5.1.ebuild.patch

patch for ebuild. Drops libtool patch, adds in emake workaround for same problem. Uses gcc43.patch. Adds debug useflag. Probably revision bump worthy.
Comment 2 Peter Alfredsen (RETIRED) gentoo-dev 2008-05-09 20:47:54 UTC
Created attachment 152697 [details, diff]
steghide-0.5.1-gcc43.patch

Patch for gcc-4.3.0. Snatched some from Debian, added in autotool magic so we don't have to do this again when gcc-4.4 comes and hash_set + hash_map is dropped. Gave some love to CXXFLAGS.
Builds with gcc-3.4.6, 4.1.2, 4.2.3 and 4.3.0.
Comment 3 Peter Alfredsen (RETIRED) gentoo-dev 2008-05-09 20:49:12 UTC
And if you think there's a lot of warnings for an ebuild that just got love, apply the patches in bug 221093 .
Comment 4 Samuli Suominen gentoo-dev 2008-05-13 20:42:53 UTC
Committed, Thanks