Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 220367 - dev-scheme/guile-1.8.4-r1 fails to libtoolize
Summary: dev-scheme/guile-1.8.4-r1 fails to libtoolize
Status: RESOLVED DUPLICATE of bug 212723
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: AMD64 Linux
: High normal (vote)
Assignee: Gentoo Linux bug wranglers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-05-05 14:29 UTC by Emopig
Modified: 2008-05-05 23:01 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Emopig 2008-05-05 14:29:17 UTC
Guile 1.8.4-r1 fails to libtoolize

>>> Emerging (1 of 2) dev-scheme/guile-1.8.4-r1 to /
 * guile-1.8.4.tar.gz RMD160 SHA1 SHA256 size ;-) ...                                              [ ok ]
 * checking ebuild checksums ;-) ...                                                               [ ok ]
 * checking auxfile checksums ;-) ...                                                              [ ok ]
 * checking miscfile checksums ;-) ...                                                             [ ok ]
 * checking guile-1.8.4.tar.gz ;-) ...                                                             [ ok ]

 * Using bashrcng profile [ 1.1.4 ]
>>> Unpacking source...
>>> Unpacking guile-1.8.4.tar.gz to /var/tmp/portage/dev-scheme/guile-1.8.4-r1/work
tar: guile-1.8.4/guile-readline/ltmain.sh: implausibly old time stamp 1970-01-01 01:00:00
tar: guile-1.8.4/build-aux/config.sub: implausibly old time stamp 1970-01-01 01:00:00
tar: guile-1.8.4/build-aux/config.guess: implausibly old time stamp 1970-01-01 01:00:00
tar: guile-1.8.4/build-aux/ltmain.sh: implausibly old time stamp 1970-01-01 01:00:00
 * Applying gcc-4.3.patch ...                                                                      [ ok ]
 * Running eautoreconf in '/var/tmp/portage/dev-scheme/guile-1.8.4-r1/work/guile-1.8.4' ...
 * Running aclocal -I guile-config ...                                                             [ ok ]
 * Running libtoolize --copy --force --automake ...                                                [ !! ]
 * Failed Running libtoolize !
 * 
 * Include in your bugreport the contents of:
 * 
 *   /var/tmp/portage/dev-scheme/guile-1.8.4-r1/temp/libtoolize-10943.out

==========================
andrew@ziggy ~ $ cat /var/tmp/portage/dev-scheme/guile-1.8.4-r1/temp/libtoolize-10943.out
***** libtoolize *****
***** libtoolize --copy --force --automake

libtoolize: AC_CONFIG_MACRO_DIR([m4]) conflicts with ACLOCAL_AMFLAGS=-I guile-config.


Reproducible: Always

Steps to Reproduce:
1. Emerge guile-1.8.4-r1 on ~amd64




andrew@ziggy ~ $ emerge --info
Portage 2.1.5_rc6 (default-linux/amd64/2007.0/desktop, gcc-4.2.3, glibc-2.7-r2, 2.6.26-rc1 x86_64)
=================================================================
System uname: 2.6.26-rc1 x86_64 AMD Athlon(tm)64 X2 Dual Core Processor 3800+
Timestamp of tree: Mon, 05 May 2008 10:33:01 +0000
app-shells/bash:     3.2_p39
dev-lang/python:     2.5.2-r2
sys-apps/baselayout: 2.0.0
sys-apps/openrc:     0.2.3
sys-apps/sandbox:    1.2.18.1-r2
sys-devel/autoconf:  2.13, 2.62
sys-devel/automake:  1.4_p6, 1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.1-r1
sys-devel/binutils:  2.18-r1
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   2.2.4
virtual/os-headers:  2.6.24
ACCEPT_KEYWORDS="amd64 ~amd64"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=k8 -msse3 -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc"
CONFIG_PROTECT_MASK="/etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-march=k8 -msse3 -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="distlocks parallel-fetch sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://mirror.qubenet.net/mirror/gentoo/ http://ftp.heanet.ie/pub/gentoo/ http://gentoo.virginmedia.com/ http://mirror.muntinternet.net/pub/gentoo/ http://gentoo.tiscali.nl/"
LANG="en_GB.utf8"
LC_ALL="en_GB.utf8"
LDFLAGS="-Wl,-O1"
LINGUAS="en en_GB"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/portage/local/layman/gechi /usr/portage/local"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="3dnow 3dnowext X a52 aac acl acpi alsa amd64 applet asf berkdb bzip2 cairo cdda cddb cdio cdparanoia cdr cli cracklib crypt cups curl cxx d dbus dri dv dvd dvdnav dvdr dvdread emboss en_GB encode esd exif fam fat ffmpeg flac fortran freetype ftp fuse gdbm gif gimp gnome gnome-keyring gphoto2 gpm gsf gstreamer gtk hal iconv id3tag imap ipv6 isdnlog jpeg jpeg2k kdehiddenvisibility kerberos libnotify libsamplerate lm_sensors mad matroska midi mikmod mjpeg mmx mp3 mpeg mplayer mudflap mysql nautilus ncurses network nls nptl nptlonly ntfs nvidia ocamlopt offensive ogg openal opengl openmp pam pcre pdf perl png pppd pulseaudio python qt3 qt3support qt4 quicktime readline reflection rtc rtsp samba scanner sdl session sound spell spl sqlite sqlite3 srt sse sse2 ssl startup-notification subtitles svg sysfs tcpd theora threads threadsafe thumbnailing tiff truetype unicode upnp usb v4l v4l2 vcd vorbis wxwindows x264 xcb xcomposite xine xml xorg xprint xulrunner xv xvid xvmc zlib" ALSA_CARDS="hda-intel" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CAMERAS="kodak" ELIBC="glibc" INPUT_DEVICES="keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en en_GB" USERLAND="GNU" VIDEO_CARDS="nv nvidia vesa"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Jan Kundrát (RETIRED) gentoo-dev 2008-05-05 14:33:18 UTC
Please tell us what version of libtool you use and reopen.
Comment 2 teidakankan 2008-05-05 22:13:06 UTC
I'm also getting this with:

[ebuild   R   ] sys-devel/libtool-2.2.4  USE="-vanilla" 0 kB

on ~x86
Comment 3 Jan Kundrát (RETIRED) gentoo-dev 2008-05-05 23:01:45 UTC
reopen for proper resolution
Comment 4 Jan Kundrát (RETIRED) gentoo-dev 2008-05-05 23:01:58 UTC

*** This bug has been marked as a duplicate of bug 212723 ***