Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 219675 - sys-cluster/lam-mpi-7.1.4 fails w/ gcc-4.3.0
Summary: sys-cluster/lam-mpi-7.1.4 fails w/ gcc-4.3.0
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] GCC Porting (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Cluster Team
Depends on:
Blocks: gcc-4.3
  Show dependency tree
Reported: 2008-04-28 22:37 UTC by Peter Alfredsen (RETIRED)
Modified: 2010-09-10 19:01 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---

7.1.4-gcc43.patch (7.1.4-gcc43.patch,6.62 KB, patch)
2008-04-28 22:39 UTC, Peter Alfredsen (RETIRED)
Details | Diff
config.log (config.log,39.75 KB, text/plain)
2008-04-28 22:47 UTC, Peter Alfredsen (RETIRED)

Note You need to log in before you can comment on or make changes to this bug.
Description Peter Alfredsen (RETIRED) gentoo-dev 2008-04-28 22:37:45 UTC
*** C++ compiler and preprocessor
checking for i686-pc-linux-gnu-g++... i686-pc-linux-gnu-g++
checking whether we are using the GNU C++ compiler... yes
checking whether i686-pc-linux-gnu-g++ accepts -g... yes
checking dependency style of i686-pc-linux-gnu-g++... gcc3
checking how to run the C++ preprocessor... i686-pc-linux-gnu-g++ -E
checking if want C++ exception handling... no
checking whether i686-pc-linux-gnu-g++ has new(std::nothrow)... no
checking for C++ template repository directory... templates not supported?
not used
checking for C++ compiler template parameters... none needed
checking for C++ optimization flags... -O2 -march=i686 -mtune=athlon-xp -msse -mmmx -pipe -ggdb3
checking map usability... yes
checking map presence... yes
checking for map... yes
checking for type bool... no
checking for true/false... no
configure: WARNING: *** Your C++ compiler does not support the bool data type.
configure: WARNING: *** LAM requires a C++ compiler with support for the bool
configure: WARNING: *** data type.
configure: error: cannot continue
Comment 1 Peter Alfredsen (RETIRED) gentoo-dev 2008-04-28 22:39:23 UTC
Created attachment 151287 [details, diff]

Fixes the configure system.
Comment 2 Peter Alfredsen (RETIRED) gentoo-dev 2008-04-28 22:47:48 UTC
Created attachment 151289 [details]

The specific error messages. I'll mail upstream and point them at this bug. Debian are just patching $S/configure, but that's not the Correct and Authorized way to do it. Especially when we're doing eautoreconf.
Comment 3 Peter Alfredsen (RETIRED) gentoo-dev 2008-04-28 23:25:01 UTC
The patch is valid and work. Only, I seem to have stepped in some libtool foo.
Comment 4 Peter Alfredsen (RETIRED) gentoo-dev 2008-04-29 00:43:06 UTC
This is the problem I ran into.
*** [Gentoo] sanity check failed! ***
*** libtool.m4 and have a version mismatch! ***
*** (libtool.m4 = 1.5.26, = 1.5.22) ***

I solved it by adding these lines to the ebuild, right after eautoreconf:
        for oldltmain in $(grep -l 1.5.22 `find ./ -name ''`) ;do
                cp config/ ${oldltmain}

Not pretty, but it works.
Comment 5 Peter Alfredsen (RETIRED) gentoo-dev 2008-04-29 20:43:48 UTC
On the lam mailing list I was referred by this post:
to this patch:
Which does the same, only better.
Comment 6 Justin Bronder (RETIRED) gentoo-dev 2008-05-02 03:13:12 UTC
Just added the fixes to cvs for this, should hit the mirrors soon.  I don't have gcc-4.3.0 on any machines to test against so please reopen if you hit any problems.

Thanks for the patch and report.  Extra thanks for emailing upstream :)