Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 219337 - app-office/planner-0.14.3 fails to build
Summary: app-office/planner-0.14.3 fails to build
Status: VERIFIED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: GNOME Office (OBSOLETE)
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-04-26 12:57 UTC by justXi
Modified: 2008-04-28 19:56 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
config.log file (config.log,46.38 KB, text/plain)
2008-04-28 16:53 UTC, Patrizio Bassi
Details

Note You need to log in before you can comment on or make changes to this bug.
Description justXi 2008-04-26 12:57:07 UTC
planner fails to build.

Reproducible: Always

Steps to Reproduce:
emerge planner


Actual Results:  
>>> Emerging (3 of 3) app-office/planner-0.14.3 to /
 * planner-0.14.3.tar.bz2 RMD160 SHA1 SHA256 size ;-) ...                                                                                              [ ok ]
 * checking ebuild checksums ;-) ...                                                                                                                   [ ok ]
 * checking auxfile checksums ;-) ...                                                                                                                  [ ok ]
 * checking miscfile checksums ;-) ...                                                                                                                 [ ok ]
 * checking planner-0.14.3.tar.bz2 ;-) ...                                                                                                             [ ok ]
>>> Unpacking source...
>>> Unpacking planner-0.14.3.tar.bz2 to /var/tmp/portage/app-office/planner-0.14.3/work
 * Fixing OMF Makefiles ...                                                                                                                            [ ok ]
 * Running elibtoolize in: planner-0.14.3
 *   Applying install-sh-1.5.4.patch ...
 *   Applying portage-1.5.10.patch ...
 *   Applying sed-1.5.6.patch ...
 * Applying planner-0.14.3-parallel-build.patch ...                                                                                                    [ ok ]
 * Applying planner-0.14.3-eds-plugin.patch ...                                                                                                        [ ok ]
 * Automake used for the package (1.9.6) differs from
 * the installed version (1.10.1).
 * Running eautoreconf in '/var/tmp/portage/app-office/planner-0.14.3/work/planner-0.14.3' ...
 * Running aclocal ...                                                                                                                                 [ ok ]
 * Running libtoolize --copy --force --automake ...                                                                                                    [ ok ]
 * Running aclocal ...                                                                                                                                 [ ok ]
 * Running autoconf ...                                                                                                                                [ ok ]
 * Running autoheader ...                                                                                                                              [ ok ]
 * Running automake --add-missing --copy ...                                                                                                           [ ok ]
You should update your 'aclocal.m4' by running aclocal.
>>> Source unpacked.
>>> Compiling source in /var/tmp/portage/app-office/planner-0.14.3/work/planner-0.14.3 ...
 * econf: updating planner-0.14.3/config.guess with /usr/share/gnuconfig/config.guess
 * econf: updating planner-0.14.3/config.sub with /usr/share/gnuconfig/config.sub
./configure --prefix=/usr --host=i686-pc-linux-gnu --mandir=/usr/share/man --infodir=/usr/share/info --datadir=/usr/share --sysconfdir=/etc --localstatedir=/var/lib --disable-database --enable-python --enable-python-plugin --disable-gtk-doc --disable-eds --disable-update-mimedb --disable-gtk-doc --build=i686-pc-linux-gnu
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for a thread-safe mkdir -p... /bin/mkdir -p
checking for gawk... gawk
checking whether make sets $(MAKE)... yes
checking whether to enable maintainer-specific portions of Makefiles... no
checking for style of include used by make... GNU
checking for i686-pc-linux-gnu-gcc... i686-pc-linux-gnu-gcc
checking for C compiler default output file name... a.out
checking whether the C compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables... 
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether i686-pc-linux-gnu-gcc accepts -g... yes
checking for i686-pc-linux-gnu-gcc option to accept ISO C89... none needed
checking dependency style of i686-pc-linux-gnu-gcc... gcc3
checking for library containing strerror... none required
checking for i686-pc-linux-gnu-gcc... (cached) i686-pc-linux-gnu-gcc
checking whether we are using the GNU C compiler... (cached) yes
checking whether i686-pc-linux-gnu-gcc accepts -g... (cached) yes
checking for i686-pc-linux-gnu-gcc option to accept ISO C89... (cached) none needed
checking dependency style of i686-pc-linux-gnu-gcc... (cached) gcc3
checking how to run the C preprocessor... i686-pc-linux-gnu-gcc -E
checking for grep that handles long lines and -e... /bin/grep
checking for egrep... /bin/grep -E
checking for ANSI C header files... yes
checking build system type... i686-pc-linux-gnu
checking host system type... i686-pc-linux-gnu
checking for a sed that does not truncate output... /bin/sed
checking for ld used by i686-pc-linux-gnu-gcc... /usr/i686-pc-linux-gnu/bin/ld
checking if the linker (/usr/i686-pc-linux-gnu/bin/ld) is GNU ld... yes
checking for /usr/i686-pc-linux-gnu/bin/ld option to reload object files... -r
checking for BSD-compatible nm... /usr/bin/nm -B
checking whether ln -s works... yes
checking how to recognize dependent libraries... pass_all
checking for sys/types.h... yes
checking for sys/stat.h... yes
checking for stdlib.h... yes
checking for string.h... yes
checking for memory.h... yes
checking for strings.h... yes
checking for inttypes.h... yes
checking for stdint.h... yes
checking for unistd.h... yes
checking dlfcn.h usability... yes
checking dlfcn.h presence... yes
checking for dlfcn.h... yes
checking for i686-pc-linux-gnu-g++... i686-pc-linux-gnu-g++
checking whether we are using the GNU C++ compiler... yes
checking whether i686-pc-linux-gnu-g++ accepts -g... yes
checking dependency style of i686-pc-linux-gnu-g++... gcc3
checking how to run the C++ preprocessor... i686-pc-linux-gnu-g++ -E
checking for i686-pc-linux-gnu-g77... no
checking for i686-pc-linux-gnu-xlf... no
checking for i686-pc-linux-gnu-f77... no
checking for i686-pc-linux-gnu-frt... no
checking for i686-pc-linux-gnu-pgf77... no
checking for i686-pc-linux-gnu-cf77... no
checking for i686-pc-linux-gnu-fort77... no
checking for i686-pc-linux-gnu-fl32... no
checking for i686-pc-linux-gnu-af77... no
checking for i686-pc-linux-gnu-xlf90... no
checking for i686-pc-linux-gnu-f90... no
checking for i686-pc-linux-gnu-pgf90... no
checking for i686-pc-linux-gnu-pghpf... no
checking for i686-pc-linux-gnu-epcf90... no
checking for i686-pc-linux-gnu-gfortran... i686-pc-linux-gnu-gfortran
checking whether we are using the GNU Fortran 77 compiler... yes
checking whether i686-pc-linux-gnu-gfortran accepts -g... yes
checking the maximum length of command line arguments... 98304
checking command to parse /usr/bin/nm -B output from i686-pc-linux-gnu-gcc object... ok
checking for objdir... .libs
checking for i686-pc-linux-gnu-ar... i686-pc-linux-gnu-ar
checking for i686-pc-linux-gnu-ranlib... i686-pc-linux-gnu-ranlib
checking for i686-pc-linux-gnu-strip... i686-pc-linux-gnu-strip
checking for correct ltmain.sh version... yes
checking if i686-pc-linux-gnu-gcc supports -fno-rtti -fno-exceptions... no
checking for i686-pc-linux-gnu-gcc option to produce PIC... -fPIC
checking if i686-pc-linux-gnu-gcc PIC flag -fPIC works... yes
checking if i686-pc-linux-gnu-gcc static flag -static works... yes
checking if i686-pc-linux-gnu-gcc supports -c -o file.o... yes
checking whether the i686-pc-linux-gnu-gcc linker (/usr/i686-pc-linux-gnu/bin/ld) supports shared libraries... yes
checking whether -lc should be explicitly linked in... no
checking dynamic linker characteristics... GNU/Linux ld.so
checking how to hardcode library paths into programs... immediate
checking whether stripping libraries is possible... yes
checking if libtool supports shared libraries... yes
checking whether to build shared libraries... yes
checking whether to build static libraries... no
configure: creating libtool
appending configuration tag "CXX" to libtool
checking for ld used by i686-pc-linux-gnu-g++... /usr/i686-pc-linux-gnu/bin/ld
checking if the linker (/usr/i686-pc-linux-gnu/bin/ld) is GNU ld... yes
checking whether the i686-pc-linux-gnu-g++ linker (/usr/i686-pc-linux-gnu/bin/ld) supports shared libraries... yes
checking for i686-pc-linux-gnu-g++ option to produce PIC... -fPIC
checking if i686-pc-linux-gnu-g++ PIC flag -fPIC works... yes
checking if i686-pc-linux-gnu-g++ static flag -static works... yes
checking if i686-pc-linux-gnu-g++ supports -c -o file.o... yes
checking whether the i686-pc-linux-gnu-g++ linker (/usr/i686-pc-linux-gnu/bin/ld) supports shared libraries... yes
checking dynamic linker characteristics... GNU/Linux ld.so
(cached) (cached) checking how to hardcode library paths into programs... immediate
appending configuration tag "F77" to libtool
checking if libtool supports shared libraries... yes
checking whether to build shared libraries... yes
checking whether to build static libraries... no
checking for i686-pc-linux-gnu-gfortran option to produce PIC... -fPIC
checking if i686-pc-linux-gnu-gfortran PIC flag -fPIC works... yes
checking if i686-pc-linux-gnu-gfortran static flag -static works... yes
checking if i686-pc-linux-gnu-gfortran supports -c -o file.o... yes
checking whether the i686-pc-linux-gnu-gfortran linker (/usr/i686-pc-linux-gnu/bin/ld) supports shared libraries... yes
checking dynamic linker characteristics... GNU/Linux ld.so
(cached) (cached) checking how to hardcode library paths into programs... immediate
checking for i686-pc-linux-gnu-pkg-config... no
checking for pkg-config... /usr/bin/pkg-config
checking pkg-config is at least version 0.16... yes
checking for GLIB - version >= 2.0.0... yes (version 2.14.6)
checking what warning flags to pass to the C compiler... 
checking for intltool >= 0.35.5... 0.35.5 found
checking for perl... /usr/bin/perl
checking for XML::Parser... ok
checking for iconv... /usr/bin/iconv
checking for msgfmt... /usr/bin/msgfmt
checking for msgmerge... /usr/bin/msgmerge
checking for xgettext... /usr/bin/xgettext
checking for pkg-config... /usr/bin/pkg-config
checking for update-mime-database... /usr/bin/update-mime-database
checking for update-desktop-database... /usr/bin/update-desktop-database
checking for gconftool-2... /usr/bin/gconftool-2
Using config source xml:merged:/etc/gconf/gconf.xml.defaults for schema installation
Using $(sysconfdir)/gconf/schemas as install directory for schema files
./configure: line 22067: syntax error near unexpected token `1.0'
./configure: line 22067: `GTK_DOC_CHECK(1.0)'

!!! Please attach the following file when seeking support:
!!! /var/tmp/portage/app-office/planner-0.14.3/work/planner-0.14.3/config.log
 * 
 * ERROR: app-office/planner-0.14.3 failed.
 * Call stack:
 *               ebuild.sh, line   49:  Called src_compile
 *             environment, line 2752:  Called gnome2_src_compile
 *             environment, line 2130:  Called gnome2_src_configure
 *             environment, line 2144:  Called econf 'src_compile' 'src_compile' '--disable-database' '--enable-python' '--enable-python-plugin' '--disable-gtk-doc' '--disable-eds'
 *               ebuild.sh, line  513:  Called die
 * The specific snippet of code:
 *   			die "econf failed"
 *  The die message:
 *   econf failed
 * 
 

Expected Results:  
successful emerge of planner.
Comment 1 Gilles Dartiguelongue gentoo-dev 2008-04-26 16:51:58 UTC
fixed in tree. Thanks for reporting.
Comment 2 Patrizio Bassi 2008-04-28 15:55:44 UTC
this is notfixed, i synced 5 minutes ago and i still have the same issue.

Can you please reopen?
Comment 3 Gilles Dartiguelongue gentoo-dev 2008-04-28 16:47:25 UTC
sorry, you'll have to be a bit more specific.

Version of gtk-doc{,am} and config.log please.
Comment 4 Patrizio Bassi 2008-04-28 16:53:08 UTC
Created attachment 151255 [details]
config.log file
Comment 5 Patrizio Bassi 2008-04-28 16:53:32 UTC
emerge gtk-doc gtk-doc-am -pv

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R   ] dev-util/gtk-doc-am-1.10-r1  395 kB
[ebuild   R   ] dev-util/gtk-doc-1.10-r1  USE="-debug -doc -emacs" 0 kB
Comment 6 Gilles Dartiguelongue gentoo-dev 2008-04-28 17:10:15 UTC
could you attach the configure.in and configure because I have no clue at what's wrong here. It works good on all the boxes I have. Could you also try after reemerging gtk-doc-am ?
Comment 7 Patrizio Bassi 2008-04-28 17:46:28 UTC
you're right afte re-emerging it planner compiled.

i have no idea what happened.
Comment 8 Gilles Dartiguelongue gentoo-dev 2008-04-28 19:56:16 UTC
not sure either, maybe the macro wasn't named properly even though with -r1 it should have been ok.