Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 218823 - net-dns/bind-9.4.1_p1 fails to build
Summary: net-dns/bind-9.4.1_p1 fails to build
Status: RESOLVED DUPLICATE of bug 220361
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Server (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: BIND Maintainers (DISABLED)
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-04-22 03:39 UTC by Chris Smith
Modified: 2008-05-05 19:42 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Chris Smith 2008-04-22 03:39:51 UTC
net-dns/bind-9.4.1_p1 fails to build, possible issue with libtool-2.2

Reproducible: Always

Steps to Reproduce:
1.emerge bind
2.
3.

Actual Results:  
make[4]: Leaving directory `/var/tmp/portage/net-dns/bind-9.4.1_p1/work/bind-9.4.1-P1/lib/isc/unix/include'
/bin/sh /var/tmp/portage/net-dns/bind-9.4.1_p1/work/bind-9.4.1-P1/libtool --mode=compile i686-pc-linux-gnu-gcc  -I/var/tmp/portage/net-dns/bind-9.4.1_p1/work/bind-9.4.1-P1 -I./include -I./../pthreads/include -I../include -I./../include -I./..  -D_REENTRANT   -O2 -march=native -fomit-frame-pointer -pipe  -W -Wall -Wmissing-prototypes -Wcast-qual -Wwrite-strings -Wformat -Wpointer-arith -fno-strict-aliasing  -c app.c
/var/tmp/portage/net-dns/bind-9.4.1_p1/work/bind-9.4.1-P1/libtool: line 450: CDPATH: command not found
/var/tmp/portage/net-dns/bind-9.4.1_p1/work/bind-9.4.1-P1/libtool: line 1260: func_opt_split: command not found
libtool: Version mismatch error.  This is libtool 2.2, but the
libtool: definition of this LT_INIT comes from an older release.
libtool: You should recreate aclocal.m4 with macros from libtool 2.2
libtool: and run autoconf again.


Expected Results:  
should have built

emerge --info
Portage 2.1.5_rc5 (default/linux/x86/2008.0, gcc-4.3.0, glibc-2.7-r2, 2.6.25-gentoo-r1 i686)
=================================================================
System uname: 2.6.25-gentoo-r1 i686 Intel(R) Celeron(R) CPU 1.70GHz
Timestamp of tree: Mon, 21 Apr 2008 18:45:03 +0000
app-shells/bash:     3.2_p33
dev-lang/python:     2.5.2-r2
dev-python/pycrypto: 2.0.1-r6
sys-apps/baselayout: 2.0.0
sys-apps/openrc:     0.2.2
sys-apps/sandbox:    1.2.18.1-r2
sys-devel/autoconf:  2.13, 2.62
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.1
sys-devel/binutils:  2.18.50.0.6
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   2.2
virtual/os-headers:  2.6.25-r1
ACCEPT_KEYWORDS="x86 ~x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=native -fomit-frame-pointer -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /var/bind"
CONFIG_PROTECT_MASK="/etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-O2 -march=native -fomit-frame-pointer -pipe"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="--with-bdeps y"
FEATURES="distlocks metadata-transfer parallel-fetch sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://gentoo.chem.wisc.edu/gentoo"
LANG="en_US.UTF-8"
LDFLAGS=""
LINGUAS="en en_US"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync21.us.gentoo.org/gentoo-portage"
USE="acl acpi bash-completion berkdb bzip2 caps cli cracklib crypt cups dri fam fortran gdbm iconv ipv6 isdnlog ithreads jpeg kerberos ldap midi mmx mudflap ncurses nls nptl nptlonly openmp pam pcre perl png pppd python readline reflection session spl sse ssl threads unicode x86 xattr xorg zlib" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en en_US" USERLAND="GNU" VIDEO_CARDS="vesa i810 fbdev vga"
Unset:  CPPFLAGS, CTARGET, INSTALL_MASK, LC_ALL, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Tobias Scherbaum (RETIRED) gentoo-dev 2008-05-05 19:42:53 UTC

*** This bug has been marked as a duplicate of bug 220361 ***