Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 218794 - The great Gnome 2.22 keywording request bug
Summary: The great Gnome 2.22 keywording request bug
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High enhancement (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL:
Whiteboard:
Keywords: KEYWORDREQ
Depends on: 196852 215972 237026
Blocks: gnome2.22-tracker
  Show dependency tree
 
Reported: 2008-04-21 21:27 UTC by Gilles Dartiguelongue
Modified: 2010-11-14 18:37 UTC (History)
5 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
keywords-request.txt (keywords-request.txt,2.47 KB, text/plain)
2008-04-21 21:27 UTC, Gilles Dartiguelongue
Details
Log of failed build against =dev-python/pygtk-2.12.0 (20080423-151626.log.gz,4.54 KB, application/x-gzip)
2008-04-23 16:38 UTC, Jeroen Roovers
Details
Slightly but not fully updated list (keywords-request.txt,2.34 KB, text/plain)
2008-05-01 20:44 UTC, Mart Raudsepp
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Gilles Dartiguelongue gentoo-dev 2008-04-21 21:27:05 UTC
Hello arches, please find in the next attachments packages that needs (re)keywording for gnome-2.22 to be supported on your favorite platform.
Comment 1 Gilles Dartiguelongue gentoo-dev 2008-04-21 21:27:58 UTC
Created attachment 150539 [details]
keywords-request.txt
Comment 2 Gilles Dartiguelongue gentoo-dev 2008-04-21 21:29:17 UTC
gah missed my announcement effect. Please read comment #0 and #1 :)
Comment 3 Gilles Dartiguelongue gentoo-dev 2008-04-21 21:30:51 UTC
This list might be incomplete so in doubt, you can always poke me or the rest of the team on #gentoo-desktop, by mail, jabber, ...

Thanks in advance.
Comment 4 Dawid Węgliński (RETIRED) gentoo-dev 2008-04-21 21:46:54 UTC
Remove x86 as there's nothing to do for us. ;)
Comment 5 Olivier Crete (RETIRED) gentoo-dev 2008-04-21 21:56:42 UTC
There is nothing amd64 or x86 related in that list
Comment 6 Raúl Porcel (RETIRED) gentoo-dev 2008-04-22 20:02:05 UTC
~alpha/~ia64/~sparc done
Comment 7 Jeroen Roovers gentoo-dev 2008-04-23 16:38:31 UTC
Created attachment 150724 [details]
Log of failed build against =dev-python/pygtk-2.12.0

Could it be that net-libs/gtk-vnc needs >=dev-python/pygtk-2.12.1 ? I saw sandbox violations when building against =dev-python/pygtk-2.12.0.
Comment 8 Gilles Dartiguelongue gentoo-dev 2008-04-23 16:50:36 UTC
(In reply to comment #7)
> Created an attachment (id=150724) [edit]
> Log of failed build against =dev-python/pygtk-2.12.0
> 
> Could it be that net-libs/gtk-vnc needs >=dev-python/pygtk-2.12.1 ? I saw
> sandbox violations when building against =dev-python/pygtk-2.12.0.
> 

these kind of sandbox violation happens with migrating from python 2.4 to 2.5 without running python-updater.
Comment 9 Jeroen Roovers gentoo-dev 2008-04-23 17:18:14 UTC
Comment on attachment 150724 [details]
Log of failed build against =dev-python/pygtk-2.12.0

(In reply to comment #8)
> these kind of sandbox violation happens with migrating from python 2.4 to 2.5
> without running python-updater.

Ah yes, of course.
Comment 10 Markus Rothe (RETIRED) gentoo-dev 2008-04-24 18:29:20 UTC
added ~ppc64 as far as I could (some missing due to bug #176380)
Comment 11 Mart Raudsepp gentoo-dev 2008-05-01 20:44:36 UTC
Created attachment 151560 [details]
Slightly but not fully updated list
Comment 12 Mart Raudsepp gentoo-dev 2008-05-01 21:12:11 UTC
Additionally the following are necessary for gnome-games (ggz) and totem (gdata):

>=dev-games/libggz-0.0.14           alpha arm hppa ia64 ppc64 sh
>=dev-games/ggz-client-libs-0.0.14  alpha arm hppa ia64 ppc64 sh
>=dev-python/gdata-1                alpha arm hppa ia64 ppc64 sh

Re-CCing some arches based on that
Comment 13 Mart Raudsepp gentoo-dev 2008-05-01 21:17:45 UTC
sparc is also missing dev-python/gdata.

SPARC: Please keyword dev-python/gdata and after that feel free to copy the GNOME-2.22 unmask block from profiles/arch/x86/package.mask to your profiles in profiles/arch/sparc/package.mask and profiles/default-linux/sparc/package.mask
Comment 14 Ferris McCormick (RETIRED) gentoo-dev 2008-05-02 15:26:17 UTC
(In reply to comment #13)
> sparc is also missing dev-python/gdata.
> 
> SPARC: Please keyword dev-python/gdata and after that feel free to copy the
> GNOME-2.22 unmask block from profiles/arch/x86/package.mask to your profiles in
> profiles/arch/sparc/package.mask and profiles/default-linux/sparc/package.mask
> 
Added ~sparc for dev-python/gdata-1.0.8 --- it seems fine and its test check out.  As for the big gnome request, I am not in a position to do that (can't really test).
Comment 15 Raúl Porcel (RETIRED) gentoo-dev 2008-05-05 10:53:51 UTC
sparc is done
Comment 16 Raúl Porcel (RETIRED) gentoo-dev 2008-05-05 15:48:38 UTC
~alpha/~ia64 done
Comment 17 Markus Rothe (RETIRED) gentoo-dev 2008-05-14 16:37:28 UTC
removed ~ppc64 from gnome-base/gnome-volume-manager-2.22.1. We'll add ~ppc64 to the remaining packages on the list once bug #176380 is fixed.
Comment 18 nixnut (RETIRED) gentoo-dev 2008-06-01 11:27:56 UTC
~ppc'd. Let me know if I missed something.
Comment 19 Alexis Ballier gentoo-dev 2008-06-02 10:12:10 UTC
(In reply to comment #18)
> ~ppc'd. Let me know if I missed something.
> 

  DEPEND.bad                    17
   net-misc/vinagre/vinagre-0.5.1.ebuild: ~ppc(default-linux/ppc/ppc32/2006.1) ['>=net-libs/gtk-vnc-0.3.3']
   net-misc/vinagre/vinagre-0.5.1.ebuild: ~ppc(default-linux/ppc/ppc32/2007.0) ['>=net-libs/gtk-vnc-0.3.3']
   net-misc/vinagre/vinagre-0.5.1.ebuild: ~ppc(default-linux/ppc/ppc32/2007.0/desktop) ['>=net-libs/gtk-vnc-0.3.3']
   net-misc/vinagre/vinagre-0.5.1.ebuild: ~ppc(default-linux/ppc/ppc32/2007.0/G3) ['>=net-libs/gtk-vnc-0.3.3']
   net-misc/vinagre/vinagre-0.5.1.ebuild: ~ppc(default-linux/ppc/ppc32/2007.0/G3/Pegasos) ['>=net-libs/gtk-vnc-0.3.3']
   net-misc/vinagre/vinagre-0.5.1.ebuild: ~ppc(default-linux/ppc/ppc32/2007.0/G4) ['>=net-libs/gtk-vnc-0.3.3']


etc etc etc
Comment 20 Gilles Dartiguelongue gentoo-dev 2008-06-08 19:59:46 UTC
 ~hppa ['>=dev-libs/totem-pl-parser-2.22.2', '>=gnome-extra/gnome-power-manager-2.22.1', '>=media-video/totem-2.22.1']
 ~ppc ['>=gnome-extra/gnome-power-manager-2.22.1']

besides ppc64 that needs fixes for hal, hppa and ppc still need to fix the above packages. sparc, ia64, alpha got their ticket for unmasking.
Comment 21 Jeroen Roovers gentoo-dev 2008-07-15 18:43:58 UTC
(In reply to comment #20)
>  ~hppa ['>=dev-libs/totem-pl-parser-2.22.2',
> '>=gnome-extra/gnome-power-manager-2.22.1', '>=media-video/totem-2.22.1']
>  ~ppc ['>=gnome-extra/gnome-power-manager-2.22.1']
> 
> besides ppc64 that needs fixes for hal, hppa and ppc still need to fix the
> above packages. sparc, ia64, alpha got their ticket for unmasking.

totem doesn't seem to work for HPPA, continuously spitting out this message:
(totem:27645): GLib-GObject-CRITICAL **: g_signal_handler_disconnect: assertion `handler_id > 0' failed

I haven't been able to trace where exactly it goes wrong, but it would seem this is a glib function that is at fault.
Comment 22 Mart Raudsepp gentoo-dev 2008-08-26 21:21:55 UTC
What does "doesn't work" mean? The warning is a warning. It can happen while everything is working fine too, so not really descriptive. The warning happens when an event signal is tried to be disconnected (probably temporarily) but that exact signal doesn't exist to disconnect. So if there's a real problem, then it might be related if a signal isn't connected and therefore something doesn't work, but otherwise maybe doesn't even matter much.
Comment 23 Mart Raudsepp gentoo-dev 2008-09-03 01:20:30 UTC
HPPA, I copied the GNOME-2.22 mask to your profiles, so that I can unmask it globally while the HPPA keywording is sorted out. However I will look later into unmasking most of it if possible, as lack of totem-2.22 just means the meta can't be keyworded, but the rest of GNOME-2.22 could be there if you keyworded the rest (sans totem-2.22 experience with its new features).
Comment 24 Jeroen Roovers gentoo-dev 2008-09-08 04:25:05 UTC
How is this bug related to bug #236971 and bug #236971? Except for totem, HPPA is all done, I think.
Comment 25 Mart Raudsepp gentoo-dev 2008-09-08 04:39:58 UTC
(In reply to comment #24)
> How is this bug related to bug #236971 and bug #236971? Except for totem, HPPA
> is all done, I think.

Sorry, yes, you might be done with the rest, as your keyword level is testing right now for GNOME-2.22. I'll try to unmask most of GNOME-2.22 for you soon then, I assume that's fine. Then you can start thinking about stabilization when you feel it suitable, considering it will enter ~hppa only now, 2.22 has been out for half a year and we are likely to be asking GNOME-2.24 stabilization from arches in 6 weeks from now, so I'm not sure the 30 days in ~arch should apply here once unmasked.
Comment 26 Jeroen Roovers gentoo-dev 2008-09-25 17:28:27 UTC
With totem having dropped HPPA keywords and totem-pl-parser having no HPPA keyword at all, and the gnome-2.22* ebuilds having their HPPA keywords dropped (to make repoman happy), HPPA is done here. Once the totem problem has been resolved I will readd it.
Comment 27 SpanKY gentoo-dev 2008-09-29 02:48:41 UTC
shouldnt x11-libs/gtk+-2.14.3 be in the mask as well since it requires gail-1000+
Comment 28 Mart Raudsepp gentoo-dev 2008-09-29 03:20:05 UTC
(In reply to comment #27)
> shouldnt x11-libs/gtk+-2.14.3 be in the mask as well since it requires
> gail-1000+

gtk+-2.14.3 and gail-1000 are recent things that GNOME-2.24 uses. gtk+-2.14.3 now ships gail libraries itself, hence the gail-1000. We have always tried to keep gtk+ not masked anyhow even if GNOME is I think, because gtk+ is not for only GNOME but many other apps and XFCE4 too.
gtk+-2.14.3 was added 4-5 days ago to tree, and unmasked 8 hours ago as a normal big gtk+ upgrade for all apps to benefit with new API and features.
Comment 29 Mart Raudsepp gentoo-dev 2008-09-29 03:21:33 UTC
(In reply to comment #27)
> shouldnt x11-libs/gtk+-2.14.3 be in the mask as well since it requires
> gail-1000+

Oh, I get it what you mean. You are having >=gail-2.22 p.masked, but that includes gail-1000. I think we can simply remove that one p.mask entry our of many from all profiles because this is a low-level thing that should work fine with GNOME-2.20 as welll
Comment 30 Mart Raudsepp gentoo-dev 2008-09-30 08:31:41 UTC
(In reply to comment #29)
> I think we can simply remove that one p.mask entry our of
> many from all profiles because this is a low-level thing that should work fine
> with GNOME-2.20 as well

I've done that now
Comment 31 Joe Jezak (RETIRED) gentoo-dev 2009-03-18 06:39:51 UTC
PPC should be all set here...
Comment 32 Raúl Porcel (RETIRED) gentoo-dev 2009-04-28 17:56:39 UTC
arm done and s390 has nothing to do here.

sh waiting for totem
Comment 33 Raúl Porcel (RETIRED) gentoo-dev 2009-04-28 18:25:28 UTC
Adding a dep to bug 196852
Comment 34 Alexis Ballier gentoo-dev 2009-07-05 21:39:44 UTC
bsd should be done here except for badindev deps in nautilus
Comment 35 Gilles Dartiguelongue gentoo-dev 2009-08-14 11:58:49 UTC
obsoleted by bug #238650