Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 218724 - media-gfx/splash-themes-livecd-2007.0-r1 doesnt work correctly with sys-apps/openrc
Summary: media-gfx/splash-themes-livecd-2007.0-r1 doesnt work correctly with sys-apps/...
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] baselayout (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Gentoo LiveCD Package Maintainers
Depends on:
Reported: 2008-04-21 11:43 UTC by Peter
Modified: 2008-10-09 11:26 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---

profile file (profile,13.65 KB, text/plain)
2008-05-27 09:52 UTC, Peter
svcs_start file (svcs_start,456 bytes, text/plain)
2008-05-27 09:53 UTC, Peter
/lib/splash/cache/profile (profile,13.05 KB, text/plain)
2008-08-18 11:28 UTC, Peter

Note You need to log in before you can comment on or make changes to this bug.
Description Peter 2008-04-21 11:43:48 UTC
when i use this splash with openrc and baselayout-2 the boot icons doesn' show correctly, first of all when system starts to boot it should show me chechfs is starting or something but it isn't another thing is that i see only free boot icons bootmisc, alsasound and keymaps and nothing more, and one more thing when initializing the kernel is finished and system start to booting i still have in bottom left corner this information that the computer is initializing the kernel... on media-gfx/splash-themes-livecd-2006.1 icons are displaying correctly but still with this inf. that system is initializing the kernel dunno maybe this is an issue with genkernel...

Reproducible: Always

Steps to Reproduce:
Comment 1 Michal Januszewski (RETIRED) gentoo-dev 2008-05-01 08:48:26 UTC
Could you please boot with splash=<your_options>,profile and attach the /lib/splash/cache/profile file?
Comment 2 Peter 2008-05-02 09:11:45 UTC
this are mine options in /etc/lilo.conf "splash=silent,theme:livecd-2007.0 console=tty1 quiet" and the file u asked me for is an empty file...
Comment 3 Michal Januszewski (RETIRED) gentoo-dev 2008-05-05 15:37:34 UTC
You changed your command line to "splash=silent,theme:livecd-2007.0,profile
console=tty1 quiet" and rebooted, right?

Could you please post your emerge --info?
Comment 4 Peter 2008-05-05 17:58:53 UTC
yes i have added, and still the same and here is mine emerge --info:

Portage 2.1.5_rc6 (default/linux/x86/2008.0/desktop, gcc-4.2.3, glibc-2.7-r2, 2.6.25-gentoo-r1 i686)
System uname: 2.6.25-gentoo-r1 i686 Intel(R) Core(TM)2 Duo CPU E6550 @ 2.33GHz
Timestamp of tree: Mon, 05 May 2008 09:05:01 +0000
ccache version 2.4 [enabled]
app-shells/bash:     3.2_p39
dev-java/java-config: 1.3.7, 2.1.6
dev-lang/python:     2.5.2-r2
dev-python/pycrypto: 2.0.1-r6
dev-util/ccache:     2.4-r7
sys-apps/baselayout: 2.0.0
sys-apps/openrc:     0.2.3
sys-devel/autoconf:  2.13, 2.62
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.1-r1
sys-devel/binutils:  2.18-r1
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   2.2.4
virtual/os-headers:  2.6.25-r1
CFLAGS="-O2 -mtune=generic -mmmx -msse -msse2 -msse3 -fomit-frame-pointer -mfpmath=sse -pipe"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/splash /etc/terminfo /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-O2 -mtune=generic -mmmx -msse -msse2 -msse3 -fomit-frame-pointer -mfpmath=sse -pipe"
FEATURES="ccache distlocks parallel-fetch sandbox sfperms strict unmerge-orphans userfetch"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTDIR_OVERLAY="/usr/local/overlays/xeffects/jmbsvicetto /usr/local/overlays/berkano /usr/local/overlays/kadu-svn /usr/local/overlays/portage-arcon"
USE="X aac acl acpi alsa berkdb bluetooth branding bzip2 cairo cdr cli cracklib crypt cups dbus divx4linux dri dvd dvdr dvdread eds emboss encode evo fam firefox flac fortran gdbm gif gimpprint gpm hal iconv isdnlog jpeg kde kdeenablefinal kerberos ldap libcaca libnotify mad matriska midi mikmod mmx mmx2 mp3 mpeg mudflap ncurses nls nptl nptlonly nvidia ogg opengl openmp pam pccts pcre pdf perl png ppds pppd python qt qt3 qt3support qt4 quicktime readline real reflection sdl session slang smp spell spl sse sse2 sse3 ssl ssse3 startup-notification svg tcpd theora tiff truetype type1 unicode userlocales vorbis win32codecs x86 xml xorg xv xvid xvmc zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="pl" USERLAND="GNU" VIDEO_CARDS="nvidia"
Comment 5 Michal Januszewski (RETIRED) gentoo-dev 2008-05-25 12:20:53 UTC
Could you please try to upgrade to the latest available version of baselayout and openrc, re-emerge splashutils and retry booting with the 'profile' splash option?
Comment 6 Peter 2008-05-26 13:16:09 UTC
Heh still no use, i have baselayout-2.0 and openrc-0.2.4-r1 and as allways i make my initrd with genkernel...
Comment 7 Michal Januszewski (RETIRED) gentoo-dev 2008-05-26 16:24:30 UTC
Do you have any files in /lib/splash/cache?
Comment 8 Peter 2008-05-27 09:39:04 UTC
yes i have and this are those files what i have:

-rw-r--r-- 1 root root     6 sty  9 23:44
-rw-r--r-- 1 root root 51289 sty  2 19:35 depcache
-rw-r--r-- 1 root root 20649 sty  2 19:35 deptree
-rw-r--r-- 1 root root     0 maj 26 00:12 .keep_media-gfx_splashutils-0
-rw-r--r-- 1 root root    85 sty  2 19:32 levels
-rw-r--r-- 1 root root     0 sty  9 23:44 message
-rw-r--r-- 1 root root 13978 maj 27 11:30 profile
-rw-r--r-- 1 root root   291 sty  9 23:44 progress
prw-r--r-- 1 root root     0 sty  9 23:44 .splash
-rw-r--r-- 1 root root   456 maj 27  2008 svcs_start
Comment 9 Michal Januszewski (RETIRED) gentoo-dev 2008-05-27 09:44:11 UTC
Could you please attach the 'profile' and 'svcs_start' files from this directory?
Comment 10 Peter 2008-05-27 09:52:32 UTC
Created attachment 154449 [details]
profile file
Comment 11 Peter 2008-05-27 09:53:11 UTC
Created attachment 154451 [details]
svcs_start file
Comment 12 Peter 2008-05-27 09:53:59 UTC
this are those files you asked for
Comment 13 Michal Januszewski (RETIRED) gentoo-dev 2008-05-27 13:05:20 UTC
Oh, I just noticed that you don't have the 'mng' USE flag set.  Could you please try to set it and reinstall splashutils?  This should fix your problem with the boot icons.

Could you also try running `splash_manager -c demo -t livecd-2007.0`.  What text message do you see at the bottom of the screen?
Comment 14 Peter 2008-05-27 15:32:59 UTC
but i have mng flag turned on as u can see:

[ebuild   R   ] media-gfx/splashutils-  USE="fbcondecor gpm mng png truetype -hardened"

and mng flag is turned on in package.use only for splashutils, no less no more, and this command u wrote me works only on root and i see in bottom left corner "Testing the 'livecd-2007.0' theme (here is %)"
Comment 15 Michal Januszewski (RETIRED) gentoo-dev 2008-07-22 22:07:46 UTC
Could you please upgrade to splashutils- and see whether you still experience this problem?

If you do, please boot with "splash=silent,theme:livecd-2007.0,profile
console=tty1" and try running `splash_manager -c replay -t livecd-2007.0`.  Are the icons working when the fbsplash daemon is run this way?
Comment 16 Peter 2008-07-24 08:32:01 UTC
oh after upgrading the baselayoput and making initrd with genkernel again it works but still when the system checks fs there is no icon and gpm also has no icon and i still have in bottom left corner this information that the computer is initializing the kernel with no %... but now it really looks better
Comment 17 Michal Januszewski (RETIRED) gentoo-dev 2008-07-24 19:49:19 UTC
Nice :)  As I said in my previous comment, could you please boot with "splash=silent,theme:livecd-2007.0,profile console=tty1" and try running `splash_manager -c replay -t livecd-2007.0`.  Are the icons working when the fbsplash daemon is run this way?

Also, please attach your new (after booting using the parameters described above) /lib/splash/cache/profile file.

Comment 18 Peter 2008-08-18 11:27:34 UTC
ok i have booted with "splash=silent,theme:livecd-2007.0,profile console=tty1" and still no % and running `splash_manager -c replay -t livecd-2007.0` shows me the same icons what i see on boot process still without checkfs
Comment 19 Peter 2008-08-18 11:28:33 UTC
Created attachment 163199 [details]

this is this file you asked for
Comment 20 Michal Januszewski (RETIRED) gentoo-dev 2008-08-19 07:12:49 UTC
(In reply to comment #18)
> ok i have booted with "splash=silent,theme:livecd-2007.0,profile console=tty1"
> and still no % and running `splash_manager -c replay -t livecd-2007.0` shows me
> the same icons what i see on boot process still without checkfs

The profile file doesn't contain any information about checkfs.  It looks like this service isn't started during boot.  Are you sure it exists and is started during boot?

Do you see the system message with the % progress when you run `splash_manager -c replay -t livecd-2007.0`?
Comment 21 Peter 2008-08-19 10:59:38 UTC
this are mine ale processes, and as you can see fsck is starting on boot also gpm is starting

                  gpm |      default
                  xdm |      default
           ntp-client |      default
                 dbus |      default
                 fsck | boot
                 hald |      default
                 mtab | boot
                 root | boot
                 sshd |      default
                 swap | boot
              keymaps | boot
                cupsd |      default
                local |      default nonetwork
           vixie-cron |      default
            syslog-ng |      default
           lm_sensors |      default
           localmount | boot
          consolefont | boot
              modules | boot
             hostname | boot
           fbcondecor |      default
               net.lo | boot
             net.eth0 |      default
               procfs | boot
             netmount |      default
               sysctl | boot
              urandom | boot
         termencoding | boot
             timidity |      default
              hwclock | boot
         cpufrequtils | boot
             bootmisc | boot
        device-mapper | boot
            alsasound | boot
Comment 22 Peter 2008-08-20 10:56:50 UTC
i forget to tell you that yes when i run `splash_manager
-c replay -t livecd-2007.0` i see % progress
Comment 23 Michal Januszewski (RETIRED) gentoo-dev 2008-08-20 20:07:46 UTC
The problem seems to be caused by the fact that the theme doesn't contain icon links for the new names of the services used by openrc (e.g. checkfs -> fsck).

livecd team: Could you please update the theme by adding the missing links?
Comment 24 Andrew Gaffney (RETIRED) gentoo-dev 2008-08-20 20:21:02 UTC
You might want to do it yourself. There is essentially no livecd@ team anymore, since wolf31o2 retired.
Comment 25 Matthew Kasa (RETIRED) gentoo-dev 2008-08-20 20:41:30 UTC
If you give me a list of the links needed I'll roll a new tarball, but I don't have -x86 commit access anymore, so someone else will still have to bump the ebuild.
Comment 26 Michal Januszewski (RETIRED) gentoo-dev 2008-08-24 13:32:17 UTC
Cool, I can bump the ebuild if you make a new release tarball.  The new links would seem to be:

checkfs -> fsck
clock -> hwclock

Also, while we're at the issue of making a new release of the theme, could you please change the rc_init-pre script so that it would use `/sbin/splash_util.static -c getres -t livecd-2007.0` instead of `/sbin/fbres`?  It will make it possible for the theme to work with resolutions that aren't explicitly supported by it.
Comment 27 Michal Januszewski (RETIRED) gentoo-dev 2008-09-14 11:45:04 UTC
Fixed in -r2.
Comment 28 Peter 2008-09-15 08:26:37 UTC
yes now it works but still i see no % and no F2 button but alt+F1... but yes finally i see all icons what is nice:)
Comment 29 Peter 2008-10-09 11:26:50 UTC
okej now finally it is solved with newest openrc3 and finally i see those % for witch i'm glad ]:->