Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 218666 - media-libs/libsndfile - eautoreconf fails with >=sys-devel/libtool-2.2
Summary: media-libs/libsndfile - eautoreconf fails with >=sys-devel/libtool-2.2
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Unspecified (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Gentoo Linux bug wranglers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: libtool-2.2
  Show dependency tree
 
Reported: 2008-04-21 00:26 UTC by Lars Wendler (Polynomial-C)
Modified: 2008-04-21 07:14 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Lars Wendler (Polynomial-C) gentoo-dev 2008-04-21 00:26:50 UTC
libsndfile fails during eautoreconf when >=libtool-2.2 is installed:

 * Running automake --add-missing --copy ...                              [ !! ]

 * Failed Running automake !
 *
 * Include in your bugreport the contents of:
 *
 *   /home/.portage/tmp/portage/media-libs/libsndfile-1.0.17-r1/temp/automake-16453.out

The content of that file looks like this:

***** automake *****
***** automake --add-missing --copy

src/Makefile.am:38: compiling `file_io.c' with per-target flags requires `AM_PROG_CC_C_O' in `configure.ac'
/usr/share/automake-1.10/am/depend2.am: am__fastdepCXX does not appear in AM_CONDITIONAL
/usr/share/automake-1.10/am/depend2.am:   The usual way to define `am__fastdepCXX' is to add `AC_PROG_CXX'
/usr/share/automake-1.10/am/depend2.am:   to `configure.ac' and run `aclocal' and `autoconf' again.
tests/Makefile.am: C++ source seen but `CXX' is undefined
tests/Makefile.am:   The usual way to define `CXX' is to add `AC_PROG_CXX'
tests/Makefile.am:   to `configure.ac' and run `autoconf' again.


The fix is the same as for bug# 212772:

sed -i -e '/AC_PROG_CC/aAC_PROG_CXX' "${S}"/configure.ac

Reproducible: Always

Steps to Reproduce: