Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 218327 - x11-drivers/xf86-video-ati-6.8.0-r1 freeze in games-fps/nexuiz-2.4 and i have this message in Xorg log: (II) AIGLX: Suspending AIGLX clients for VT switch
Summary: x11-drivers/xf86-video-ati-6.8.0-r1 freeze in games-fps/nexuiz-2.4 and i have...
Status: RESOLVED NEEDINFO
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Unspecified (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo X packagers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-04-18 20:25 UTC by GNUtoo
Modified: 2009-05-08 12:26 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
Xorg.0.log (Xorg.0.log_crash_2,88.76 KB, text/plain)
2008-04-18 20:26 UTC, GNUtoo
Details
xorg.conf (xorg.conf,6.91 KB, text/plain)
2008-04-18 20:26 UTC, GNUtoo
Details
crash under nexuiz (7.0.3,78.59 KB, text/plain)
2008-05-20 16:40 UTC, GNUtoo
Details
new crash (bugreport,95.50 KB, text/plain)
2008-06-05 18:44 UTC, GNUtoo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description GNUtoo 2008-04-18 20:25:21 UTC
hello,if i play long enough in nexuiz, my screen freeze...but i can access the computer trough ssh
so i used ssh to retrive Xorg log
i'll attach Xorg.conf and Xorg logs
this happened twice so the 2 logs tells me that at their end:
(II) AIGLX: Suspending AIGLX clients for VT switch
but i do not have aiglx enabled...strange



Reproducible: Always




# emerge --info
 * Overlay eclasses override eclasses from PORTDIR:
 *
 *   '/usr/portage/local/layman/java-gcj-overlay/eclass/java-osgi.eclass'
 *   '/usr/portage/local/layman/java-gcj-overlay/eclass/java-pkg-2.eclass'
 *   '/usr/portage/local/layman/java-gcj-overlay/eclass/java-pkg-opt-2.eclass'
 *   '/usr/portage/local/layman/java-gcj-overlay/eclass/java-utils-2.eclass'
 *   '/usr/portage/local/layman/kde/eclass/kde4-base.eclass'
 *   '/usr/portage/local/layman/kde/eclass/kde4-functions.eclass'
 *   '/usr/portage/local/layman/kde/eclass/kde4-meta.eclass'
 *   '/usr/overlay/eclass/mercurial.eclass'
 *
 * It is best to avoid overridding eclasses from PORTDIR because it will
 * trigger invalidation of cached ebuild metadata that is distributed with
 * the portage tree. If you must override eclasses from PORTDIR then you
 * are advised to run `emerge --regen` after each time that you run `emerge
 * --sync`. Set PORTAGE_ECLASS_WARNING_ENABLE="0" in /etc/make.conf if you
 * would like to disable this warning.
Portage 2.1.4.4 (selinux/2007.0/x86, gcc-4.2.2, glibc-2.6.1-r0, 2.6.25_port4 i686)
=================================================================
System uname: 2.6.25_port4 i686 Intel(R) Pentium(R) M processor 2.00GHz
Timestamp of tree: Fri, 18 Apr 2008 15:00:11 +0000
distcc 2.18.3 i686-pc-linux-gnu (protocols 1 and 2) (default port 3632) [disabled]
ccache version 2.4 [disabled]
app-shells/bash:     3.2_p17-r1
dev-java/java-config: 1.3.7, 2.1.4
dev-lang/python:     2.3.6-r4, 2.4.4-r6, 2.5.1-r4
dev-python/pycrypto: 2.0.1-r6
dev-util/ccache:     2.4-r7
sys-apps/baselayout: 1.12.11.1
sys-apps/sandbox:    1.2.18.1-r2
sys-devel/autoconf:  2.13, 2.61-r1
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10
sys-devel/binutils:  2.18-r1
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   1.5.26
virtual/os-headers:  2.6.23-r3
ACCEPT_KEYWORDS="x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=pentium-m -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config /var/bind"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/terminfo /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-O2 -march=pentium-m -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="distlocks loadpolicy metadata-transfer nostrip parallel-fetch sandbox selinux sesandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://distfiles.gentoo.org http://distro.ibiblio.org/pub/linux/distributions/gentoo"
LANG="en_US.utf8"
LC_ALL="en_US.utf8"
LINGUAS="en en_GB en_US"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/overlay /usr/portage/local/layman/pro-audio /usr/portage/local/layman/sunrise /usr/portage/local/layman/custom-kernels /usr/portage/local/layman/java-overlay /usr/portage/local/layman/java-gcj-overlay /usr/portage/local/layman/zugaina /usr/portage/local/layman/kde /usr/overlay"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="7zip X a52 aac acl acpi adns aiglx alsa amr apache2 asf bash-completion berkdb bl blender-game bluetooth branding cdda cddb cdparanoia chardet clearcase cli contrarius cracklib cran crypt css cups cvs dbus dga dia divx dri dts dv dvb dvd dvdnav dvdr dvdread editor effects enca encode examples exif expat fam fat ffmpeg firefox flac foomaticdb fping fuse gcj gdbm gif gimp gimpprint glsa gmedia gmp gnutls gpm gstreamer gtk hfs httpd iconv ieee1394 imagemagick inkjar inquisitio irmc isdnlog jabber jfs jpeg jpeg2k kde kerberos kqemu lcms ldap libnotify lzo mad maps matroska midi mikmod mjpeg mmx mmxext mng modplug mp2 mp3 mp4 mpi mplayer mudflap musepack ncurses nfs nptl nptlonly nsplugin ntfs ofa ogg openal openexr openmp p2p pam pcre perforce perl php plugin png pnm postscript ppds pppd python qa qt3 quicktime quotas readline realmedia reflection reiser4 reiserfs rt2500pci rtc rtsp samba sasl scenarios sdl selinux session skins slang sox speex spell spl srteam sse sse2 ssl stream subtitles subversion svg swat tga theora tiff timidity tordns truetype tta unicode usb v4l vcd vidx vlm vorbis wavpack wifi wma wmf wmp wxwindows x86 xanim xfs xine xml xorg xprint xv xvid xvmc yahoo yv12 zlib zrtp zsh" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="access auth auth_dbm auth_anon auth_digest alias file-cache echo charset-lite cache disk-cache mem-cache ext-filter case_filter case-filter-in deflate mime-magic cern-meta expires headers usertrack unique-id proxy proxy-connect proxy-ftp proxy-http info include cgi cgid dav dav-fs vhost-alias speling rewrite log_config logio env setenvif mime status autoindex asis negotiation dir imap actions userdir so filter unique_id authz_host" ELIBC="glibc" INPUT_DEVICES="wacom evdev keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en en_GB en_US" USERLAND="GNU" VIDEO_CARDS="radeon"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LDFLAGS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 GNUtoo 2008-04-18 20:26:05 UTC
Created attachment 150222 [details]
Xorg.0.log
Comment 2 GNUtoo 2008-04-18 20:26:53 UTC
Created attachment 150226 [details]
xorg.conf
Comment 3 GNUtoo 2008-04-18 20:27:23 UTC
# lspci | grep VGA
01:00.0 VGA compatible controller: ATI Technologies Inc Radeon Mobility X700 (PCIE)
Comment 4 Donnie Berkholz (RETIRED) gentoo-dev 2008-04-21 04:41:20 UTC
AIGLX is enabled by default nowadays.

Which mesa version do you have?
Comment 5 GNUtoo 2008-04-22 12:28:43 UTC
(In reply to comment #4)
> AIGLX is enabled by default nowadays.
> 
> Which mesa version do you have?
> 

7.0.2
Comment 6 Donnie Berkholz (RETIRED) gentoo-dev 2008-04-30 17:38:31 UTC
Could you try mesa 7.0.3?
Comment 7 Donnie Berkholz (RETIRED) gentoo-dev 2008-05-09 08:12:40 UTC
Please reopen when you reply.
Comment 8 GNUtoo 2008-05-20 16:40:56 UTC
Created attachment 153767 [details]
crash under nexuiz

it still crashed when i played nexuiz
Comment 9 GNUtoo 2008-05-20 16:41:27 UTC
as i can't reopen as i attach i file i reopen now
Comment 10 GNUtoo 2008-06-05 18:44:19 UTC
Created attachment 155637 [details]
new crash
Comment 11 GNUtoo 2008-06-05 18:45:54 UTC
this time i ran nexuiz at the same resolution than Xorg...and i was able to kill nexuiz...that made me return under a special screen of gnome telling me that i could log out...that's what i made because the mouse wasn't working anymore...
Comment 12 Rémi Cardona gentoo-dev 2009-05-08 12:26:13 UTC
Can you still reproduce this bug with the latest stable versions of xorg-server (1.5.3-r5) and xf86-video-ati (6.12.1-r1) ?

If so, please don't hesitate to reopen this bug (with an updated Xorg.0.log if you can get one).

Thanks