Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 217925 - amsn-0.97 does not work with kde4-s systray
Summary: amsn-0.97 does not work with kde4-s systray
Status: VERIFIED TEST-REQUEST
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo net-im Herd
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-04-16 10:29 UTC by David Carlos Manuelda
Modified: 2008-08-07 15:29 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
patch for a working systray icon in kde4 (amsn-0.97-kde4-systray.patch,1.25 KB, patch)
2008-04-16 10:30 UTC, David Carlos Manuelda
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description David Carlos Manuelda 2008-04-16 10:29:48 UTC
I know this is an upstream bug, but they have fixed it in their trunk. I have been looking it, and I created a patch to backport this fix to current 0.97. And it is working now in KDE4 (as well as KDE3) systray.

Could you apply in a revbump?

Reproducible: Always
Comment 1 David Carlos Manuelda 2008-04-16 10:30:22 UTC
Created attachment 149918 [details, diff]
patch for a working systray icon in kde4
Comment 2 David Hardstone 2008-04-26 13:45:44 UTC
I think this was a bug in KDE4 itself and was fixed in KDE 4.0.2.
Comment 3 Olivier Crete (RETIRED) gentoo-dev 2008-04-26 14:29:27 UTC
get kde 4.0.2 then...
Comment 4 David Carlos Manuelda 2008-04-26 15:48:34 UTC
It WAS NOT fixed in KDE 4.0.2 because I was using trunk (later than 4.0.2 release) when I discovered that bug. And, the fixed it upstream (and this is the reason I tried to backport it). If you google a bit, you could see the problem :)

So I reopen
Comment 5 Olivier Crete (RETIRED) gentoo-dev 2008-08-07 01:21:02 UTC
is that patch in 0.97.2 ? Has it been reported upstream ?
Comment 6 David Carlos Manuelda 2008-08-07 12:21:30 UTC
Sorry for my late answer, I have just installed KDE from svn trunk (4.2), and it seems it is working again as expected.

If anyone can try in kde 4.1 and see if it is fixed in 4.1 I could close the bug.
Comment 7 Olivier Crete (RETIRED) gentoo-dev 2008-08-07 15:29:57 UTC
It seems its been fixed in KDE 4.1
http://www.amsn-project.net/forums/viewtopic.php?t=5538