Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 217851 - media-sound/cheesetracker-0.9.15.3 fails w/ gcc-4.3.0
Summary: media-sound/cheesetracker-0.9.15.3 fails w/ gcc-4.3.0
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] GCC Porting (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Sound Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: gcc-4.3
  Show dependency tree
 
Reported: 2008-04-15 20:10 UTC by Peter Alfredsen (RETIRED)
Modified: 2008-04-16 17:49 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
cheesetracker-0.9.15.3-gcc43.patch (cheesetracker-0.9.15.3-gcc43.patch,5.21 KB, patch)
2008-04-15 20:11 UTC, Peter Alfredsen (RETIRED)
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Peter Alfredsen (RETIRED) gentoo-dev 2008-04-15 20:10:14 UTC
g++ -o cheesetracker/trackercore/file_writer.o -c -I/usr/lib/sigc++-1.2/include -I/usr/include/sigc++-1.2 -I/usr/include -trigraphs -Wpointer-arith -D_GLIBCXX_DEBUG -DPOSIX_ENABLED -DBITS_PER_BYTE=8 -DHAVE_LIBAUDIOFILE -D__STDC_LIMIT_MACROS -DHAVE_GNU_BASENAME -DHAVE_STDINT_H -DHAVE_MMAP -DHAVE_MADVISE -g -Wall -DLADSPA_ENABLED -DOSS_ENABLED -DALSA_ENABLED -I/usr/include/alsa -Icommon/ -Icommon/defines/ -I/usr/qt/3/include -DQT_NO_EMIT -I/usr/qt/3/include -DQT_NO_EMIT -Icommon -I. -Icommon/defines cheesetracker/trackercore/file_writer.cpp
cheesetracker/trackercore/file_writer.cpp: In member function ‘void File_Writer::store_pascal_string(const char*)’:
cheesetracker/trackercore/file_writer.cpp:145: error: ‘strlen’ was not declared in this scope
scons: *** [cheesetracker/trackercore/file_writer.o] Error 1
scons: building terminated because of errors.


Reproducible: Always

Steps to Reproduce:
Comment 1 Peter Alfredsen (RETIRED) gentoo-dev 2008-04-15 20:11:00 UTC
Created attachment 149843 [details, diff]
cheesetracker-0.9.15.3-gcc43.patch

Fixes the problem. Snatched from Debian.
Comment 2 Samuli Suominen gentoo-dev 2008-04-16 17:49:10 UTC
Thanks.

+  16 Apr 2008; Samuli Suominen <drac@gentoo.org>
+  +files/cheesetracker-0.9.15.3-gcc43.patch, cheesetracker-0.9.15.3.ebuild:
+  Fix building with GCC 4.3 wrt #217851, thanks to Peter Alfredsen.