Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 217743 - xfce-extra/xfce4-sensors-0.10.99.3 broken
Summary: xfce-extra/xfce4-sensors-0.10.99.3 broken
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: x86 Linux
: High major (vote)
Assignee: XFCE Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-04-15 01:20 UTC by takuan
Modified: 2008-06-28 13:25 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
patch to re-enable refresh_acpi (xfce4-sensors-0.10.99.3-acpi.patch,791 bytes, patch)
2008-04-16 10:18 UTC, Tim Taubert
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description takuan 2008-04-15 01:20:23 UTC
xfce-extra/xfce4-sensors-0.10.99.3 breaks my acpi and hddtemp sensors.
They work with xfce-extra/xfce4-sensors-0.10.99.2

Reproducible: Always

Steps to Reproduce:
It may be hard to reproduce due to different hardware. It is reproducible on the Kohjinsha SH series laptops.
Comment 1 Jeroen Roovers (RETIRED) gentoo-dev 2008-04-15 16:16:41 UTC
You'll need to provide a lot more information than you have done so far. Your emerge --info is required at the very least. Some build/usage output (error messages) would be very welcome as well.
Comment 2 Tim Taubert 2008-04-16 10:18:46 UTC
Created attachment 149917 [details, diff]
patch to re-enable refresh_acpi

For some reason the author commented out the call to 'refresh_acpi'. This patch re-enables this function and works for acpi only.

I'm not using hddtemp and therefore can't tell anything about it.
Comment 3 Tim Taubert 2008-04-16 10:25:34 UTC
Oh, my bad. Look at bug #214527. Combine mine and Andy Crook's patch and acpi and hddtemp should work again.
Comment 4 Arthur Spitzer 2008-05-24 16:40:30 UTC
Hi,

will there be an ebuild with included patches? Would be very nice.

With best regards,
Arthur
Comment 5 Samuli Suominen gentoo-dev 2008-05-31 11:48:11 UTC
+*xfce4-sensors-0.10.99.3-r1 (31 May 2008)
+
+  31 May 2008; Samuli Suominen <drac@gentoo.org>
+  +files/xfce4-sensors-0.10.99.3-acpi.patch,
+  +files/xfce4-sensors-0.10.99.3-hddtemp.patch,
+  +xfce4-sensors-0.10.99.3-r1.ebuild:
+  Apply patches ffrom bugs 217743 and 214527, thanks to Torsten Krah, Paolo
+  Pedroni, Tim Taubert and Andy Crook. Fixes for ACPI and hddtemp.
Comment 6 Samuli Suominen gentoo-dev 2008-06-05 12:44:41 UTC
The patch is now removed from -r2, because it breaks xfce4-sensors. It won't start anymore.
Comment 7 Fabian Nowak 2008-06-28 00:56:43 UTC
(In reply to comment #6)
> The patch is now removed from -r2, because it breaks xfce4-sensors. It won't
> start anymore.
> 

can you please try o.10.99.5 from svn and tell me exactly what is failing  and where? See ./configure --help and --enable-debug or similar to get the output. Also include your configuration, i.e. tree /proc/acpi, ls -l `which hddtemp`, and similar.

Comment 8 Arthur Spitzer 2008-06-28 08:21:18 UTC
Hi,

checked version from svn.
./autogen.sh --enable-debug:
...
===============================================================
Build Configuration
===============================================================

Host system:  

The following sensor interfaces will be built into the plugin:
*  libsensors
*  /proc/acpi

Full debug is enabled

===============================================================

Compiled. Installed. Works!
Do you still need the acpi tree etc. ?
Comment 9 Fabian Nowak 2008-06-28 13:25:09 UTC
(In reply to comment #8)

Well, closing the bug reports would be enough ;-)