Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 217283 - gnome-base/gvfs and sys-fs/fuse-2.7.2 hangs sync call
Summary: gnome-base/gvfs and sys-fs/fuse-2.7.2 hangs sync call
Status: VERIFIED WORKSFORME
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] GNOME (show other bugs)
Hardware: AMD64 Linux
: High critical (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-04-11 12:14 UTC by Jimmy.Jazz
Modified: 2008-08-26 12:10 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
fuse config.log (config.log,4.80 KB, text/plain)
2008-04-22 16:21 UTC, Jimmy.Jazz
Details
emerge --info (emerge-info.txt,4.24 KB, text/plain)
2008-04-22 16:23 UTC, Jimmy.Jazz
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jimmy.Jazz 2008-04-11 12:14:43 UTC
gvfs when compiled with fuse USE flag calls fusermount when a gnome session is opened.fusermount makes sync to hang. strace and gdb return both operation not permitted and hang also.

# ps aux 
fusermount -o rw,nosuid,nodev,subtype=gvfs-fuse-daemon -- /home/user/.gvfs

Moreover when you close the gnome session, fusermount won't be killed.

Reproducible: Always

Steps to Reproduce:
1.run a gnome session (optionally, leave it)
2.ps aux | grep fusermount
3.run sync   <-- hangs
4.open a new terminal and run gdb sync <pid> <- hangs too
5.kill fusermount
6.sync terminates.  

Actual Results:  
The computer hangs after a fs sync on init 6
(sync command, umount, etc.)

Expected Results:  
assumption: fusermount should release locks

Magic keys sysrq command i, u and b have worked as expected.


sys-fs/fuse-2.7.2
gnome-base/gvfs-0.2.3
sys-apps/coreutils-6.10-r1
sys-libs/glibc-2.7-r2

Linux gentoo 2.6.25-rc8-git7 #2 SMP PREEMPT Fri Apr 11 00:36:36 CEST 2008 x86_64 AMD Phenom(tm) 9500 Quad-Core Processor AuthenticAMD GNU/Linux
Comment 1 Vlastimil Babka (Caster) (RETIRED) gentoo-dev 2008-04-18 11:14:38 UTC
Please post emerge --info. Also is fuse module built from kernel or the fuse package? Any difference with gentoo-sources-2.6.24, 2.6.25 (final) or fuse-2.7.3 (if you copy the 2.7.2 ebuild locally) ?
Comment 2 Jimmy.Jazz 2008-04-19 21:58:51 UTC
(In reply to comment #1)
> Please post emerge --info. Also is fuse module built from kernel or the fuse
> package? Any difference with gentoo-sources-2.6.24, 2.6.25 (final) or
> fuse-2.7.3 (if you copy the 2.7.2 ebuild locally) ?
> 

fuse is built from the kernel. I made the test with 2.6.25 rc 8 and 9 vanilla sources. I will make more test with 2.6.25 final tomorrow. 

Dirvish (rsync) also fails to read /home/<username>/.gvfs and fusermount is not killed when the user leaves the gnome session.

Too bad, I'm now upgrading gentoo. So emerge --info won't be of any help. Please look at bug http://bugs.gentoo.org/show_bug.cgi?id=217644#c7 . I sent two emerge --info that were current when i made the test. Both computers have the same problem.

I will try with fuse 2.7.3.
Comment 3 Jimmy.Jazz 2008-04-22 16:17:24 UTC
(In reply to comment #1)
> Please post emerge --info. Also is fuse module built from kernel or the fuse
> package? Any difference with gentoo-sources-2.6.24, 2.6.25 (final) or
> fuse-2.7.3 (if you copy the 2.7.2 ebuild locally) ?
> 
Same problem with fuse 2.7.3 and I was unable to install fuse kernel module. 

make -C /usr/src/linux-2.6.25 SUBDIRS=`pwd`  modules
make[1]: entrant dans le répertoire « /usr/src/linux-2.6.25 »
  CC [M]  /var/tmp/portage/sys-fs/fuse-2.7.3/work/fuse-2.7.3/kernel/dev.o
  CC [M]  /var/tmp/portage/sys-fs/fuse-2.7.3/work/fuse-2.7.3/kernel/dir.o
  CC [M]  /var/tmp/portage/sys-fs/fuse-2.7.3/work/fuse-2.7.3/kernel/file.o
  CC [M]  /var/tmp/portage/sys-fs/fuse-2.7.3/work/fuse-2.7.3/kernel/inode.o
/var/tmp/portage/sys-fs/fuse-2.7.3/work/fuse-2.7.3/kernel/inode.c:693: erreur: unknown field ‘read_inode’ specified in initializer
/var/tmp/portage/sys-fs/fuse-2.7.3/work/fuse-2.7.3/kernel/inode.c:948: erreur: expected ‘)’ before ‘(’ token
/var/tmp/portage/sys-fs/fuse-2.7.3/work/fuse-2.7.3/kernel/inode.c:950: erreur: expected ‘)’ before ‘(’ token
/var/tmp/portage/sys-fs/fuse-2.7.3/work/fuse-2.7.3/kernel/inode.c:951: erreur: expected ‘)’ before ‘(’ token
/var/tmp/portage/sys-fs/fuse-2.7.3/work/fuse-2.7.3/kernel/inode.c: In function ‘fuse_sysfs_init’:
/var/tmp/portage/sys-fs/fuse-2.7.3/work/fuse-2.7.3/kernel/inode.c:1019: erreur: implicit declaration of function ‘subsystem_register’
/var/tmp/portage/sys-fs/fuse-2.7.3/work/fuse-2.7.3/kernel/inode.c:1019: erreur: ‘fs_subsys’ undeclared (first use in this function)
/var/tmp/portage/sys-fs/fuse-2.7.3/work/fuse-2.7.3/kernel/inode.c:1019: erreur: (Each undeclared identifier is reported only once
/var/tmp/portage/sys-fs/fuse-2.7.3/work/fuse-2.7.3/kernel/inode.c:1019: erreur: for each function it appears in.)
/var/tmp/portage/sys-fs/fuse-2.7.3/work/fuse-2.7.3/kernel/inode.c:1024: erreur: implicit declaration of function ‘kobj_set_kset_s’
/var/tmp/portage/sys-fs/fuse-2.7.3/work/fuse-2.7.3/kernel/inode.c:1024: erreur: ‘fuse_subsys’ undeclared (first use in this function)
/var/tmp/portage/sys-fs/fuse-2.7.3/work/fuse-2.7.3/kernel/inode.c:1033: erreur: ‘connections_subsys’ undeclared (first use in this function)
/var/tmp/portage/sys-fs/fuse-2.7.3/work/fuse-2.7.3/kernel/inode.c:1044: erreur: implicit declaration of function ‘subsystem_unregister’
/var/tmp/portage/sys-fs/fuse-2.7.3/work/fuse-2.7.3/kernel/inode.c: In function ‘fuse_sysfs_cleanup’:
/var/tmp/portage/sys-fs/fuse-2.7.3/work/fuse-2.7.3/kernel/inode.c:1054: erreur: ‘connections_subsys’ undeclared (first use in this function)
/var/tmp/portage/sys-fs/fuse-2.7.3/work/fuse-2.7.3/kernel/inode.c:1055: erreur: ‘fuse_subsys’ undeclared (first use in this function)
/var/tmp/portage/sys-fs/fuse-2.7.3/work/fuse-2.7.3/kernel/inode.c:1057: erreur: ‘fs_subsys’ undeclared (first use in this function)
make[2]: *** [/var/tmp/portage/sys-fs/fuse-2.7.3/work/fuse-2.7.3/kernel/inode.o] Erreur 1
make[1]: *** [_module_/var/tmp/portage/sys-fs/fuse-2.7.3/work/fuse-2.7.3/kernel] Erreur 2
make[1]: quittant le répertoire « /usr/src/linux-2.6.25 »
make: *** [all-spec] Erreur 2

It does not detect sysfs correctly.
Comment 4 Jimmy.Jazz 2008-04-22 16:21:20 UTC
Created attachment 150605 [details]
fuse config.log
Comment 5 Jimmy.Jazz 2008-04-22 16:23:13 UTC
Created attachment 150606 [details]
emerge --info
Comment 6 Rémi Cardona gentoo-dev 2008-08-25 09:39:05 UTC
"sync" works for me with gvfs-0.2.5-r2 and fuse-2.7.3 on a ~amd64 system.

Please don't hesitate to reopen this bug with updated information if the issue is still there.

Thanks
Comment 7 Jimmy.Jazz 2008-08-26 10:14:33 UTC
(In reply to comment #6)
> "sync" works for me with gvfs-0.2.5-r2 and fuse-2.7.3 on a ~amd64 system.
> 
It works thx
Comment 8 Rémi Cardona gentoo-dev 2008-08-26 12:10:26 UTC
Great, thanks for the follow up.